SYSTEM ADMINISTRATOR GUIDE     15/1543-CRA 119 1170/1-V1 Uen A    

Configuring Link Aggregation

© Copyright Ericsson AB 2009. All rights reserved.

Disclaimer

No part of this document may be reproduced in any form without the written permission of the copyright owner. The contents of this document are subject to revision without notice due to continued progress in methodology, design and manufacturing. Ericsson shall have no liability for any error or damage of any kind resulting from the use of this document.

Trademark List

SmartEdge is a registered trademark of Telefonaktiebolaget L M Ericsson.
NetOp is a trademark of Telefonaktiebolaget L M Ericsson.

Contents

1Overview
1.1MLPPP in This Document
1.2MLPPP in Other Documents
1.3MFR
1.4IEEE 802.3ad Link Groups for FE and GE Ports
1.5HDLC IEEE 802.3ad Link Groups for POS OC-3 and OC-12 Ports
1.6Load Balancing and Load Distribution
1.7Supported Link Aggregation Standards and Recommendations
1.8Related Information

2

Configurations and Operations Tasks and Examples
2.1Configuring an MLPPP Bundle
2.2Configuring an MFR Bundle
2.3Configuring an Ethernet Link Group
2.4Configuring an 802.1Q Link Group
2.5Configuring an Access Link Group
2.6Configuring an HDLC Link Group for OC-3 and OC-12 Ports
2.7Link Group Operations
2.8Bridged Link Groups Examples
2.9Multichassis Link Aggregation Example


1   Overview

This document describes how to configure, monitor, and administer the following types of link aggregation: Multilink PPP (MLPPP) and Multilink Frame Relay (MFR) and Ethernet media link groups. The terms MLPPP bundle and MFR bundle refer to link-aggregated PPP- and Frame Relay-encapsulated DS-1 channels or E1 channels or ports, respectively. The term link group refers to link-aggregated FE or GE ports with IP over Ethernet (IPoE), Point-to-Point Protocol (PPP) over Ethernet (PPPoE), or 802.1Q encapsulation and link-aggregated ports and channels. The term standby link describes a port in the link group bundle that currently is not carrying traffic but stands by ready to carry traffic if any of the active ports fail.

Link aggregation, whether as a link group, MLPPP bundle, or MFR bundle, provides increased bandwidth and availability. When a number of ports (or channels) are bundled in a link group, the failure or replacement of one link in the bundle does not cause the link group to be taken down because the other links take on the traffic of the one that is out of service. Increased bandwidth is a result of load balancing and load distribution over the ports in the link group.

The term link group as used in this document is synonymous with link aggregation group (LAG).

1.1   MLPPP in This Document

The configuration for MLPPP for PPP-encapsulated DS-1 channels, E1 channels, POS ports, and E1 ports is described in the section Configure an MLPPP Bundle. MLPPP is an extension to PPP that allows a router, such as the SmartEdge router, to use more than one physical link for communication.

MLPPP in this form is often used to provide bandwidth increments between DS-1 channels and DS-3 channels or DS-3 ports, in areas where DS-3 channels or ports are unavailable, or the required bandwidth does not justify the cost of a DS-3 channel or port. For example, four DS-1 channels can be linked together using the MLPPP to provide an aggregate connection of 6 Mbps:

1.1.1   Load Balancing

When using more than one physical link to connect two routers, MLPPP provides a mechanism to load balance the connection across all links in the bundle. Both ends of point-to-point links must be capable of supporting MLPPP connections. The two routers configure the data link by swapping Link Control Protocol (LCP) packets during a link establishment phase. If MLPPP is not successfully negotiated, the connection is not established and an error is logged.

The traffic load on a circuit in an MLPPP bundle is distributed packet by packet in a round-robin over the multiple links in the link bundle.

For a complete discussion of load balancing, see Load Balancing.

1.2   MLPPP in Other Documents

MLPPP of the following types are described in Configuring PPP and PPPoE:

1.3   MFR

The SmartEdge router supports MFR, which allow Frame Relay-encapsulated DS-1 channels, clear-channel E1 channels, or clear-channel E1 ports to be aggregated. MFR bundles comply with FRF.16.1, Multilink Frame Relay UNI/NNI Implementation Agreement, which defines the connections between data terminal equipment (DTE) and data communications equipment (DCE) endpoints or between DCE endpoints.

The traffic load on a circuit in an MFR bundle is distributed packet by packet in a round-robin over the multiple links in the link bundle.

The configuration for MFR is described in the section, Configure an MFR Bundle.

1.4   IEEE 802.3ad Link Groups for FE and GE Ports

The SmartEdge router supports the aggregation of FE or GE ports into a single, larger logical pipe, as specified in Part 3 of the IEEE 802.3ad 2000 specification, Carrier sense multiple access with collision detection (CSMA/CD) access method and physical layer specifications. The SmartEdge router supports 802.3ad Link Groups with IPoE, PPPoE, and 802.1Q encapsulation.

The following table defines terminology used in this section.

Table 1    Terminology in this Section

Term

Definition

Ethernet link group

A network-facing link group that bundles IPoE-encapsulated circuits. Specified in Part 3 of the IEEE 802.3ad 2000 specification, Carrier sense multiple access with collision detection (CSMA/CD) access method and physical layer specifications

802.1Q link group

A network-facing link group that bundles 802.1Q-encapsulated circuits; in other words, 802.1Q PVCs. Specified in Part 3 of the IEEE 802.3ad 2000 specification, Carrier sense multiple access with collision detection (CSMA/CD) access method and physical layer specifications.

Access link group

A subscriber-facing link group that bundles either PPPoE or 802.1Q single- or double-encapsulated (Q-in-Q) circuits. Access link groups support untagged traffic, single-tagged VLAN traffic, and double-tagged VLAN traffic. Specified in Part 3 of the IEEE 802.3ad 2000 specification, Carrier sense multiple access with collision detection (CSMA/CD) access method and physical layer specifications.

outer VLAN

A VLAN inside which multiple VLANs have been configured. The inner VLANs are double-tagged 802.1Q PVCs; that is, the outer VLAN is given an ID and each of the inner VLANs is given its own ID.

inner VLAN

An 802.1Q PVC inside an outer VLAN.

Q-in-Q

A configuration consisting of an 802.1Q tunnel containing one or more single-tagged VLANs.

802.1Q PVC

802.1Q PVCs are also referred to as VLANs.

VLAN

A virtual LAN. Also referred to as an 802.1Q PVC. Optionally, the VLAN can be an inner VLAN.

A VLAN is a separate, administratively defined, subgroup of a bridged LAN. Bridged LANs and 802.1Q encapsulation are described in the 802.1Q IEEE Standard for Local and Metropolitan Area Networks: Virtual Bridged Local Area Networks specification, which defines an architecture and bridging protocols for the partitioning of a bridged LAN into VLANs.

Three types of non-MLPPP link groups for FE and GE ports are supported by the SmartEdge router. An overview of each follow:

Figure 1 shows a typical application of bridged link groups:

Figure 1   Typical Application of Bridged Link Groups

1.5   HDLC IEEE 802.3ad Link Groups for POS OC-3 and OC-12 Ports

Link groups can be formed by the aggregation of High-Level Data Link Control (HDLC) encapsulated Packet over SONET/SDH (POS) ports on the following traffic cards:

The following restrictions apply:

HDLC link groups support the following protocols:

The following protocols are not supported:

1.6   Load Balancing and Load Distribution

For information on load balancing and load distribution, see Load Balancing.

1.7   Supported Link Aggregation Standards and Recommendations

The SmartEdge router supports the following link aggregation recommendations and standards:

1.8   Related Information

Other documents with related tasks and commands include:

2   Configurations and Operations Tasks and Examples

This section provides tasks and examples for configuring and operating link aggregation.

Note:  
Unless otherwise noted, the SmartEdge 100 router supports all commands described in this document.

2.1   Configuring an MLPPP Bundle

To configure an MLPPP bundle, perform the tasks in the following sections.

2.1.1   Configure an MLPPP Bundle

All DS-1 channels, E1 channels, POS ports, or E1 ports in an MLPPP bundle must be configured on the same traffic card, must have identical configurations, and must have PPP encapsulation. Fragmentation and reassembly are not supported in this release; the default maximum received reconstructed unit (MRRU) is set to 1,524 bytes. MRRU is configured by the mp mrru command. Fragmentation must be disabled at the remote peer.

To configure an MLPPP bundle for PPP-encapsulated DS-1 channels, E1 channels, POS ports, or E1 ports, perform the tasks described in Table 2.

Table 2    Configure an MLPPP Bundle

Step

Task

Root Command

Notes

1.

Specify the context and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the MLPPP bundle and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the MLPPP bundle.

ip address (interface)

Enter this command in interface configuration mode.

4.

Create an empty MLPPP bundle for PPP-encapsulated DS-1 channels, E1 channels, or E1 ports.

link-group

Enter this command in global configuration mode.

Specify the mp keyword.

Enter this command for each port or channel added to the link group. Enter the command in port configuration mode.

5.

Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

 

6.

Specify the type of endpoint discriminator to be used for negotiation with an MLPPP bundle.

mp endpoint-discriminator

The default value is the system host-name.

7.

Sets the MRRU to be used for negotiation with an MLPPP bundle.

mp mrru

 

8.

Bind the MLPPP bundle to the interface.

bind interface

 
Note:  
An MLPPP bundle is always enabled (operational). The shutdown command is not available in link group configuration mode for MLPPP bundles.

2.1.2   Add DS-1 Channels, E1 Channels, POS Ports, or E1 Ports to an MLPPP Bundle

You configure the constituent DS-1 channels, E1 channels, POS ports, or E1 ports for an MLPPP bundle as described in Configuring Channels and Clear-Channel and Channelized Ports but with these restrictions:

To configure and add a DS-1 channel, E1 channel, POS port, or E1 port to an MLPPP bundle, perform the task described in Table 3. For DS-1 channels, E1 channels, or E1 ports, enter this command in DS-1 or E1 configuration mode. For POS ports, enter this command in POS port configuration mode.

Table 3    Configure and Add DS-1 Channels, E1 Channels, or E1 Ports to an MLPPP Bundle

Task

Root Command

Notes

Add a constituent DS-1 channel, E1 channel, or E1 port to an MLPPP bundle.

link-group

 
Note:  
See the link-group command for the maximum number of ports or channels that can be included in a link group bundle.

2.1.3   MLPPP Bundle Example

This section provides a sample configuration of an MLPPP bundle.

The following example shows how to create an interface, multi, in the local context, assigns an IP address to it, creates an MLPPP bundle, lg-multi, specifies the IP address of the interface as the endpoint discriminator and binds the bundle to the interface; then, the example shows how to configure two DS-1 channels with PPP encapsulation and includes them in the bundle

Create the MLPPP bundle interface and assign an IP address to it:

[local]Redback(config)#context local
[local]Redback(config-ctx)#interface multi
[local]Redback(config-if)#ip address 172.16.1.1/30
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#exit

Create an MLPPP bundle and bind it to an interface:

[local]Redback(config)#link-group lg-multi mp
[local]Redback(config-link-group)#mp endpoint-discriminator ip
[local]Redback(config-link-group)#bind interface multi local
[local]Redback(config-link-group)#exit

Configure a DS-1 channel on DS-3 port 1 and add it to the bundle:

[local]Redback(config)#port channelized-ds3 1/1
[local]Redback(config-ds3)#no shutdown
[local]Redback(config-ds3)#exit
[local]Redback(config)#port ds1 1/1:1
[local]Redback(config-ds1)#encapsulation ppp
[local]Redback(config-ds1)#no shutdown
[local]Redback(config-ds1)#link-group lg-multi
[local]Redback(config-ds1)#exit

Configure a DS-1 channel on DS-3 port 2 and add it to the bundle:

[local]Redback(config)#port channelized-ds3 1/2
[local]Redback(config-ds3)#no shutdown
[local]Redback(config-ds3)#exit
[local]Redback(config)#port ds1 1/2:1
[local]Redback(config-ds1)#encapsulation ppp
[local]Redback(config-ds1)#no shutdown
[local]Redback(config-ds1)#link-group lg-multi
[local]Redback(config-ds1)#exit

2.2   Configuring an MFR Bundle

2.2.1   Configure an MFR Bundle

All DS-1 channels, E1 channels, or E1 ports in an MFR bundle must be configured on the same traffic card, must have identical configurations and have Frame Relay encapsulation. MFR bundles can include DS-1 channels, E1 channels, or E1 ports. Fragmentation and reassembly as described in FRF.12, Frame Relay Fragmentation Agreement, are not supported in this release. Fragmentation must be disabled at the remote peer.

The number of MFR bundles that you can configure with DS-1 channels or E1 channels or ports on a card and the Frame Relay PVCs in those bundles is restricted in this release. The maximum number of MFR bundles and Frame Relay PVCs must be less than 164 per card according to the following formula:

3 x MFR bundles + MFR PVCs £ 164

For Frame Relay to operate, you must configure the Local Management Interface (LMI) type and the Frame Relay LMI.

Note:  
The LMI is for the MFR bundle.

To configure an MFR bundle, perform the tasks described in Table 4.

Table 4    Configure an MFR Bundle

Step

Task

Root Command

Notes

1.

Create an empty MFR bundle for DS-1 channels or E1 channels or ports with Frame Relay encapsulation.

link-group

Enter this command in global configuration mode.

Specify the mfr keyword.

2.

Specify the interface type.

frame-relay intf-type

Enter this command in link group configuration mode.

The default value is DTE.

3.

Specify the Frame Relay LMI type.

frame-relay lmi-type

 

4.

Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

 

5.

Enable the automatic detection of the LMI type.

frame-relay auto-detect

This is the default condition; use the no form to disable automatic detection.

6.

Specify attributes for a DCE interface:

 

- Specify the interval for the polling verification timer.

frame-relay lmi-t392dce

 
 

- Specify the error threshold before LMI is considered to have failed.

frame-relay lmi-n392dce

 
 

- Specify the monitored event count.

frame-relay lmi-n393dce

 

7.

Specify attributes for a DTE interface:

 

- Specify the number of keepalive messages sent before the status message request is sent.

frame-relay lmi-n391dte

 
 

- Specify the interval for the polling verification timer.

frame-relay lmi-n392dte

 
 

- Specify the monitored event count.

frame-relay lmi-n393dte

 
 

- Enable the keepalive function and specify the interval value.

frame-relay keepalive

By default, the keepalive function is enabled, with a 10-second interval.

8.

Disable the MFR bundle.

shutdown (PVC)

By default, the MFR bundle is enabled (operational).

2.2.2   Configure an Aggregated Frame Relay PVC

You create an aggregated Frame Relay PVC to represent the PVCs with the same Data Link Connection Identifier (DLCI) on the DS-1 channels, E1 channels, or E1 ports that you intend to add to the MFR bundle. To configure an aggregated Frame Relay PVC, perform the tasks described in Table 5.

Table 5    Configure an Aggregated Frame Relay PVC

Step

Task

Root Command

Notes

1.

Specify the context for the aggregated Frame Relay PVC and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the PVC and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the PVC.

ip address (interface)

Enter this command in interface configuration mode.

4.

Select an existing MFR bundle.

link-group

Enter this command in global configuration mode.

5.

Create or select a Frame Relay PVC and access the Frame Relay PVC configuration mode.

frame-relay pvc

Enter this command in link group configuration mode.

6.

Bind the Frame Relay PVC to the interface created in step 2.

bind interface

 

7.

Disable the PVC (stop operations on it) until you are ready to begin operations on it.

shutdown (PVC)

By default, all circuits are enabled (operational).

2.2.3   Add DS-1 Channels, E1 Channels, or E1 Ports to the MFR Bundle

You configure a constituent DS-1 channel, E1 channel, or E1 port with its Frame Relay encapsulation as described in Configuring Channels and Clear-Channel and Channelized Ports, but with these restrictions:

To configure and add a constituent DS-1 channel, E1 channel, or E1 port to an MFR bundle, perform the additional tasks described in Table 6.

Table 6    Configure and Add DS-1 or E1 Channels or E1 Ports to an MFR Bundle

Step

Task

Root Command

Notes

1.

Add a DS-1 channel, E1 channel, or E1 port with Frame Relay encapsulation to the MFR bundle.

link-group

Enter this command in DS-1 or E1 configuration mode.

2.

Specify timing values for FRF.16 Hello and acknowledgement messages.

frame-relay multilink

Enter this command multiple times to specify each parameter.

Note:  
Adding a DS-1 channel, E1 channel, or E1 port to the MFR bundle creates a PVC on that channel or port for each aggregated Frame Relay PVC that you have created.


 Caution! 
Risk of data loss. Adding a DS-1 channel, E1 channel, or E1 port to an MFR bundle, deletes any Frame Relay PVCs that you have created on it. To reduce the risk, do not create Frame Relay PVCs on any DS-1 channel, E1 channel, or E1 port that you intend to add to an MFR bundle.
Note:  
If you remove a constituent DS-1 channel, E1 channel, or E1 port from an MFR bundle, either directly with the no link-group command (in DS-1 or E1 configuration mode), or indirectly by deleting the link group with the no link-group command (in global configuration mode), you cannot use the channel as an single-link channel; you can only add it to another link group. To use the channel as a single-link channel, you must first remove it from the configuration, by using the no port ds1 command (in DS-1 configuration mode) or the no port e1 command (in E1 configuration mode), and then reconfigure it.

2.2.4   MFR Bundle Example

This section provides an MFR bundle configuration sample.

The following example shows how to create an MFR bundle, lg-mfr, with a data terminal equipment (DTE) interface and an ITU Local Management Interface (LMI) type and disables it until ready to begin operations. It creates the interfaces, frpvc30 and frpvc40, in the local context for the aggregated Frame Relay PVCs and assigns an IP address to each one. Then it creates two aggregated Frame Relay PVCs and binds them to the frpvc30 and frpvc40 interfaces. Finally, the DS-1 channels are configured and added to the MFR bundle

Create the MFR bundle and configure the Frame Relay LMI:

[local]Redback(config)#link-group lg-mfr mfr
[local]Redback(config-link-group)#frame-relay intf-type dte
[local]Redback(config-link-group)#frame-relay lmi-type itu
[local]Redback(config-link-group)#frame-relay keepalive 6 
[local]Redback(config-link-group)#frame-relay lmi-n391dte 10
[local]Redback(config-link-group)#frame-relay lmi-n392dte 4
[local]Redback(config-link-group)#no shutdown
[local]Redback(config-link-group)#exit

Create the Frame Relay PVC interfaces; assign an IP address to each one:

[local]Redback(config)#context local
[local]Redback(config-ctx)#interface frpvc30
[local]Redback(config-if)#ip address 172.16.3.1/24
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#interface frpvc40
[local]Redback(config-if)#ip address 172.16.4.1/24
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#exit

Create Frame Relay PVC 30 and bind it to its interface:

[local]Redback(config)#link-group lg-mfr mfr
[local]Redback(config-link-group)#frame-relay pvc 30 
[local]Redback(config-link-pvc)#bind interface frpvc30 local
[local]Redback(config-link-pvc)#exit

Create Frame Relay PVC 40 and bind it to its interface:

[local]Redback(config-link-group)#frame-relay pvc 40
[local]Redback(config-link-pvc)#bind interface frpvc40 local
[local]Redback(config-link-pvc)#exit
[local]Redback(config-link-group)#exit
[local]Redback(config-config)#

Configure a DS-1 channel on DS-3 port 3 and add it to the bundle:

[local]Redback(config)#port channelized-ds3 1/3
[local]Redback(config-ds3)#no shutdown
[local]Redback(config-ds3)#exit
[local]Redback(config)#port ds1 1/3:1
[local]Redback(config-ds1)#encapsulation frame-relay
[local]Redback(config-ds1)#no shutdown
[local]Redback(config-ds1)#link-group lg-mfr
[local]Redback(config-ds1)#frame-relay multilink ack-timer 12
[local]Redback(config-ds1)#frame-relay multilink hello-interval 6
[local]Redback(config-ds1)#frame-relay multilink retries 3
[local]Redback(config-ds1)#exit

Configure a DS-1 channel on DS-3 port 4 and add it to the bundle:

[local]Redback(config)#port channelized-ds3 1/4
[local]Redback(config-ds3)#no shutdown
[local]Redback(config-ds3)#exit
[local]Redback(config)#port ds1 1/4:1
[local]Redback(config-ds1)#encapsulation frame-relay
[local]Redback(config-ds1)#no shutdown
[local]Redback(config-ds1)#link-group lg-mfr
[local]Redback(config-ds1)#frame-relay multilink ack-timer 12
[local]Redback(config-ds1)#frame-relay multilink hello-interval 6
[local]Redback(config-ds1)#frame-relay multilink retries 3
[local]Redback(config-ds1)#exit

2.3   Configuring an Ethernet Link Group

This section includes the following topics:

2.3.1   Configure an Ethernet Link Group

Ports in an Ethernet link group must be network-facing and IPoE-encapsulated and have identical configurations, but need not be configured on the same traffic card. You cannot mix FE ports with GE ports in the same link group. You cannot mix ports on different the types of GE traffic cards.

To configure an Ethernet link group, perform the tasks described in Table 7. Enter all commands in link group configuration mode, unless otherwise noted.

Table 7    Configure an Ethernet Link Group

Step

Task

Root Command

Notes

1.

Specify the context and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the link group and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the Ethernet link group.

ip address (interface)

This command applies only when the link group is not bound to a bridged interface.

Enter this command in interface configuration mode.

4.

Create an empty Ethernet link group.

link-group

Enter this command in global configuration mode. Specify the ether keyword.

5.

Enter the following commands ( step 6 through step 15) in link group configuration mode to set the parameters of the Ethernet link group:(1)

6.

Bind the link group to an interface.

bind interface

You can bind to an IP interface or to a bridged interface. To create bridged LAG ports, bind to a bridged interface.

7.

Specify the static MAC addresses.

bridge mac-entry

This command applies only when bound to a bridged interface.

Enter this command for the MAC address of each station known to be on this link group. The bridge dynamically learns the addresses of other stations as they connect to the link group.

8.

Assign a bridge profile.

bridge profile

This command applies only when bound to a bridged interface.

The default trunk bridge profile is assigned automatically if you do not enter this command.(2)

9.

Associate a description with the link group.

description (link group)

 

10.

Specify the forward output or policy

 

11.

Enable LACP for the link group.

lacp

For all practical link-group configurations, LACP must be enabled. You can turn off LACP for debugging purposes. Use the lacp command in link group configuration mode to enable LACP and set its parameters.

12.

Specify a MAC address for the link group.

mac-address (link group)

 

13.

Specify the maximum number of links that can be in the active state.

maximum-links

If the number of links (ports) in the link group bundle exceeds the maximum-links setting, those links are set in standby mode, should any of the active links fail.

The default is eight.

14.

Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

The default is one.

15.

Assign a spanning-tree profile.

spanning-tree profile

This command applies only when not bound to a bridged interface.

(1)  The rate circuit and qos commands are not supported for Ethernet link groups.

(2)  Supported only if the bridge is a trunk type. Not supported if the bridge is a tributary type.

Note:  
An Ethernet link group is always enabled (operational). The shutdown command is not available in link group configuration mode for Ethernet link groups.

2.3.2   Add an FE or a GE Port to an Ethernet Link Group

You configure the constituent FE or GE ports for a link group as described in Configuring ATM, Ethernet, and POS Ports but with these restrictions:

To add a constituent port to an Ethernet link group, perform the task in Table 8. Enter this command in port configuration mode.

Table 8    Add an FE or a GE Port to an Ethernet Link Group

Task

Root Command

Notes

Add an FE or a GE port to an Ethernet link group.

link-group

 

Each Ethernet link group is limited to eight ports. You cannot mix FE ports with GE ports in the same access link group or GE3, GE1020, or 10GE ports with any other type of GE ports. You can mix ports on FE traffic cards if the ports on the FE traffic cards are configured to run at 100 Mbps.

2.3.3   Ethernet Link Group Example

The following example shows how to create an interface, etherx, in the local context, assign an IP address to each one, create an Ethernet link group, lg-ether and bind it to the interface, etherx. Then the FE or GE ports are configured and added to the link group

Create the link group interface and assign an IP address to it:

[local]Redback(config)#context local
[local]Redback(config-ctx)#interface etherx
[local]Redback(config-if)#ip address 172.16.0.1/24
[local]Redback(config-if)#exit

Create the link group and bind it to its interface:

[local]Redback(config)#link-group lg-ether ether
[local]Redback(config-link-group)#bind interface etherx local

Configure an FE port and add it to the link group:

[local]Redback(config-config)#port ethernet 5/4
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#link-group lg-ether
[local]Redback(config-port)#exit

Configure another FE port and add it to the link group:

[local]Redback(config-config)#port ethernet 5/5
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#link-group lg-ether
[local]Redback(config-port)#exit

2.4   Configuring an 802.1Q Link Group

This section describes how to configure network-facing ports with 802.1Q encapsulation.

2.4.1   Configure an 802.1Q Link Group for 802.1Q-Encapsulated FE or GE Ports

Ports in an 802.1Q link group must be network facing and 802.1Q encapsulated and have identical configurations, but need not be configured on the same traffic card. You cannot mix FE ports with GE ports in the same link group. You cannot mix ports on different the types of GE traffic cards.

To configure an 802.1Q link group for 802.1Q-encapsulated FE or GE ports, perform the tasks described in Table 9. Enter all commands in link group configuration mode, unless otherwise noted.

Table 9    Configure an 802.1Q Link Group for 802.1Q-Encapsulated FE or GE Ports

Step

Task

Root Command

Notes

1.

Specify the context and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the link group and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the link group.

ip address (interface)

This command applies only when not bound to a bridged interface.

Enter this command in interface configuration mode.

4.

Create an empty 802.1Q link group.

link-group

Enter this command in global configuration mode. Specify the dot1q keyword.

5.

Enter the commands in step 6 through step 15 link group configuration mode to set the parameters of the 802.1Q link group.(1)

6.

Bind the link group to an interface.

bind interface

You can bind to an IP interface or a bridged interface. To create bridged LAG ports, bind to a bridged interface.

7.

Specify the static MAC addresses.

bridge mac-entry

This command applies only when bound to a bridged interface.

Enter this command for the MAC address of each station known to be on this link group. The bridge dynamically learns the addresses of other stations as they connect to the link group.

8.

Assign a bridge profile.

bridge profile

This command applies only when bound to a bridged interface.

The default trunk bridge profile is assigned automatically if you do not enter this command.

Supported only if the bridge is a trunk type. Not supported if the bridge is a tributary type.

9.

Associate a description with the link group.

description (link group)

 

10.

Specify the forward output or policy.

 

11.

Enable LACP for the link group.

lacp

For all practical link group configurations, LACP must be enabled. You can turn off LACP for debugging purposes. Use the lacp command in link group configuration mode to enable LACP and set its parameters.

12.

Specify a MAC address for the link group.

mac-address (link group)

 

13.

Specify the maximum number of links that can be in the active state.

maximum-links

If the number of links (ports) in the link group bundle exceeds the maximum-links setting, those links are set in standby mode, should any of the active links fail.

The default is eight.

14.

Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

The default is one.

15.

Assign a spanning-tree profile.

spanning-tree profile

This command applies only when bound to a bridged interface.

(1)  The rate circuit and qos commands are not supported for 802.1Q link groups.

Note:  
An 802.1Q link group is always enabled (operational). The shutdown command is not available in link group configuration mode for 802.1Q link groups.

2.4.2   Configure an Aggregated 802.1Q PVC in the 802.1Q Link Group

Ports in an 802.1Q link group must be 802.1Q encapsulated and have identical configurations, but need not be configured on the same traffic card. You cannot mix FE ports with GE ports in the same link group. You cannot mix ports on different the types of GE traffic cards.

For FE or GE ports configured with 802.1Q encapsulation, the 802.1Q PVCs and the untagged traffic on each port are referred to as the constituent PVCs. If the constituent PVCs are aggregated in a link group as separate logical pipes, they are referred to as aggregated PVCs.

You create an aggregated 802.1Q PVC to represent the PVCs with the same tag value on the FE or GE ports that you intend to add to the 802.1Q link group.

To configure an aggregated 802.1Q PVC in the 802.1Q link group, perform the tasks described in Table 10; enter all commands in link PVC configuration mode, unless otherwise noted.

Table 10    Configure an Aggregated 802.1Q PVC in the 802.1Q Link Group

Step

Task

Root Command

Notes

1.

Select an existing 802.1Q link group and access the link group configuration mode.

link-group

Enter this command in global configuration mode. Specify the dot1q keyword and the name of an existing 802.1Q link group.

2.

Enter the commands in step 3 through step 13 in link group configuration mode to set the parameters of the 802.1Q link group.(1)

3.

Specify the static MAC addresses.

bridge mac-entry

This command applies only when bound to a bridged interface.

Enter this command for the MAC address of each station known to be on this link group. The bridge dynamically learns the addresses of other stations as they connect to the link group.

4.

Assign a bridge profile.

bridge profile

This command applies only when bound to a bridged interface.

The default trunk bridge profile is assigned automatically if you do not enter this command.

Supported only if the bridge is a trunk type. Not supported if the bridge is a tributary type.

5.

Associate a description with the link group.

description (Dot1Q)

Enter this command in dot1q configuration mode.

6.

Assign a spanning-tree profile.

spanning-tree profile

This command applies only when bound to a bridged interface.

7.

Specify the forward output or policy

 

8.

Enable LACP for the link group.

lacp

For all practical link group configurations, LACP must be enabled. You can turn off LACP for debugging purposes. Use the lacp command in link group configuration mode to enable LACP and set its parameters.

9.

Specify a MAC address for the link group.

mac-address (link group)

 

10.

Specify the maximum number of links that can be in the active state.

maximum-links

If the number of links (ports) in the link group bundle exceeds the maximum-links setting, those links are set in standby mode, should any of the active links fail.

The default is eight.

11.

Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

The default is one.

12.

Create an aggregated 802.1Q PVC in the link group and access the link PVC configuration mode.

dot1q pvc

Multiple PVC can be created in the 802.1Q link group.

13.

Bind the aggregated 802.1Q PVC to its interface.

bind interface

Enter in link PVC configuration mode. Bind each PVC created in the previous step.

You can bind to an IP interface or a bridged interface. To create bridged LAG 802.1Q PVCs, bind to a bridged interface.(2)

(1)  The rate circuit and qos commands are not supported for 802.1Q link groups.

(2)  The SmartEdge router does not support binding an aggregated 802.1Q PVC in an 802.1Q link group to a bridged interface.

2.4.3   Add an FE or a GE Port to the 802.1Q Link Group

You configure the FE or GE ports for a link group as described in Configuring ATM, Ethernet, and POS Ports but with these restrictions:

To add a constituent port to an 802.1Q link group, perform the task described in Table 11. Enter this command in port configuration mode.

Table 11    Configure and Add an FE or a GE Port to the 802.1Q Link Group

Task

Root Command

Notes

Add an FE or a GE port to an 802.1Q link group.

link-group

 

Each 802.1Q link group is limited to eight ports. You cannot mix FE ports with GE ports in the same access link group or GE3, GE1020, or 10GE ports with any other type of GE ports. You can mix ports on FE traffic cards if the ports on the FE traffic cards are configured to run at 100 Mbps.

Note:  
Adding an FE or a GE port to the link group creates an 802.1Q PVC on that port for each aggregated 802.1Q PVC that you created.

2.4.4   802.1Q Link Group Aggregated PVCs Example

The following example shows how to create the interfaces, vlans, vlan10, and vlan20, in the local context, assigns an IP address to each one, creates an 802.1Q link group, lg-vlans and binds it to the vlans interface. Then, the example shows how to configure two 802.1Q PVCs and binds them to the vlan10 and vlan20 interfaces. Finally, the FE or GE ports are configured and added to the link group

Create the link group interface and assign an IP address to it:

[local]Redback(config)#context local
[local]Redback(config-ctx)#interface vlans
[local]Redback(config-if)#ip address 172.16.0.1/24
[local]Redback(config-if)#exit

Create the link group and bind it to its interface:

[local]Redback(config)#link-group lg-vlans dot1q
[local]Redback(config-link-group)#bind interface vlans local

Create the PVC interfaces and assign an IP address to each one:

[local]Redback(config)#context local
[local]Redback(config-ctx)#interface vlan10
[local]Redback(config-if)#ip address 172.16.1.1/24
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#interface vlan20
[local]Redback(config-if)#ip address 172.16.2.1/24
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#exit

Create PVC 10 and bind it to its interface:

[local]Redback(config)#link-group lg-vlans dot1q 
[local]Redback(config-link-group)#dot1q pvc 10 
[local]Redback(config-link-pvc)#bind interface vlan10 local
[local]Redback(config-link-pvc)#exit

Create PVC 20 and bind it to its interface:

[local]Redback(config-link-group)#dot1q pvc 20
[local]Redback(config-link-pvc)#bind interface vlan20 local
[local]Redback(config-link-pvc)#exit
[local]Redback(config-link-group)#exit

Configure another FE port and add it to the link group:

[local]Redback(config-config)#port ethernet 5/2
[local]Redback(config-port)#encapsulation dot1q
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#link-group lg-vlans
[local]Redback(config-port)#exit

Configure another FE port and add it to the link group:

[local]Redback(config-config)#port ethernet 5/3
[local]Redback(config-port)#encapsulation dot1q
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#link-group lg-vlans
[local]Redback(config-port)#exit

2.5   Configuring an Access Link Group

This section describes how to configure subscriber-facing ports with PPPoE or 802.1Q encapsulation.

2.5.1   Configuration Guidelines for Access Link Groups

Consider the following guidelines when configuring access link groups:

Table 12    Access Link Group Cross-Connections

Circuit Inside Access Link Group

Circuit Outside Access Link Group

802.1Q PVC

802.1Q PVC

802.1Q PVC inside an 802.1Q tunnel

802.1Q PVC inside an 802.1Q tunnel

802.1Q PVC

802.1Q PVC inside an 802.1Q tunnel

802.1Q PVC inside an 802.1Q tunnel

802.1Q PVC

802.1Q PVC

ATM RFC 1483 bridged PVC

802.1Q PVC inside an 802.1Q tunnel

ATM RFC 1483 bridged PVC

2.5.2   Configure an Access Link Group for FE or GE Ports

Use Table 13 to configure an access link group for FE or GE ports with no aggregated 802.1Q PVCs or tunnels. Use Table 15 to configure an access link group with aggregated 802.1Q PVCs or tunnels.

Table 13    Configure an Access Link Group for FE or GE Ports

Step

Task

Root Command

Notes

1.

Specify the context and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the link group and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the link group.

ip address (interface)

This command does not apply to bridge link groups.

Enter this command in interface configuration mode.

4.

Create an access link group.

link-group

Enter this command in global configuration mode. Specify the access keyword.

5.

Enable LACP for the link group.

lacp

For all practical link group configurations, LACP must be enabled. You can turn off LACP for debugging purposes. Use the lacp command in link group configuration mode to enable LACP and set its parameters.

6.

Configure the link group to operate in strict hierarchical mode.

qos hierarchical mode strict

Enter this command in link group configuration mode.

For access link group configurations on PPA2 (TM cards), QoS hierarchical mode strict is required.

7.

Use Table 14 to set the optional parameters of the link group.

   

8.

To bind the access link group, enter one of the following commands in link group configuration mode.

 

- Create a static binding to the interface.

bind interface

Applies if the link group encapsulation command is set to dot1q (802.1Q) or IPoE (the default).

You can bind to an IP interface or a bridged interface. To create bridged LAG ports, bind to a bridged interface.

 

- Create a dynamic binding to the interface.

bind authentication

Applies if the link group encapsulation command is set to pppoe.

You must specify a value greater than 1 for the max-ses argument.

 

- Create a static binding through a subscriber record to the interface.

bind subscriber

Applies if the link group encapsulation command is set to pppoe.

Note:  
An access link group is always enabled (operational). The shutdown command is not available in link group configuration mode for access link groups.

2.5.3   Configure the Optional Parameters of an Access Link Group for FE or GE Ports

Use Table 14 to configure the optional parameters of an access link group for FE or GE ports. Enter all commands in link group configuration mode unless otherwise noted.

Table 14    Configure the Optional Parameters of an Access Link Group for FE or GE Ports

Step

Task

Root Command

Notes

1.

Optional. Specify an encapsulation type for the link group.

encapsulation (link group mode)

The default encapsulation is IPoE.

2.

Optional. Specify the static MAC addresses.

bridge mac-entry

This command applies only when the link group is bound to a bridged interface.

Enter this command for the MAC address of each station known to be on this bridge. The bridge dynamically learns the addresses of other stations as they connect to the link group.

3.

Optional. Assign a bridge profile.

bridge profile

This command applies only to link groups bound to a bridged interface.

The default tributary bridge profile is assigned automatically if you do not enter this command.(1)

4.

Optional. Specify a text string description of the access link group.

description (link group)

This string is used as the prefix to the NAS-PORT-ID attribute in RADIUS if the command radius attribute nas-port-id format modified-agent-circuit-id prefix-lg-description has been entered. This step applies only to link group subscribers.

5.

Optional. Specify the forward output or policy.

 

6.

Optional. Enable L2VPN bindings on this link group.

l2vpn (ctx-name)

 

7.

Optional. Specify a MAC address for the link group.

mac-address (link group)

 

8.

Optional. Specify the maximum number of links that can be in the active state.

maximum-links

If the number of links (ports) in the link group bundle exceeds the maximum-links setting, those links are set in standby mode, should any of the active links fail.

The default is eight.

9.

Optional. Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

The default is one.

10.

Optional. Specify the algorithm by which the port for outgoing subscriber traffic is chosen.

protect-group

 

11.

Optional. Configure the optional QoS parameters of the 802.1Q PVC.

See the document, Configuring Circuits for QoS for use of the qos commands.

For access link group configurations on PPA2 (TM cards), QoS hierarchical mode strict is required.

12.

Optional. Configure a different rate for a circuit that has a QoS metering, policing, or priority weighted fair queuing (PWFQ) policy attached to it.

rate circuit

 

13.

Optional. Enable clientless IP service selection (CLIPS).

service clips dhcp , service clips (static)

See Configuring CLIPS for the full set of CLIPS configuration commands.

14.

Optional. Assign a spanning-tree profile.

spanning-tree profile

This command applies only when bound to a bridged interface.

(1)  Supported only if the bridge is a tributary type. Not supported if the bridge is a trunk type.

2.5.4   Configure an Access Link Group for Aggregated 802.1Q PVCs or 802.1Q Tunnels

Use Table 15 to configure an access link group with aggregated 802.1Q PVCs or tunnels. 802.1Q PVCs are also called VLANs. Use Table 13 to configure an access link group for FE or GE ports with no aggregated 802.1Q PVCs or tunnels.

Table 15    Configure an Access Link Group for Aggregated 802.1Q PVCs or 802.1Q Tunnels

Step

Task

Root Command

Notes

1.

Specify the context and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the link group and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the link group.

ip address (interface)

This command does not apply to bridge link groups.

Enter this command in interface configuration mode.

4.

Create an access link group.

link-group

Enter this command in global configuration mode. Specify the access keyword. See Table 18 for economical link groups.

5.

Enable LACP for the link group.

lacp

For all practical link group configurations, LACP must be enabled. You can turn off LACP for debugging purposes. Use the lacp command in link group configuration mode to enable LACP and set its parameters.

6.

Configure the link group for hierarchical mode strict.

qos hierarchical mode strict

Enter this command in link group configuration mode.

For access link group configurations on PPA2 (TM cards), QoS hierarchical mode strict is required.

7.

Specify 802.1Q encapsulation type for the link group.

encapsulation (link group mode)

Enter the encapsulation command with the dot1q keyword in link group configuration mode.

8.

Optional. Associate a description with the link group.

description (link group)

Enter this command in link group configuration mode.

9.

Optional. Specify the tunnel type for this link group. Applies only if configuring an 802.1Q tunnel in the next step.

dot1q tunnel

Enter this command in link group configuration mode.

10

Create an aggregated 802.1Q PVC or tunnel in the link group and access the link PVC configuration mode.

dot1q pvc

Enter this command in link group configuration mode:

  • To create an 802.1Q tunnel, enter this command with the encapsulation 1qtunnel keywords.

  • To create an aggregated 802.1Q PVC not in a tunnel, enter this command with no specified encapsulation or specify the multi, raw, or pppoe encapsulation.

  • To create an aggregated 802.1Q PVC within an 802.1Q tunnel, first create the tunnel. Next, exit dot1q PVC configuration mode to re-enter the link group configuration mode for this access link group ( step 4). Enter the dot1q PVC command with the tunl-vlan-id:start-vlan-id arguments.

11.

Use Table 16 to set the optional parameters of the aggregated 802.1Q PVC or 802.1Q tunnel.

12.

Bind the aggregated 802.1Q PVC with one of the following tasks.

Unless otherwise stated, enter these commands in link PVC configuration mode.

 

- Create a static binding to an interface.

bind interface

This binding is supported on PVCs with:

  • IPoE encapsulation (default)

  • Multiprotocol encapsulation

Enter this command only if you are not cross-connecting the PVC.

You can bind to an IP interface or a bridged interface. To create bridged aggregated 802.1Q PVCs, bind to a bridged interface.

The SmartEdge router does not support binding an aggregated 802.1Q PVC in an access link group to a bridged interface when the interface encapsulation is PPPoE or multibind.

 

- Create a restricted or an unrestricted dynamic binding.

bind authentication

This binding is supported on PVCs with PPPoE encapsulation.

You must specify the context to create a restricted dynamic binding.

This binding is also supported on child circuits in dot1q child protocol configuration mode, but it is not supported on ipv6oe child circuit encapsulation.

 

- Create a static binding through a subscriber record or records to an interface.

bind subscriber bind auto-subscriber

Enter either of these commands only if you are not cross-connecting the PVC.

This binding is supported on PVCs with:

  • IPoE encapsulation (default)

  • PPPoE encapsulation (bind subscriber command only)

  • Multiprotocol encapsulation

This binding is also supported on child circuits in dot1q child protocol configuration mode, but it is not supported on ipv6oe child circuit encapsulation. You must specify the context to create a restricted dynamic binding.

 

- Bind the PVC to a bypass for cross-connecting.

bind bypass

This binding is supported on all PVC encapsulations.

Enter this command only if you are cross-connecting the PVC and have no child circuits on it. If the PVC has child circuits, you can bind them to a bypass.

2.5.5   Configure the Optional Parameters of an Aggregated 802.1Q PVC (VLAN) of an Access Link Group

Use Table 16 to configure the optional parameters of an aggregated 802.1Q PVC of an access link group. Enter all commands in link PVC configuration mode unless otherwise noted.

Table 16    Configure the Optional Parameters of the Aggregated 802.1Q PVCs of an Access Link Group

Step

Task

Root Command

Notes

1.

Optional. Configure the access-line ID.

access-line access-node-id, access-line adjust, access-line agent-circuit-id, access-line rate,

 

2.

Optional. Specify the static MAC addresses.

bridge mac-entry

This command applies only when the aggregated 802.1Q PVC is bound to a bridged interface.

Enter this command for the MAC address of each station known to be on this bridge. The bridge dynamically learns the addresses of other stations as they connect to the bridge.

Not supported when the interface encapsulation is PPPoE or multibind.

3.

Optional. Assign a bridge profile.

bridge profile

This command applies only when bound to a bridged interface.

The default tributary bridge profile is assigned automatically if you do not enter this command.

Supported only if the bridge is a tributary type. Not supported if the bridge is a trunk type.

Not supported when the interface encapsulation is PPPoE or multibind.

4.

Optional. Create a child circuit on a multiprotocol 802.1Q PVC, specify an encapsulation for it, and enter dot1q child protocol configuration mode.

circuit protocol

Enter this command only if you have encapsulated the PVC by using the multi keyword in the dot1q pvc command.

5.

Create a binding for cross-connecting the child circuit created in the previous step.

bind bypass

Enter this command only if you are cross-connecting the child circuit.

6.

Optional. Specify that the PVCs in the link group being configured are members of the specified circuit group.

circuit-group-member

 

7.

Optional. Associate a description with the aggregated 802.1Q PVC or tunnel.

description (Dot1Q)

 

8.

Optional. Specify the forward output or policy.

 

9.

Optional. Enable a watchdog timer for PVCs created on demand.

idle-down

This command applies only to PVCs created by using the on-demand keyword.

10.

Optional Specify IP ACL filters, if any.

ip access-group (circuits)

 

11.

Optional. Associate the PVC with the IP address of the remote host on the circuit.

ip host (PVC)

Perform this task only for a PVC that you intend to bind directly to an interface.

You cannot perform this task if you have created the PVC as part of a range of PVCs.

12.

Optional. Enable L2VPN bindings on this PVC.

l2vpn (ctx-name)

 

13.

Optional. Specify a MAC address for the PVC.

mac-address (link group)

 

14.

Optional. Configure the optional QoS parameters of the 802.1Q PVC.

See the document, Configuring Circuits for QoS for use of the qos commands.

For access link group configurations on PPA2 (TM cards), QoS hierarchical mode strict is required.

15.

Optional. Configure a different rate for a circuit that has a QoS metering, policing, or priority weighted fair queuing (PWFQ) policy attached to it.

rate circuit

 

16.

Optional. Enable clientless IP service selection (CLIPS).

service clips (static) , service clips dhcp

See Configuring CLIPS for the CLIPS configuration commands.

17.

Optional. Assign a spanning-tree profile.

spanning-tree profile

This command applies only when bound to a bridged interface.

2.5.6   Add an FE or a GE Port to the Access Link Group

If the FE or GE ports are configured with 802.1Q encapsulation, the 802.1Q PVCs and the untagged traffic on each port, referred to as the constituent PVCs, are aggregated in separate logical pipes, referred to as aggregated PVCs.

You configure the FE or GE ports for an access link group as described in Configuring ATM, Ethernet, and POS Ports but with these restrictions:

To add a constituent FE or GE port to an access link group, perform the task described in Table 17. Enter this command in port configuration mode.

Table 17    Configure and Add an FE or a GE Port to the Access Link Group

Task

Root Command

Notes

Add an FE or a GE port to an existing access link group.

link-group

The number of ports you can add to an access link group depends on the type of port and is described in the reference page for this command.

Enter in port configuration mode.

You cannot mix FE ports with GE ports in the same access link group or GE3, GE1020, or 10GE ports with any other type of GE ports. You can mix ports on FE traffic cards if the ports on the FE traffic cards are configured to run at 100 Mbps.

Note:  
Adding an FE or a GE port to the link group creates an 802.1Q PVC on that port for each aggregated 802.1Q PVC that you created.

2.5.7   Configuring an Economical Access Link Group

To configuration economical hierarchical nodes in access link groups follow the steps in Table 18. This table does not describe other features of access link groups, but this information can be found in other tables in this section.

Table 18    Configuring an Economical Access Link Group

Step

Task

Root Command

Notes

1.

Create an economical access link group.

link-group

In global configuration mode, enter the link-group command with the access and economical keywords. For a description of the restrictions and uses of economical access link groups see the link-group command page.

2.

Enable LACP for the link group.

lacp

For all practical link group configurations, LACP must be enabled. You can turn off LACP for debugging purposes. Use the lacp command in link group configuration mode to enable LACP and set its parameters.

3.

Configure the link group for hierarchical mode strict.

qos hierarchical mode strict

Enter this command in link group configuration mode.

For access link group configurations on PPA2 (TM cards), QoS hierarchical mode strict is required.

4.

Optionally, create aggregated 802.1Q tunnel circuits and replicate their features on the active links in the bundle.

dot1q pvc

In link group configuration mode, enter the dot1q pvc command with the encapsulation 1qtunnel and replicate keywords.

The dot1q pvc command description contains important information on the restrictions and uses of the replicate keyword.

2.5.8   Example of Access Link Group with Aggregated On-Demand PVCs

The following example shows how to create an access link group‚ÄČthat aggregates two GE ports on a ge3-4-port traffic cards. On-demand PVCs are created for the link group as they are needed to support link redundancy:

[local]Redback#config
Enter configuration commands, one per line, 'end' to exit
[local]Redback(config)#link-group test1 access
[local]Redback(config-link-group)#encapsulation dot1q
[local]Redback(config-link-group)#dot1q pvc on-demand 10 through 19
[local]Redback(config-dot1q-pvc)#end
[local]Redback#config
Enter configuration commands, one per line, 'end' to exit
[local]Redback(config)#port ethernet 5/2
[local]Redback(config-port)#encapsulation dot1q
[local]Redback(config-port)#link-group test1
[local]Redback(config-port)#end
[local]Redback#config
Enter configuration commands, one per line, 'end' to exit
[local]Redback(config)#port ethernet 5/3
[local]Redback(config-port)#encapsulation dot1q
[local]Redback(config-port)#link-group test1
[local]Redback(config-port)#end

After configuring the test1 link group, use the show link-group... detail command to display the details of its configuration. Notice that the link group ID is 26. The SmartEdge router automatically sets the link group ID value as shown in the following:

[local]Redback#show link-group test1 detail
Link-Group: test1, ID   : 26, State : Down
------------------------------------------------------------------------------
Ccct count      : 2                              Grouping        : LoadShare
Card Type       : ether-12-port                  Type            : access

Bindings        : Unbound                        Minimum-links   : 1

Maximum-links   : 1                              Prot-Group-Type : round-robin
Internal Handle : 255/22:1:27/1/1/20
Description     :
Constituent Circuits:
 1. 5/2               (Down)|  0.00%
 2. 5/3               (Down)|  0.00%

2.5.9   Example of Aggregated 802.1Q Tunnel in a Cross Connected Access Link Group

The following example shows the creation of an aggregated 802.1Q tunnel configured in a cross connected access link group. An IP ACL filter is applied to the 802.1Q PVC in the tunnel:

[local]Redback(config)#link-group LGXC7 access
[local]Redback(config-link-group)#encapsulation dot1q
[local]Redback(config-link-group)#qos hierarchical mode strict
[local]Redback(config-link-group)#dot1q pvc 200 encapsulation 1qtunnel
[local]Redback(config-dot1q-pvc)#exit
[local]Redback(config-link-group)#dot1q pvc 200:1
[local]Redback(config-dot1q-pvc)#ip access-group ACL_1 context CTX_1 in count
[local]Redback(config-dot1q-pvc)#bind bypass
!
[local]Redback(config)#link-group LGXC8 access
[local]Redback(config-link-group)#encapsulation dot1q
[local]Redback(config-link-group)#qos hierarchical mode strict
[local]Redback(config-link-group)#dot1q pvc 200 encapsulation 1qtunnel
[local]Redback(config-dot1q-pvc)#exit
[local]Redback(config-link-group)#dot1q pvc 100:1
[local]Redback(config-dot1q-pvc)#bind bypass
!
[local]Redback(config)#port ethernet 11/2
local]Redback(config-port)#encapsulation dot1q
local]Redback(config-port)#link-group LGXC7
! Cannot add NON-TM card based port to an access link-group when qos hierarchical mode 
! strict is set
!
[local]Redback(config)#port ethernet 11/3
local]Redback(config-port)#encapsulation dot1q
local]Redback(config-port)#link-group LGXC8
! Cannot add NON-TM card based port to an access link-group when qos hierarchical mode 
! strict is set
!
[local]Redback(config)#xc-group xcg4
[local]Redback(config-xc-group)xc lg LGXC8 vlan-id 100:1 to lg LGXC7 vlan-id 200:1

2.5.10   Example of Economical Access Link Group

The following example shows the configuration of an economical access link group. In an economical access link group, replicas of the circuit features of active ports are not maintained on the standby ports; therefore, when an active port fails and its standby port becomes active, a small number of packets are lost in the transition. The economic behavior reduces the SmartEdge router resources used by the access link group, allowing more of these resources to become available to other applications. The replicate keyword applies to economical access link groups and specifies whether the circuit features of active ports are replicated on the other active ports as shown in the following:

[local]Redback(config)#link-group abc access economical
[local]Redback(config-link-group)#qos hierarchical mode strict
[local]Redback(config-link-group)#maximum-links 8
[local]Redback(config-link-group)#encapsulation dot1q
[local]Redback(config-link-group)#dot1q pvc 100 encapsulation 1qtunnel replicate
[local]Redback(config-dot1q-pvc)#qos policy queuing pwfq1
[local]Redback(config-dot1q-pvc)#dot1q pvc 100:1 encapsulation pppoe
[local]Redback(config-dot1q-pvc)#qos policy metering mymeter1 inherit
[local]Redback(config-dot1q-pvc)#qos rate maximum 300
[local]Redback(config-dot1q-pvc)#bind auth chap max 10

2.6   Configuring an HDLC Link Group for OC-3 and OC-12 Ports

This section contains the following:

2.6.1   Configuration Steps

To configure a link group for HDLC-encapsulated OC-3 or OC-12 ports, perform the tasks described in Table 19. Enter all commands in link group configuration mode, unless otherwise noted.

Table 19    Configure an HDLC Link Group

Step

Task

Root Command

Notes

1.

Specify the context and access the context configuration mode.

context

Enter this command in global configuration mode.

2.

Create an interface for the HDLC link group and access the interface configuration mode.

interface (context)

Enter this command in context configuration mode.

3.

Assign an IP address to the interface for the HDLC link group.

ip address (interface)

Enter this command in interface configuration mode.

4.

Create an empty HDLC link group.

link-group

Enter this command in global configuration mode. Specify the hdlc keyword.

5.

Optional. Specify the minimum number of links that should be in the up state for the link group to be active.

minimum-links

 

6.

Bind the HDLC link group to an interface.

bind interface

 

7.

Add POS ports to the HDLC link group.

link-group

Enter this command for each POS port added to the HDLC link group. Enter the command in port configuration mode.

2.6.2   HDLC Link Group Example

The following configuration shows how to bundle three POS ports to the lg1 link group and apply the QoS policing policy slow1 to each port. The link group lg1 is bound to the interface pos1 to which an access-list filter, named filter1, acts on inbound packets:

[local]Redback(config)#context local
[local]Redback(config-ctx)#ip access-list filter1

The following portion of this example shows the configuration of access-list:

!...
[local]Redback(config-ctx)#interface pos1
[local]Redback(config-if)#ip address 10.1.1.1/24
[local]Redback(config-if)#ip access-group filter1 in
[local]Redback(config-if)#end
!...
[local]Redback(config)#link-group lg1 hdlc
[local]Redback(config-link-group)#bind interface pos1 local
[local]Redback(config-link-group)#end
!...

Ports should be unchannelized POS and use HDLC encapsulation (defaults). OC-3 ports and OC-12 ports cannot be bundled together. A maximum of eight ports is allowed per link group:

[local]Redback(config)#port pos 11/2
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#qos policy policing slow1
[local]Redback(config-port)#link-group lg1
[local]Redback(config-link-group)#end
!...
[local]Redback(config)#port pos 12/1
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#qos policy policing slow1
[local]Redback(config-port)#link-group lg1
[local]Redback(config-link-group)#end
!...
[local]Redback(config)#port pos 12/2
[local]Redback(config-port)#no shutdown
[local]Redback(config-port)#qos policy policing slow1
[local]Redback(config-port)#link-group lg1
[local]Redback(config-link-group)#end

2.7   Link Group Operations

To monitor and troubleshoot link groups, perform the appropriate task listed in Table 20. Enter the debug commands in exec mode; enter the show commands in any mode.

Table 20    Link Group Operations

Task

Root Command

Enable the generation of debug messages for Frame Relay PVCs on DS-1 or E1 channels in an MFR bundle.

debug frame-relay frf16

Enable the generation of debug messages for link group events.

debug lg

Enable the generation of debug messages for MLPPP-related events.

debug ppp multilink

Display link groups, circuits, and bindings.

show link-group

Display LACP links on subscriber-facing Ethernet ports.

show lacp actor

Display the counters for all LACP links on the system.

show lacp counters

Display the LACP link group with a given identification number.

show lacp lg-id

Display LACP information for a link group with the specified name.

show lacp lg-name

Display the partner information for all the LACP circuits or the LACP circuit with a specified circuit handle.

show lacp partner

Display the counters for all LACP links on the system.

show lacp system-id

Display state and statistics information for one or all MLPPP bundles.

show ppp multilink

2.8   Bridged Link Groups Examples

In the following scenario, four link groups are created. Two network link groups, lg1 and lg3, are bound to the ac1 and ac3 interfaces, respectively. Two access link groups, lg2 and lg4, are bound to the ac2 and ac4 interfaces, respectively. The ac1 and ac2 interfaces are part of the SE1 bridge, while the ac3 and ac4 interfaces are part of the SE2 bridge.

Configure a network-facing bridge profile, bp1:

[local]Redback#config
Enter configuration commands, one per line, 'end' to exit
[local]Redback(config)#service multiple-service
[local]Redback(config)#bridge profile bp1
[local]Redback(config-bridge-profile)#trunk
[local]Redback(config-bridge-profile)#exit

Configure a subscriber-facing bridge profile, bp2:

[local]Redback(config)#bridge profile bp2
[local]Redback(config-bridge-profile)#mac-limit 10
[local]Redback(config-bridge-profile)#broadcast rate-limit 10 burst 333
[local]Redback(config-bridge-profile)#exit

Configure two bridge groups in the local context, bridgeSE1 and bridgeSE2:

[local]Redback(config)#context local
[local]Redback(config-ctx)#bridge bridgeSE1
[local]Redback(config-ctx)#exit
[local]Redback(config-ctx)#bridge bridgeSE2
[local]Redback(config-ctx)#exit

In the local context, configure four bridged interfaces named ac1, ac2, ac3, and ac4. Attach two interfaces to each bridge; specifically, attach ac1 and ac2 to bridgeSE1 bridge and attach ac3 and ac4 to bridgeSE2 bridge:

[local]Redback(config-ctx)#interface ac1 bridge
[local]Redback(config-if)#bridge name bridgeSE1
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#interface ac2 bridge
[local]Redback(config-if)#bridge name bridgeSE1
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#interface ac3 bridge
[local]Redback(config-if)#bridge name bridgeSE2
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#interface ac4 bridge
[local]Redback(config-if)#bridge name bridgeSE2
[local]Redback(config-if)#exit
[local]Redback(config-ctx)#exit

Configure lg1 as an Ethernet link group. Because Ethernet link groups must be network facing, lg1 is provisioned by bp1 (a network-facing bridge profile), and bound to ac1 (an interface to the bridgeSE1 bridge group:

[local]Redback(config)#link-group lg1 ether
[local]Redback(config-link-group)#bind interface ac1 local
[local]Redback(config-link-group)#bridge profile bp1
[local]Redback(config-bridge-profile)#exit

Configure lg2 as an access link group. Because access link groups must be subscriber facing, lg2 is provisioned by bp2 (a subscriber-facing bridge profile) and bound to ac2 (an interface to the bridgeSE1 bridge group). The bridgeSE1 bridge group has two interfaces, one that is network facing and the other that is subscriber facing:

[local]Redback(config)#link-group lg2 access
[local]Redback(config-link-group)#bind interface ac2 local
[local]Redback(config-link-group)#bridge profile bp2
[local]Redback(config-bridge-profile)#exit

Configure lg3 as an 802.1Q link group. Because 802.1Q link groups must be network facing, lg3 is provisioned by bp1 (a network-facing bridge profile), and bound to ac3 (an interface to the bridgeSE2 bridge group:

[local]Redback(config)#link-group lg3 dot1q
[local]Redback(config-link-group)#dot1q pvc 1
[local]Redback(config-link-pvc)#bind interface ac3 local
[local]Redback(config-link-pvc)#bridge profile bp1
[local]Redback(config-bridge-profile)#exit

Configure lg4 as an access link group. Because access link groups must be subscriber facing, lg4 is provisioned by bp2 (a subscriber-facing bridge profile) and bound to ac4 (an interface to the bridgeSE2 bridge group). The bridgeSE2 bridge group has two interfaces, one that is network facing and the other that is subscriber facing :

[local]Redback(config)#link-group lg4 access
[local]Redback(config-link-group)#encap dot1q
[local]Redback(config-link-group)#dot1q pvc 1
[local]Redback(config-dot1q-pvc)#bind interface ac4 local
[local]Redback(config-dot1q-pvc)#bridge profile bp2
[local]Redback(config-dot1q-pvc)#exit
[local]Redback(config-link-group)#exit

The following lines show the resulting configuration:

[local]Redback#show config link-group
Building configuration...

Current configuration:
!
link-group lg2 access
 bind interface ac2 local
!
link-group lg4 access
 encapsulation dot1q
 dot1q pvc 1
  bind interface ac4 local
!
link-group lg1 ether
 bind interface ac1 local
!
link-group lg3 dot1q
 dot1q pvc 1
   bind interface ac3 local
!
!
end
[local]Redback#show config interface
Building configuration...

Current configuration:
context local
!
 interface ac1 bridge
  bridge name bridgeSE1
!
 interface ac2 bridge
  bridge name bridgeSE1
!
 interface ac3 bridge
  bridge name bridgeSE2
!
 interface ac4 bridge
  bridge name bridgeSE2
!
 interface mgmt
  ip address 10.18.17.102/24
!

2.9   Multichassis Link Aggregation Example

This section provides an example of multichassis link aggregation, where two system share a common endpoint in a SmartEdge router. LACP manages the connections in an access link group bundle so that only one link to one satellite chassis is active at any time:

Figure 2   Multichassis Link Aggregation

The following example shows how to configure the preceding illustrated system. The first set of commands create and configure the access link group named LAG-1, which bundles the two links to the two external chassis:

[local]Redback(config)#system lacp priority 1
[local]Redback(config)#link-group LAG-1 access
[local]Redback(config-link-group)#bind interface LAG-1 local
[local]Redback(config-link-group)#mac-address auto
[local]Redback(config-link-group)#lacp active
[local]Redback(config-link-group)#lacp ignore-system-id
[local]Redback(config-link-group)#maximum-links 1

The second set of commands adds the SmartEdge port that interfaces to Switch A into the link group bundle:

[local]Redback(config)#port ethernet 2/6
[local]Redback(config-port)#link-group LAG-1
[local]Redback(config-link-group)#lacp priority 20

The third set of commands adds the SmartEdge port that interfaces to Switch B into the link group bundle:

[local]Redback(config)#port ethernet 3/6
[local]Redback(config-port)#link-group LAG-1
[local]Redback(config-link-group)#lacp priority 20

The following configuration guidelines apply to configuration of the multichassis access link groups: