SYSTEM ADMINISTRATOR GUIDE     18/1543-CRA 119 1170/1-V1 Uen A    

Configuring BGP

© Copyright Ericsson AB 2009. All rights reserved.

Disclaimer

No part of this document may be reproduced in any form without the written permission of the copyright owner. The contents of this document are subject to revision without notice due to continued progress in methodology, design and manufacturing. Ericsson shall have no liability for any error or damage of any kind resulting from the use of this document.

Trademark List

SmartEdge is a registered trademark of Telefonaktiebolaget L M Ericsson.
NetOp is a trademark of Telefonaktiebolaget L M Ericsson.

Contents

1Overview
1.1Introduction to iBGP and eBGP
1.2Introduction to iBGP Route Reflectors
1.3Introduction to iBGP Confederations
1.4Route Aggregation
1.5Next-Hop-Triggered BGP Best-Path Calculation
1.6MBGP
1.7Routing Policy Triggered Update
1.8Non-Intrusive MD5 Password Change

2

Configuration and Operations Tasks
2.1Configuring BGP Routing Instances and Instance Attributes
2.2Configuring BGP Neighbors and Neighbor Attributes
2.3Enabling IPv6 over an IPv4 MPLS Core
2.4Configuring BGP Peer Groups and Peer Group Attributes
2.5BGP Operations

3

Configuration Examples
3.1Example: Configure Basic BGP
3.2Example: Configure Next-Hop-Triggered BGP Best-Path Calculation
3.3Example: Configure iMBGP Peers
3.4Example: Configure an iMBGP Peer Group
3.5Example: Configure eMBGP Peers
3.6Example: Configure an eMBGP Peer Group
3.7Example: Configure IPv6 over an IPv4 Core


1   Overview

This document provides an overview of the Border Gateway Protocol (BGP) and describes the tasks and commands used to configure, monitor, troubleshoot, and administer BGP features through the SmartEdge® router.

BGP is an Exterior Gateway Protocol (EGP) based on distance-vector algorithms, and uses the Transmission Control Protocol (TCP) as its transport protocol. BGP is a protocol between exactly two BGP nodes, or BGP speakers. First, the TCP connection is established and then the two BGP speakers exchange dynamic routing information over the connection. The exchange of messages is a BGP session between BGP peers.

The SmartEdge router supports multiple BGP features, including those specified in the following IETF drafts and RFCs:

Redback Networks also supports the following additional features:

In-depth information on how BGP is structured, and how it operates, is described the sections that follow.

1.1   Introduction to iBGP and eBGP

Routers that belong to the same AS and exchange BGP updates are running iBGP, and routers that belong to different autonomous systems and exchange BGP updates are running eBGP.

Figure 1 illustrates the concept of autonomous systems and iBGP versus eBGP.

Figure 1   Autonomous Systems and iBGP Versus eBGP Networks

1.2   Introduction to iBGP Route Reflectors

Typically, iBGP speakers must be fully meshed. Any BGP speaker that receives messages from an external router must advertise the routes it receives to all BGP speakers in its autonomous system. However, if a route reflector is configured, although it must have connections to all other BGP speakers in the AS, not all other BGP speakers must be fully meshed. When a BGP speaker in the AS receives messages from an external router, it is sufficient to advertise these routes only to the route reflector, which then readvertises the routes to all other BGP speakers in the AS.

Internal peers of the route reflector are divided into two groups: client peers and nonclient peers. A route reflector reflects routes between these two groups. The route reflector and its client peers form a cluster. Nonclient peers must be fully meshed with each other. Client peers are not required to be fully meshed and do not communicate with BGP speakers outside their cluster. If it is required, peer client-to-peer client route reflection can be disabled.

When the route reflector receives an advertised route:

Figure 2 shows an example of iBGP networking using route reflection.

Figure 2   Example of an iBGP Network Using Route Reflection

1.3   Introduction to iBGP Confederations

Another way to reduce iBGP mesh is to divide an autonomous system into subautonomous systems grouped by a routing domain identifier. The AS and its subautonomous systems are part of the same confederation. Externally, the confederation looks like a single AS. Each subautonomous system is fully meshed within itself and has a few connections to other subautonomous systems in the confederation.

Neighbors from other subautonomous systems are treated as special eBGP peers. Even though peers in different subautonomous systems engage in eBGP sessions, they exchange routing information as if they were iBGP peers. Specifically, the next-hop, the Multi-Exit Discriminator (MED), and local preference information is preserved, so that a single Interior Gateway Protocol (IGP) is used for all of the subautonomous systems; see Figure 3.

Figure 3   Example of an iBGP Confederation

1.4   Route Aggregation

BGP4 supports Classless InterDomain Routing (CIDR). With CIDR, routers use the network prefix to determine the dividing point between the network number and the host number. For example, the range of addresses 128.186.1.0 to 128.186.1.255 can be represented as the network prefix 128.186.1.0/24; the 24 indicates that all addresses in the segment agree in their first 24 bits.

In addition, CIDR does not require a network to be of standard size, as is the case in classful addressing, which provides 8-bit (Class A), 16-bit (Class B), and 24-bit (Class C) network deployment. This flexibility in CIDR enables the creation of arbitrarily sized networks.

Of particular importance is CIDR’s ability to lend itself to the concept of route aggregation. The Internet is divided into addressing domains. Within a domain, detailed information is available about all of the networks that reside in the domain. Outside of an addressing domain, however, only the common network prefix is advertised. By allowing a single routing table entry to specify a route to many individual network addresses, aggregation minimizes the size of the routing table. A router cannot aggregate an address if it does not have a more specific route of that address in the BGP routing table. More-specific routes can be injected in the BGP routing table by incoming updates from other autonomous systems.

1.5   Next-Hop-Triggered BGP Best-Path Calculation

The SmartEdge router performs BGP best-path calculations periodically by scanning the RIB for changes in next hops. For intermittent next-hop moves, the SmartEdge router runs the best-path calculation immediately upon notification by the RIB and updates the RIB with the new next hop. In addition, this feature improves convergence time for BGP by triggering immediate best-path calculation for next-hop withdrawals. A back-off mechanism prevents unnecessary churn during network instability.

Use the following commands in IPv4 BGP address family configuration mode to configure next-hop-triggered BGP best-path calculation:

Note:  
Next-hop-triggered BGP best-path calculation is supported for the IPv4 BGP address family only.

The following commands show information related to BGP next-hop scanning:

1.6   MBGP

Multiprotocol BGP (MBGP) makes use of multiprotocol extensions to BGP4, as defined in RFC 2283, Multiprotocol Extensions for BGP-4, that allow other protocols to use BGP to exchange protocol-specific information.

One of the main advantages of MBGP is the ability to use BGP’s scalability and policy control, to easily configure routers to peer with other interdomain routers, exchange multicast source route information, and configure multicast routing policies using familiar BGP commands. MBGP also carries two sets of routes: one set for unicast routing and one set for multicast routing, allowing you to configure separate routing policies for unicast and multicast routes.

1.7   Routing Policy Triggered Update

Before Release 2.5, whenever there was a change in an inbound or outbound routing policy, such as a prefix-list, as-path-list, or route-map, for a BGP peer, the clear bgp neighbor ip-addr soft [in | out] command had to be manually issued to make the policy change effective. Currently, routing policy changes automatically take effect, and issuing the clear bgp neighbor ip-addr soft [in | out] command to update routing policies can cause updates to be unnecessarily sent, so it is not recommended.

To aggregate multiple policy changes, the operating system performs the necessary action 15 seconds after a policy change.


 Caution! 
Risk of dropped connection. If the remote peer does not support the BGP Route Refresh Capability, an inbound policy change for the peer results in an automatic hard reset of the session. To reduce the risk, ensure that the remote peer supports the BGP Route Refresh Capability.

1.8   Non-Intrusive MD5 Password Change

The non-intrusive Message Digest 5 (MD5) password change feature for BGP allows you to change the password for a BGP peer without resetting the BGP session. The sections that follow describe in detail how the non-intrusive MD5 password change feature is implemented.

1.8.1   Replace a Password

When an old MD5 password is replaced by a new one in a BGP peer configuration, both passwords are allowed to coexist for authentication until the old password expires. To facilitate a smooth transition from the old to new password, a new configuration can be used to specify the time interval during which the old MD5 password coexists with the new one.

For a TCP connection that is already established, or is in one of the closing states when an existing password is replaced by a new MD5 password, both password strings coexist for authentication during the specified time interval before the old MD5 password expires. The old MD5 password continues to be used for authentication until either the password expires, or the remote TCP for the peer uses a new MD5 password.

For a TCP connection that is not yet established, when the old password is replaced, the local TCP immediately uses the new MD5 password.

Note:  
BGP keeps only the latest password string configured and the previous password to be replaced. That is, if a third password is configured before the timer for first (active) password expires, the oldest password is immediately deleted, and the expiration timer is started for the second password.

1.8.2   Add a New Password

This feature does not apply when configuring a new MD5 password for a peer while there is no existing password already configured for the peer. The BGP peer session is reset after the new MD5 password is configured.

1.8.3   Delete a Password

This feature does not apply when explicitly deleting a MD5 password from the BGP peer configuration.

When the current active MD5 password is deleted from the configuration, the old password (if existing) and the current password are both immediately deleted, and the BGP session with the peer is reset.

Note:  
To avoid BGP sessions from being reset when changing a peer MD5 password, we recommend that you do not delete the password from the configuration, and always use the password command to implicitly replace the password.

2   Configuration and Operations Tasks

Note:  
In this section, the command syntax in the task tables displays only the root command.

To configure BGP, perform the tasks described in the sections that follow.

2.1   Configuring BGP Routing Instances and Instance Attributes

A BGP routing instance enables the SmartEdge router to be a BGP speaker. In addition, many BGP parameters that can affect the global routing process can be configured within a BGP routing instance.

To configure a BGP routing instance and other instance attributes, perform the tasks described in the sections that follow.

2.1.1   Create and Configure a BGP Routing Instance

To configure a BGP routing instance, perform the tasks described in Table 1.

Table 1    Configure a BGP Routing Instance

Task

Root Command

Notes

Create a BGP routing instance using an autonomous system number (ASN) and enter BGP router configuration mode.

router bgp

Enter this command in context configuration mode.

Allow the comparison of the Multi-Exit Discriminator (MED) for paths from BGP neighbors in different autonomous systems.

bestpath med always-compare

By default, the comparison of the MED is enabled for paths from BGP neighbors in the same autonomous system.

Specify a period of time that must pass before the BGP routing process drops sessions of directly connected external peers once the link used to reach them goes down.

fast-reset

By default, BGP sessions remain connected after the outbound interface goes down. BGP sessions are dropped after the BGP holdtime value, set through the timers command in BGP router configuration mode, is exceeded.

Configure the local preference attribute for the BGP routes.

local-preference

The local preference value is applied to BGP routes that do not have the local-preference attribute assigned to them.

Log BGP neighbor resets.

log-neighbor-changes

Configure the BGP routing process to use multiple equal-cost best paths for load-balancing outgoing traffic packets.

multi-paths

Configure a fixed BGP router ID.

router-id (BGP)

By default, the BGP router ID is the IP address of a loopback interface if one is configured. If a loopback interface is not configured, the interface with the highest IP address is used as the router ID. Peering sessions are reset when the router ID is changed.

Configure the time interval, in seconds, during which an old MD5 password can coexist with a new MD5 password for authentication.

timers password

Configuring the password timer interval affects only the BGP peers which have existing MD5 passwords replaced after this configuration is committed.

Modify keepalive and holdtime timers for all BGP neighbors.

timers keepalive

By default, the keepalive timer is set to 60 seconds and the holdtime value is set to 180 seconds.

Configure IPv4 multicast or unicast address family attributes.

For the complete list of tasks used to configure IPv4 address family attributes, see Configure IPv4 UNI or NNI Address Family Attributes for a BGP Routing Instance.

Configure IPv6 unicast address family attributes.

For the complete list of tasks used to configure IPv6 address family attributes, see Configure IPv6 Address Family Attributes for a BGP Routing Instance.

Configure the BGP graceful restart characteristics.

For the complete list of tasks used to configure BGP graceful restart, see Configure Graceful Restart for a BGP Routing Instance.

Configure BGP Route Reflection.

For the complete list of tasks used to configure BGP route reflection, see Configure BGP Route Reflection.

Configure BGP confederations.

For the complete list of tasks used to configure BGP confederations, see Configuring BGP Attribute-Based Accounting in Configuring Routing Policies.

2.1.2   Configure IPv4 UNI or NNI Address Family Attributes for a BGP Routing Instance

To configure the IPv4 address family attributes for a BGP routing instance, perform the tasks described in Table 2.

Table 2    Configure IPv4 Address Family Attributes for a BGP Routing Instance

Task

Root Command

Notes

Specify the use of standard IP Version 4 (IPv4) multicast or unicast address prefixes for the BGP routing instance, and access BGP address family configuration mode.

address-family ipv4 (Multicast and Unicast)

Enter this command in BGP router configuration mode.

Include the multicast keyword to specify a multicast address prefix, or the unicast keyword to specify a unicast address prefix.

Create an aggregate entry in the BGP database for the BGP address family.

aggregate-address

Enable eBGP route dampening for the specified BGP address family.

dampening

Configure the administrative distance values for a BGP address family.

distance (BGP address family)

BGP uses distances to compare and prioritize routes. The lower the distance, the more preferred the route.

Enable route-flap statistics accounting for the BGP address family.

flap-statistics

Originate BGP routes that are advertised to peers.

spf-timers

Redistribute routes learned through other protocols into the BGP routing process.

redistribute (BGP)

Be aware that the redistribute (BGP) command is available in BGP address family configuration mode for unicast address prefixes only.

Assign a traffic index to routes installed for a BGP address family.

table-map

Traffic index counters are maintained on interfaces with traffic index accounting enabled.

For more information about BGP attribute-based accounting, see the Configuring BGP Attribute-Based Accounting section in Configuring Routing Policies.

Enable the triggering of immediate BGP best-path calculation on notification of a next-hop withdrawal by the RIB, and configure next-hop scan parameters.

nexthop triggered

The nexthop triggered command is available in unicast IPv4 mode only.

2.1.3   Configure IPv6 Address Family Attributes for a BGP Routing Instance

To configure the IPv6 address family attributes for a BGP routing instance, perform the tasks described in Table 3.

Table 3    Configure IPv6 Address Family Attributes for a BGP Routing Instance

Task

Root Command

Notes

Specify the use of standard IP Version 6 (IPv6) unicast address prefixes for the BGP routing instance, and access BGP address family configuration mode.

address-family ipv6 unicast

Enter this command in BGP router configuration mode.

Create an aggregate entry in the BGP database for the BGP address family.

aggregate-address

Enable eBGP route dampening for the specified BGP address family.

dampening

Configure the administrative distance values for a BGP address family.

distance (BGP address family)

BGP uses distances to compare and prioritize routes. The lower the distance, the more preferred the route.

Enable route-flap statistics accounting for the BGP address family.

flap-statistics

Originate BGP routes that are advertised to peers.

spf-timers

Enable the triggering of immediate BGP best-path calculation on notification of a next-hop withdrawal by the RIB, and configure next-hop scan parameters.

nexthop triggered

Redistribute routes learned through other protocols into the BGP routing process.

redistribute (BGP)

Assign a traffic index to routes installed for a BGP address family.

table-map

Traffic index counters are maintained on interfaces with traffic index accounting enabled.

For more information about BGP attribute-based accounting, see Configuring BGP Attribute-Based Accounting in Configuring Routing Policies.

2.1.4   Configure Graceful Restart for a BGP Routing Instance

The graceful restart capability can be used by a BGP speaker to indicate its ability to preserve its forwarding state during a BGP restart. The BGP speaker can also convey to peers its intention of generating the end-of-Routing Information Base (RIB) marker upon the completion of its initial routing updates.

Note:  
Before you can configure graceful restart for a BGP routing instance, you need to create and configure a BGP routing instance, as described in Create and Configure a BGP Routing Instance.

To configure the graceful restart characteristics for a BGP routing instance, perform the tasks described in Table 4. Enter all commands in BGP router configuration mode.

Table 4    Configure Graceful Restart for a BGP Routing Instance

Task

Root Command

Notes

Set the maximum amount of time that it will take for a local BGP peer to come up after it has been reset.

maximum restart-time

Set the maximum amount of time the local BGP speaker retains routes it has previously received from a remote peer once that remote peer restarts the connection.

maximum retain-time

Any routes that have not been updated by the remote peer are deleted by the local peer after the local peer receives the end-of-RIB marker from the remote peer, or after the timer expires.

Set the maximum delay time for the BGP routing process after a reset has occurred before performing initial best path calculations.

maximum update-delay

Use this feature when all peers do not support a graceful restart, or when a peer may not send an end-of-RIB marker.

2.1.5   Configure BGP Route Reflection

If a BGP route reflector is configured, while it must have connections to all other BGP speakers in the AS, not all other BGP speakers must be fully meshed. When a BGP speaker in the AS receives messages from an external router, it is sufficient to advertise these routes only to the router reflector, which then readvertises the routes to all other BGP speakers in the AS.

Note:  
Before you can configure a BGP router reflector, you need to create and configure a BGP routing instance, as described in Create and Configure a BGP Routing Instance.

To configure BGP route reflection, perform the tasks described in Table 5. Enter all commands in BGP router configuration mode.

Table 5    Configure BGP Route Reflection

Task

Root Command

Notes

Enable client-to-client reflection.

client-to-client reflection

By default, routes are reflected between clients of a route reflector.

Disable client-to-client reflection.

client-to-client reflection

Use the no form of this command.

Disable client-to-client reflection when you do not want routes that have been learned from one client to be reflected to other clients; for example, when clients are fully meshed.

Assign a separate cluster ID to each route reflector.

cluster-id

Use this command when there is more than one route reflector in a cluster.

2.1.6   Configure a BGP Confederation

To reduce iBGP mesh, you can divide an autonomous system into subautonomous systems grouped by a routing domain identifier. The AS and its subautonomous systems are part of a BGP confederation. Externally, the confederation looks like a single autonomous system.

Note:  
Before you can configure a BGP confederation, you need to create and configure a BGP routing instance, as described in the Create and Configure a BGP Routing Instance.

To configure a BGP confederation, perform the tasks described in Table 6. Enter all commands in BGP router configuration mode.

Table 6    Configure a BGP Confederation

Task

Root Command

Notes

Configure a BGP confederation.

confederation identifier

Configure the subautonomous systems that belong to the BGP confederation.

confederation peers

2.2   Configuring BGP Neighbors and Neighbor Attributes

BGP speakers (BGP-enabled routers) that exchange inter-AS routing information are called BGP neighbors. BGP supports two kinds of neighbors: internal and external. Internal neighbors are in the same AS; external neighbors are in different autonomous systems. External neighbors must be adjacent to each other and share the same subnet, while internal neighbors may be located anywhere inside the same autonomous system.

To enable BGP speakers to effectively communicate with each other, each BGP speaker must be configured with information about its BGP neighbors.

The sections that follow describe how to configure a BGP neighbor and other neighbor attributes.

2.2.1   Configure a BGP Neighbor

To configure a BGP neighbor, perform the tasks described in Table 7.

Note:  
Before you can configure a BGP neighbor, you need to create and configure a BGP routing instance, as described in Create and Configure a BGP Routing Instance.

Table 7    Configure a BGP Neighbor

Task

Root Command

Notes

Enter BGP router configuration mode.

router bgp

Enter this command in context configuration mode.

Create a BGP neighbor and access BGP neighbor configuration mode.

neighbor (BGP)

Enter this command in BGP router configuration mode.

To configure an external GRP (eBGP) neighbor, include the external keyword in the neighbor command string.

To configure an internal GRP (iBGP) neighbor, include the internal keyword in the neighbor command string.

Advertise to a peer that this BGP speaker is willing to accept address prefix-based route filtering from the peer.

accept filter prefix-list

Modify the minimal interval at which BGP routing updates are sent to the specified neighbor.

advertisement-interval

Enable Bidirectional Forwarding Detection (BFD) for an eBGP neighbor.

bfd (RSVP client)

BFD is a simple Hello protocol that provides the ability to detect communication failures in less than one second. When BFD detects a communication failure to the eBGP neighbor, the neighbor is reset.

BFD can be enabled only for eBGP neighbors; enabling BFD for an iBGP neighbor generates an error message.

For more information about BFD, see Configuring BFD.

Associate a description with the neighbor.

description (BGP)

Configure the maximum number of hops used to reach an eBGP neighbor when the neighbor is not directly connected.

ebgp-multihop

This command must be enabled for BGP connections to be established with neighbors that are not directly connected.

Enable the BGP time-to-live (TTL) security check in the kernel for the BGP neighbor.

enforce ttl

For the BGP TTL security check to function correctly, it must be enabled on both ends of an eBGP session. Enabling only one end causes the eBGP session to drop.

Configure the ASN that the BGP routing process uses to peer with the specified eBGP neighbor.

local-as

Advertise the local peer address as the next-hop address.

next-hop-self

By default, when a BGP neighbor receives BGP routes from an eBGP neighbor, routes are sent to iBGP neighbors without changing the next-hop address.

Configure an encrypted MD5 password for the BGP neighbor.

password (BGP)

Apply the attributes of a configured BGP peer group to one or more BGP neighbors.

peer-group

You can assign a neighbor can be assigned to a peer group only if the neighbor and the peer group is of the same type—external or internal BGP. If a neighbor belongs to a particular peer group, you cannot configure it to belong to another peer group. You must first explicitly delete the previous peer group membership before reconfiguring the peer membership.

Attributes are inherited from the peer group to which a neighbor is assigned. The following BGP neighbor configuration mode commands represent attributes that you cannot customize per neighbor when the neighbor is assigned to a peer group: advertisement-interval, ebgp-multihop, local-as, send community, and timers. Attributes inherited from a peer group that you can customize per neighbor include those set by the following commands: description, password, send prefix, shutdown, and update-source.

Configure the ASN of the eBGP neighbor.

remote-as

Send the community attribute to the specified eBGP neighbor.

send community

Advertise to a BGP peer that this BGP speaker would like to send prefixed-based filtering to the peer.

send filter prefix-list

Administratively shut down a BGP session with the specified neighbor.

shutdown (BGP)

This command temporarily shuts down a BGP session without removing a BGP neighbor from the configuration.

Modify keepalive and holdtime timers for a specific neighbor.

timers

Values set for a BGP neighbor override the values set for the BGP routing instance.

Specify the IP address of the interface used for BGP peering.

update-source

Configure IPv4 multicast or unicast address family attributes.

For the complete list of tasks used to configure IPv4 address family attributes, see Configure IPv4 Address Family Attributes for a BGP Neighbor.

Configure IPv6 unicast address family attributes.

For the complete list of tasks used to configure IPv6 address family attributes, see Configure IPv6 Address Family Attributes for a BGP Neighbor.

Configure the graceful restart characteristics.

For the complete list of tasks used to configure BGP graceful restart, see Configure Graceful Restart for a BGP Neighbor.

2.2.2   Configure IPv4 Address Family Attributes for a BGP Neighbor

To configure the IPv4 address family attributes for a BGP neighbor, perform the tasks described in Table 8.

Note:  
Before you can configure IPv4 address family attributes for a BGP neighbor, you need to configure the BGP neighbor, as described in Configure a BGP Neighbor.

Table 8    Configure IPv4 Address Family Attributes for a BGP Neighbor

Task

Root Command

Notes

Specify the use of standard IP Version 4 (IPv4) multicast or unicast address prefixes for the neighbors in the BGP address family, and to access BGP neighbor address family configuration mode.

address-family ipv4 (Multicast and Unicast)

Enter this command in BGP neighbor configuration mode.

Filter BGP routing updates from or to the specified BGP neighbor address family.

as-path-list (BGP)

Advertise the default route of the specified address family, even when the default route is not installed in the BGP routing table, to a BGP neighbor.

default-originate

Specify how the BGP routing process responds when the maximum number of prefixes sent by the BGP neighbor for the specified address family is exceeded.

maximum prefix

Apply the attributes of a configured BGP peer group to one or more BGP neighbor address families.

peer-group

A BGP neighbor address family can belong to more than one peer group and you can modify it to belong to a different peer group without having to delete the previous peer group association first.

Attributes are inherited from the peer group to which a BGP neighbor address family is assigned. The following commands in BGP neighbor address family configuration mode represent attributes that you cannot customize per address family once it is assigned to a peer group: as-path-list out, prefix-list out, remove-private-as, and route-map out. Attributes inherited from a peer group that you can customize per neighbor address family include those set by the following commands: as-path-list in, default-originate, maximum-prefix, prefix-list in, and route-map in.

Filter BGP routes from or to the specified neighbor address family.

prefix-list

Remove ASNs from routes advertised to the specified BGP neighbor address family.

remove-private-as

Apply a route map that modifies BGP attributes or filters BGP routes received from or sent to the BGP neighbor.

route-map (BGP)

Configure an iBGP neighbor as a route reflector client for a BGP address family.

route-reflector-client

Enable a BGP router to send MPLS labels with BGP IPv4 routes to a peer BGP router.

send label

The send label command is available for BGP routers configured with IPv4 unicast address prefixes only; it is not available for routers configured with multicast IPv4 address prefixes.

2.2.3   Configure IPv6 Address Family Attributes for a BGP Neighbor

To configure the IPv6 address family attributes for a BGP neighbor, perform the tasks described in Table 9.

Note:  
Before you can configure IPv6 address family attributes for a BGP neighbor, you need to configure the BGP neighbor, as described in Configure a BGP Neighbor.

Table 9    Configure IPv6 Address Family Attributes for a BGP Neighbor

Task

Root Command

Notes

Specify the use of standard IPv6 unicast address prefixes for the neighbors in the BGP address family, and to access BGP neighbor address family configuration mode.

address-family ipv6 unicast

Enter this command in BGP neighbor configuration mode.

Filter BGP routing updates from or to the specified BGP neighbor address family.

as-path-list (BGP)

Advertise the default route of the specified address family, even when the default route is not installed in the BGP routing table, to a BGP neighbor.

default-originate

Specify how the BGP routing process responds when the maximum number of prefixes sent by the BGP neighbor for the specified address family is exceeded.

maximum prefix

Apply the attributes of a configured BGP peer group to one or more BGP neighbor address families.

peer-group

A BGP neighbor address family can belong to more than one peer group and you can modify it to belong to a different peer group without having to delete the previous peer group association first.

Attributes are inherited from the peer group to which a BGP neighbor address family is assigned. The following commands in BGP neighbor address family configuration mode represent attributes that you cannot customize per address family once it is assigned to a peer group: as-path-list out, prefix-list out,remove-private-as, and route-map out. Attributes inherited from a peer group that you can customize per neighbor address family include those set by the following commands: as-path-list in, default-originate, maximum-prefix, prefix-list in, androute-map in.

Filter BGP routes from or to the specified neighbor address family.

prefix-list

Remove ASNs from routes advertised to the specified BGP neighbor address family.

remove-private-as

Apply a route map that modifies BGP attributes or filters BGP routes received from or sent to the BGP neighbor.

route-map (BGP)

Configure an iBGP neighbor as a route reflector client for a BGP address family.

route-reflector-client

Enable a BGP router to send MPLS labels with BGP IPv6 routes to a peer BGP router.

send label

You must configure this command on both the local router and the peer router in order for the routers to send IPv6 unicast routes with MPLS labels.

Before you use the send label command to enable the sending of IPv6 packets over an IPv4 core, you must enable MPLS on the core.

2.2.4   Configure Graceful Restart for a BGP Neighbor

The graceful restart capability can be used by a BGP speaker to indicate its ability to preserve its forwarding state during a BGP restart. The BGP speaker can also convey to peers its intention of generating the end-of-Routing Information Base (RIB) marker upon the completion of its initial routing updates.

To configure the graceful restart characteristics for a BGP neighbor, perform the tasks described in Table 10.

Note:  
Before you can configure graceful restart for a BGP neighbor, you need to configure the BGP neighbor, as described in Configure a BGP Neighbor.

Table 10    Configure Graceful Restart for a BGP Neighbor

Task

Root Command

Notes

Set the maximum amount of time after the local BGP speaker has been reset before it attempts to reconnect with the remote peer.

maximum restart-time

Set the maximum amount of time the local BGP speaker retains routes it has previously received from a remote peer once that remote peer restarts the connection.

maximum retain-time

Any routes that have not been updated by the remote peer are deleted by the local peer after the local peer receives the end-of-RIB marker from the remote peer, or after the timer expires.

Force a BGP neighbor to retain routes from an iBGP peer once the peer has restarted.

retain-ibgp-routes

By default, routes are not retained for an iBGP peer after the peer restarts unless all iBGP peers support a graceful restart; however, in some network topologies, it may be desirable and feasible to retain the routes for an iBGP peer, even if not all iBGP peers support a graceful restart.

2.3   Enabling IPv6 over an IPv4 MPLS Core

To enable IPv6 over an IPv4 MPLS core, perform the tasks described in Table 11.

Note:  
IPv6 over IPv4 MPLS configuration is supported in the local context only.

Table 11    Enable IPv6 over an IPv4 Core

Task

Root Command

Notes

Access global configuration mode.

configure

Enter this command in global exec mode.

Enter context configuration mode.

contextlocal

Enter this command in global configuration mode.

Enter router configuration mode for the specified BGP routing instance.

router bgp

Enter this command in context configuration mode.

Specify the use of IP Version 6 (IPv6) unicast address prefixes for the Border Gateway Protocol (BGP) routing instance and enter BGP address family configuration mode.

address-family ipv6 unicast

Enter this command in BGP router configuration mode.

Exit BGP address family configuration mode and enter BGP router configuration mode.

exit

Enter this command in BGP address family configuration mode.

Enter BGP neighbor configuration mode for the specified neighbor.

neighbor (BGP)

Enter this command in BGP router configuration mode.

Specify the use of IPv6 unicast address prefixes for the specified BGP neighbor, and enter BGP neighbor address family configuration mode.

address-family ipv6 unicast

Enter this command in BGP neighbor configuration mode.

Enable the transport of labeled IPv6 routes over the MPLS IPv4 core.

send label

Enter this command in BGP neighbor address family configuration mode.

2.4   Configuring BGP Peer Groups and Peer Group Attributes

BGP peer groups are helpful in cases where many BGP neighbors are configured with the same update policies. Grouping a large number of neighbors into one or more peer groups simplifies modifications to a configuration and makes the BGP update calculation process more efficient. A BGP peer group can be an eBGP or as an iBGP peer group.

To configure a BGP peer group and other peer group attributes, perform the tasks described in the sections that follow.

2.4.1   Configure a BGP Peer Group

To configure a BGP peer group, perform the tasks described in Table 12.

Table 12    Configure a BGP Peer Group

Task

Root Command

Notes

Configure a BGP peer group, and enter BGP peer group configuration mode.

peer-group

Enter this command in BGP router configuration mode.

Modify the minimal interval at which BGP routing updates are sent to the specified BGP peer group.

advertisement-interval

Associate a description with the peer group.

description (BGP)

Configure the maximum number of hops used to reach an eBGP neighbor when the BGP peer group is not directly connected.

ebgp-multihop

This command must be enabled for BGP connections to be established with neighbors that are not directly connected.

Enable the BGP TTL security check in the kernel for the BGP peer group.

enforce ttl

For the BGP TTL security check to function correctly, it must be enabled on both ends of an eBGP session. Enabling only one end causes the eBGP session to drop.

Advertise the local peer address as the next-hop address.

next-hop-self

Configure an encrypted MD5 password for the BGP peer group.

password (BGP)

Send the community attribute to the specified BGP peer group.

send community

Enable a flapping peer to be temporarily suppressed for a configurable amount of time.

session-dampening

This command is per peer and peer-group based. If the peer is member of a peer group, the command is inherited from the peer-group and can be customized in the peer configuration.

The main benefit of this feature is to avoid flapping peers from using system resources, and also to reduce routing churn induced by a flapping peer.

Administratively shut down a BGP session with the specified peer group.

shutdown (BGP)

This command temporarily shuts down a BGP session without removing a BGP peer group from the configuration.

Modify keepalive and holdtime timers for a peer group.

timers

Specify the IP address of the interface used for BGP peering.

update-source

By default, when a BGP peer group receives BGP routes from an eBGP peer group, routes are sent to iBGP neighbors without changing the next-hop address.

Configure IPv4 multicast or unicast address family attributes.

For the complete list of tasks used to configure IPv4 address family attributes, see Configure IPv4 Address Family Attributes for a BGP Peer Group.

Configure IPv6 unicast address family attributes.

For the complete list of tasks used to configure IPv6 address family attributes, see Configure IPv6 Address Family Attributes for a BGP Peer Group.

2.4.2   Configure IPv4 Address Family Attributes for a BGP Peer Group

To configure IPv4 address family attributes for a BGP peer group, perform the tasks described in Table 13. Enter all commands in BGP peer group address family configuration mode, unless otherwise noted.

Table 13    Configure IPv4 Address Family Attributes for a BGP Peer Group

Task

Root Command

Notes

Specify the use of standard IPv4 multicast or unicast address prefixes for peer groups in the BGP peer groups address family, and enter BGP peer group address family configuration mode.

address-family ipv4 (Multicast and Unicast)

Enter this command in BGP peer group configuration mode.

Filter BGP routing updates from or to the specified BGP neighbor address family.

as-path-list (BGP)

Advertise the default route of the specified address family, even when the default route is not installed in the BGP routing table, to a BGP neighbor.

default-originate

Specify how the BGP address family responds when the maximum number of prefixes sent by the BGP peer group for the specified address family is exceeded.

maximum prefix

Filter BGP routes from the peer group for the specified address family.

prefix-list

Remove ASNs from routes advertised to the specified BGP peer group address family.

remove-private-as

Apply a route map that modifies BGP attributes or filters BGP routes received from or sent to the specified peer group address family.

route-map (BGP)

Configure an iBGP peer group as a route reflector client for a BGP address family.

route-reflector-client

2.4.3   Configure IPv6 Address Family Attributes for a BGP Peer Group

To configure IPv6 address family attributes for a BGP peer group, perform the tasks described in Table 14. Enter all commands in BGP peer group address family configuration mode, unless otherwise noted.

Table 14    Configure IPv6 Address Family Attributes for a BGP Peer Group

Task

Root Command

Notes

Specify the use of standard IPv6 unicast address prefixes for peer groups in the BGP peer groups address family, and enter BGP peer group address family configuration mode.

address-family ipv6 unicast

Enter this command in BGP peer group configuration mode.

Filter BGP routing updates from or to the specified BGP neighbor address family.

as-path-list (BGP)

Advertise the default route of the specified address family, even when the default route is not installed in the BGP routing table, to a BGP neighbor.

default-originate

Specify how the BGP address family responds when the maximum number of prefixes sent by the BGP peer group for the specified address family is exceeded.

maximum prefix

Filter BGP routes from the peer group for the specified address family.

prefix-list

Remove ASNs from routes advertised to the specified BGP peer group address family.

remove-private-as

Apply a route map that modifies BGP attributes or filters BGP routes received from or sent to the specified peer group address family.

route-map (BGP)

Configure an iBGP peer group as a route reflector client for a BGP address family.

route-reflector-client

2.4.4   Apply Peer Group Attributes

A BGP neighbor, or BGP neighbor address family, can inherit attributes from the peer group to which a neighbor is assigned. The following BGP neighbor configuration mode commands represent attributes that cannot be customized per neighbor when the neighbor is assigned to a peer group: advertisement-interval, ebgp-multihop, local-as, send community, and timers. Attributes inherited from a peer group that can be customized per neighbor include those set by the following commands: description, password, send prefix, shutdown, and update-source.

To apply peer group attributes, perform the tasks described in Table 15.

Table 15    Apply Peer Group Attributes

Task

Root Command

Notes

Apply peer group attributes to a BGP neighbor.

peer-group

Enter this command in BGP neighbor configuration mode.

Apply peer group attributes to a BGP neighbor address family.

peer-group

Enter this command in BGP peer group configuration mode.

2.5   BGP Operations

To manage BGP functions, perform the appropriate tasks described in Table 16. Enter the show commands in any mode; enter the clear and debug commands in exec mode.

Table 16    BGP Operations Tasks

Task

Root Command

Apply new BGP routing policies or reset BGP connections globally without dropping connections.

clear bgp

Apply new routing policies for eBGP neighbors or to reset eBGP connections.

clear bgp external

Clear BGP route-flap statistics.

clear bgp flap-statistics

Apply new BGP routing policies to connections using multicast address prefixes or to reset BGP IPv4 address connections.

clear bgp ipv4 multicast

Apply new BGP routing policies to connections using unicast address prefixes or to reset BGP IPv4 address connections.

clear bgp ipv4 unicast

Clear BGP message statistics.

clear bgp ipv4 vpn

Apply new BGP neighbor routing policies or reset BGP neighbor connections.

clear bgp neighbor

Apply new BGP peer group routing policies or to reset BGP peer group connections.

clear bgp peer-group

Enable the generation of BGP general-event messages.

debug bgp event

Enable the generation of debug messages for BGP passive open connections.

debug bgp listen

Enable the generation of debug messages for BGP nonupdate events.

debug bgp message

Enable the generation of debug messages for BGP routing policies.

debug bgp policy

Enable the generation of debug messages for interaction between BGP and the Routing Information Base (RIB).

debug bgp rib

Enable the generation of debug messages for BGP session states and timers.

debug bgp session-state

Enable the generation of debug messages for BGP update events.

debug bgp update

Display BGP attribute information, including AS path, community, next-hop address, and route reflector attributes.

show bgp attribute

Display malformed BGP messages for the purpose of troubleshooting.

show bgp malform

Display BGP neighbor status, configuration, and statistical information.

show bgp neighbor

Display BGP neighbor flap statistics.

show bgp neighbor flap-statistics

Display BGP notification messages.

show bgp notification

Display BGP peer group information, including peer group membership and session status.

show bgp peer-group

Display BGP neighbor reset information for troubleshooting purposes.

show bgp reset-log

Display information about all BGP routes, or for a subset of routes.

show bgp route

Display community information for BGP routes.

show bgp route community

Display BGP route-flap statistics.

show bgp route flap-statistics

Display BGP routes sourced from more than one AS.

show bgp route inconsistent-as

Display information about BGP multicast or unicast IP Version 4 (IPv4) address prefix-based routes.

show bgp route ipv4

Display information about BGP unicast IP Version 6 (IPv6) address prefix-based routes.

show bgp route ipv6 unicast

Display MPLS labels associated with BGP routes.

show bgp route labels

Display information about routes to or from BGP neighbors.

show bgp route neighbor

Display BGP communities that match an AS path string.

show bgp route regexp

Display BGP routes sourced from the local AS.

show bgp route sourced

Display a summary report of BGP routes in the routing table.

show bgp route summary

Display a summary of BGP status and statistical information.

show bgp summary

Display the current BGP configuration information for the current context.

show configuration bgp


 Caution! 
Risk of dropped connection. A hard reset can impact network connectivity. When using any clear bgp command, the soft keyword for inbound only takes effect if the BGP neighbor supports the refresh capability. The soft keyword for outbound is a local matter, and does not require the capability. To see if a BGP neighbor supports the refresh capability, use the show bgp neighbor summary command (in exec mode). Specify the soft keyword if you do not want the BGP neighbor connection dropped. To reduce the risk, only use a hard reset as a last resort.

3   Configuration Examples

The sections that follow provide BGP configuration examples for basic BGP, next-hop triggered BGP best-path calculation, iMBGP peers, iMBGP peer groups, eMBGP peers, eMBGP peer groups, and IPv6 over an IPv4 core.

3.1   Example: Configure Basic BGP

The following example show the minimum commands needed to configure BGP:

[local]Router_A#config

[local]Router_A(config)#context local

[local]Router_A(config-ctx)#router bgp 64001

[local]Router_A(config-bgp)#router-id 1.1.1.71

[local]Router_A(config-bgp)#address-family ipv4 unicast

[local]Router_A(config-bgp-af)#redistribute static

[local]Router_A(config-bgp-af)#exit

[local]Router_A(config-bgp)#peer-group iBGP internal

[local]Router_A(config-bgp-peer-group)#next-hop-self

[local]Redback(config-bgp-peer-group)#update-source loopback0

[local]Redback(config-bgp-peer-group)#address-family ipv4 unicast

[local]Redback(config-bgp-peer-af)#exit

[local]Redback(config-bgp-peer-group)#exit

[local]Redback(config-bgp)#peer-group customer-routes external

[local]Redback(config-bgp-peer-group)#address-family ipv4 unicast

[local]Redback(config-bgp-peer-af)#route-map rmap1 out

[local]Redback(config-bgp-peer-af)#exit

[local]Redback(config-bgp-peer-group)#exit

[local]Redback(config-bgp)#neighbor 1.1.1.1 internal

[local]Redback(config-bgp-neighbor)#peer-group ibgp

[local]Redback(config-bgp-neighbor)#exit

[local]Redback(config-bgp)#neighbor 2.2.2.2 external

[local]Redback(config-bgp-neighbor)#remote-as 200

[local]Redback(config-bgp-neighbor)#peer-group customer-routes

[local]Redback(config-bgp-neighbor)#address-family ipv4 unicast

[local]Redback(config-bgp-peer-af)#prefix-list bar in

[local]Redback(config-bgp-peer-af)#route-map foo2 in

[local]Redback(config-bgp-peer-af)#exit

[local]Redback(config-bgp-neighbor)#exit

[local]Redback(config-bgp)#neighbor 3.3.3.3 external

[local]Redback(config-bgp-neighbor)#remote-as 300

[local]Redback(config-bgp-neighbor)#address-family ipv4 unicast

[local]Redback(config-bgp-peer-af)#prefix-list bar in

[local]Redback(config-bgp-peer-af)#route-map foo3 out

3.2   Example: Configure Next-Hop-Triggered BGP Best-Path Calculation

The following example shows how to enable and then configure next-hop triggered BGP best-path calculation:

[local]Router_A#config

[local]Router_A(config)#context local

[local]Router_A(config-ctx)#router bgp 64001

[local]Router_A(config-bgp)#address-family ipv4 unicast

[local]Router_A(config-bgp-af)#nexthop triggered

[local]Router_A(config-bgp-af)#nexthop triggered delay 30

[local]Router_A(config-bgp-af)#nexthop triggered holdtime 2 backoff 10

[local]Router_A(config-bgp-af)#commit

3.3   Example: Configure iMBGP Peers

The following example configures two iMBGP peers. Figure 4 shows the network topology for the configuration.

Figure 4   Network Topology for iMBGP Peer Configuration

The configuration for Router_A is as follows:

[local]Router_A#config

[local]Router_A(config)#context local

[local]Router_A(config-ctx)#interface lo1 loopback

[local]Router_A(config-if)#ip address 10.200.1.1/32

[local]Router_A(config-if)#exit

[local]Router_A(config-ctx)#router bgp 100

[local]Router_A(config-bgp)#router-id 10.200.1.1

[local]Router_A(config-bgp)#neighbor 10.200.1.2 internal

[local]Router_A(config-bgp-neighbor)#update-source lo1

[local]Router_A(config-bgp-neighbor)#address-family ipv4 multicast

[local]Router_A(config-bgp-peer-af)#exit

[local]Router_A(config-bgp-neighbor)#exit

[local]Router_A(config-bgp)#exit

[local]Router_A(config-ctx)#ip route 10.200.1.2/32 102.1.1.2

The configuration for Router B is as follows:

[local]Router_B#config

[local]Router_B(config)#context local

[local]Router_B(config-ctx)#interface lo1 loopback

[local]Router_B(config-if)#ip address 10.200.1.2/32

[local]Router_B(config-if)#exit

[local]Router_B(config-ctx)#router bgp 100

[local]Router_B(config-bgp)#router-id 10.200.1.2

[local]Router_B(config-bgp)#neighbor 10.200.1.1 internal

[local]Router_B(config-bgp-neighbor)#update-source lo1

[local]Router_B(config-bgp-neighbor)#address-family ipv4 multicast

[local]Router_B(config-bgp-peer-af)#exit

[local]Router_B(config-bgp-neighbor)#exit

[local]Router_B(config-bgp)#exit

[local]Router_B(config-ctx)#ip route 10.200.1.1/32 102.1.1.1

3.4   Example: Configure an iMBGP Peer Group

The following example configures an iMBGP peer group for two iMBGP peers. Figure 5 shows the network topology for the configuration.

Figure 5   Network Topology for iMBGP Peer Group Configuration

The configuration for Router_A is as follows:

[local]Router_A#config

[local]Router_A(config)#context local

[local]Router_A(config-ctx)#interface lo1 loopback

[local]Router_A(config-if)#ip address 10.200.1.1/32

[local]Router_A(config-if)#exit

[local]Router_A(config-ctx)#router bgp 100

[local]Router_A(config-bgp)#router-id 10.200.1.1

[local]Router_A(config-bgp)#address-family ipv4 multicast

[local]Router_A(config-bgp-af)#exit

[local]Router_A(config-bgp)#peer-group iMBGP internal

[local]Router_A(config-bgp-peer-group)#update-source lo1

[local]Router_A(config-bgp-peer-group)#address-family ipv4 multicast

[local]Router_A(config-bgp-peer-af)#exit

[local]Router_B(config-bgp-peer-group)#exit 

[local]Router_A(config-bgp)#neighbor 10.200.1.2 internal

[local]Router_A(config-bgp-neighbor)#peer-group iMBGP

The configuration for Router_B is as follows:

[local]Router_B#config

[local]Router_B(config)#context local

[local]Router_B(config-ctx)#interface lo1 loopback

[local]Router_B(config-if)#ip address 10.200.1.2/32

[local]Router_B(config-if)#exit

[local]Router_B(config-ctx)#router bgp 100

[local]Router_B(config-bgp)#router-id 10.200.1.2

[local]Router_B(config-bgp)#address-family ipv4 multicast

[local]Router_B(config-bgp-af)#exit

[local]Router_B(config-bgp)#peer-group iMBGP internal

[local]Router_B(config-bgp-peer-group)#update-source lo1

[local]Router_B(config-bgp-peer-group)#address-family ipv4 multicast

[local]Router_B(config-bgp-peer-af)#exit

[local]Router_B(config-bgp-peer-group)#exit 

[local]Router_B(config-bgp)#neighbor 10.200.1.1 internal

[local]Router_B(config-bgp-neighbor)#peer-group iMBGP

3.5   Example: Configure eMBGP Peers

The following example configures two eMBGP peers. Figure 6 shows the network topology for the configuration.

Figure 6   Network Topology for Configuring eMBGP Peers

The configuration for Router_B is as follows:

[local]Router_B#config

[local]Router_B(config)#context local

[local]Router_B(config-ctx)#interface lo1 loopback

[local]Router_B(config-if)#ip address 10.200.1.2/32

[local]Router_B(config-if)#exit

[local]Router_B(config-ctx)#router bgp 100

[local]Router_B(config-bgp)#router-id 10.200.1.2

[local]Router_B(config-bgp)#neighbor 10.200.1.3 external

[local]Router_B(config-bgp-neighbor)#remote-as 200

[local]Router_B(config-bgp-neighbor)#ebgp-multihop 10

[local]Router_B(config-bgp-neighbor)#update-source lo1

[local]Router_B(config-bgp-neighbor)#address-family ipv4 multicast

The configuration for Router_C is as follows:

[local]Router_C#config

[local]Router_C(config)#context local

[local]Router_C(config-ctx)#interface lo1 loopback

[local]Router_C(config-if)#ip address 10.200.1.3/32

[local]Router_C(config-if)#exit

[local]Router_C(config-ctx)#router bgp 100

[local]Router_C(config-bgp)#router-id 10.200.1.2

[local]Router_C(config-bgp)#neighbor 10.200.1.1 internal

[local]Router_C(config-bgp-neighbor)#remote-as 100

[local]Router_C(config-bgp-neighbor)#ebgp-multihop 10

[local]Router_C(config-bgp-neighbor)#update-source lo1

[local]Router_C(config-bgp-neighbor)#address-family ipv4 multicast

3.6   Example: Configure an eMBGP Peer Group

The following example configures an eMBGP peer group for two eMBGP peers. Figure 7 shows the network topology for the configuration.

Figure 7   Network Topology for Configuring an eMBGP Peer Group

The configuration for Router_B is as follows:

[local]Router_B#config

[local]Router_B(config)#context local

[local]Router_B(config-ctx)#interface lo1 loopback

[local]Router_B(config-if)#ip address 10.200.1.2/32

[local]Router_B(config-if)#exit

[local]Router_B(config-ctx)#router bgp 100

[local]Router_B(config-bgp)#router-id 10.200.1.2

[local]Router_B(config-bgp)#address-family ipv4 multicast

[local]Router_B(config-bgp-af)#exit

[local]Router_B(config-bgp)#peer-group eMBGP external

[local]Router_B(config-bgp-peer-group)#ebgp-multihop 10

[local]Router_B(config-bgp-peer-group)#update-source lo1

[local]Router_B(config-bgp-peer-group)#address-family ipv4 multicast

[local]Router_B(config-bgp-peer-af)#exit

[local]Router_B(config-bgp-peer-group)#neighbor 10.200.1.3 external

[local]Router_B(config-bgp-neighbor)#remote-as 200

[local]Router_B(config-bgp-neighbor)#peer-group eMBGP

The configuration for Router_C is as follows:

[local]Router_C#config

[local]Router_C(config)#context local

[local]Router_C(config-ctx)#interface lo1 loopback

[local]Router_C(config-if)#ip address 10.200.1.3/32

[local]Router_C(config-if)#exit

[local]Router_C(config-ctx)#router bgp 200

[local]Router_C(config-bgp)#router-id 10.200.1.3

[local]Router_C(config-bgp)#address-family ipv4 multicast

[local]Router_C(config-bgp-af)#exit

[local]Router_C(config-bgp)#peer-group eMBGP external

[local]Router_C(config-bgp-peer-group)#ebgp-multihop 10

[local]Router_C(config-bgp-peer-group)#update-source lo1

[local]Router_C(config-bgp-peer-group)#address-family ipv4 multicast

[local]Router_C(config-bgp-peer-af)#exit

[local]Router_C(config-bgp-peer-group)#neighbor 10.200.1.2 external

[local]Router_C(config-bgp-neighbor)#remote-as 100

[local]Router_C(config-bgp-neighbor)#peer-group eMBGP

3.7   Example: Configure IPv6 over an IPv4 Core

The following example shows how to enable IPv6 over an MPLS IPv4 core in the SmartEdge router. Perform this configuration on a PE router that has at least one IPv4 session with a PE neighbor and one IPv6 session with a CE neighbor:

[local]Router_C#config context local

[local]Router_A(config-ctx)#router bgp 100

[local]Router_C(config-bgp)#address-family ipv6 unicast

[local]Router_C(config-bgp-af)#exit

[local]Router_C(config-bgp)#neighbor 10.200.1.3 internal

[local]Router_C(config-bgp-neighbor)#address-family ipv6 unicast

[local]Router_C(config-bgp-peer-af)#send label

[local]Router_C(config-bgp-peer-af)#commit