Configuring Channelized Ports

Contents

1Overview
1.1Channelized OC-3/STM-1 or OC-12/STM-4 Line Card Ports
1.2Port and Channel Loopback
1.3Traffic Management
1.4Software Licenses

2

Configuration
2.1Configure the Channelized Line Card
2.2Configure the Card Clock Source
2.3Configure Ports for Channelized SONET/SDH
2.4Configure SONET Mapping
2.5Configure SDH AUG Mapping
2.6Configure Ports for DS3, DS1, or E1 Channels
2.7Configure Ports for NxDS0 Subchannels
2.8Configure NxDS0 Channel Timeslots
2.9Configure the Port Transmit Timing Clock Source
2.10DS3 and POS DS1/E1 Channel and Subchannel Clock Sources
2.11CES Channelized DS1/E1 Channel/Subchannel Clock Source
2.12Configure Layer-2 Encapsulation
2.13Port Configuration and Operations Tasks

3

Configuration Examples
3.1POS Example
3.2POS with PWFQ QoS Example
3.3APS Example
3.4APS with PWFQ QoS Example
3.5MLPPP Example
3.6MLPPP with PWFQ QoS Example
3.7MLPPP with APS Example
3.8MLPPP with APS and PWFQ QoS Example

4

Verification, Testing, and Status Reporting
4.1Loopback Testing

Glossary

Reference List
Copyright

© Ericsson AB 2011. All rights reserved. No part of this document may be reproduced in any form without the written permission of the copyright owner.

Disclaimer

The contents of this document are subject to revision without notice due to continued progress in methodology, design and manufacturing. Ericsson shall have no liability for any error or damage of any kind resulting from the use of this document.

Trademark List
SmartEdge is a registered trademark of Telefonaktiebolaget LM Ericsson.
NetOp is a trademark of Telefonaktiebolaget LM Ericsson.

1   Overview

The system currently supports the Channelized OC-3/STM-1 or OC-12/STM-4 line card. This line card is an 8-port dual-services card for SmartEdge routers, with channelization capabilities down to fractional E1/T1. Both SONET (Synchronous Optical Networking) and SDH (Synchronous Digital Hierarchy) mappings are supported. Circuit Emulation, PPP (Point to Point Protocol) services are all supported on the same card, with service types configured independently down to the physical port level. The card hardware supports DS3, DS1, DS0 group (nx64K), and channelization for all Packet over SONET (POS) services. It also supports channelization for Circuit Emulation Services (CES). CES uses CESoPSN (Circuit Emulation Services over Packet Switched Networks), supporting up to 16 timing domains with adaptive clock recovery.

This document applies to both the Ericsson SmartEdge® and SM family routers. However, the software that applies to the SM family of systems is a subset of the SmartEdge OS; some of the functionality described in this document may not apply to SM family routers.

For information specific to the SM family chassis, including line cards, refer to the SM family chassis documentation.

For specific information about the differences between the SmartEdge and SM family routers, refer to the Technical Product Description SM Family of Systems (part number 5/221 02-CRA 119 1170/1) in the Product Overview folder of this Customer Product Information library.

1.1   Channelized OC-3/STM-1 or OC-12/STM-4 Line Card Ports

The Channelized OC-3/STM-1 or OC-12/STM-4 line card (ch-oc3oc12-8or2-port) has eight ports divided into two 4-port groups:

1.1.1   Restrictions and Limitations

1.2   Port and Channel Loopback

Loopbacks can be applied to ports, channels and subchannels on a Channelized OC-3/STM-1 or OC-12/STM-4 line card. Loopback support is identical for CES ports and POS ports.

For details see the loopback (channel) command. Table 1 gives a quick overview the port and channel loopback types supported.

Table 1    Port and Channel Loopback Support

Port/Channel Type

Loopback

Comments

Line

Local/Internal

Remote

OC-n/STM-n port

Yes

Yes

No

Requires C-bit framing

DS3 channel

Yes

Yes

Yes

 

DS1 channel

Yes

Yes

Yes

The loopback options available to a DS1 channel follow. For example, you can have a network loopback of either the line type or payload type. Under remote loopbacks, four types are available:


  • local

  • network line

  • network payload

  • remote line fdl ansi

  • remote line fdl bellcore

  • remote line inband

  • remote payload

E1 channel

Yes

Yes

No

No protocol for E1 remote loopback.

DS0 group

Yes

No

No

Devices are not capable of internal loopbacks.

1.3   Traffic Management

1.3.1   Policing

Policing policies are supported per channel and per MLPPP bundle.

1.3.2   Metering

Metering policies are supported per channel and per MLPPP bundle.

1.3.3   Queuing

PWFQ is the only queuing policy supported. A PWFQ policy can be applied to PPP channels and to MLPPP bundles. Up to eight priority groups are supported.

The Channelized OC-3/STM-1 or OC-12/STM-4 line card supports flow control between the EPPA and a Winpath device. As a result, all congestion drops occur in the EPPA, and not the Winpath device.

1.4   Software Licenses

1.4.1   Displaying Software Licenses

Use the show licenses command with the detail keyword to display per-slot software license information.

1.4.2   Install All Ports Software License

Before you can use ports 5 through 8 of the Channelized OC-3/STM-1 or OC-12/STM-4 line card, you must obtain an all-ports software license for the line card, one for each line card using these ports.

After obtaining the license, install it in the slot where the Channelized OC-3/STM-1 or OC-12/STM-4 line card is installed. See the all-ports command for details.

Note:  
If no software license exists for the slot, the system rejects attempts to configure ports 5 through 8 (for CES or POS service) and displays an error message.

1.4.3   Install CES Software License

Before a port can be created for CES service, a CES per-slot software license for each Channelized OC-3/STM-1 or OC-12/STM-4 line card must be obtained for the slot.

After obtaining the license, install it in the slot where the Channelized OC-3/STM-1 or OC-12/STM-4 line card is installed. See the cescommand for details.

Note:  
If this software license does not exist for the slot, the CES service type token will not appear in CLI.

ln the following example, the CES software license is installed.

[local]dennys#
[local]dennys#config
Enter configuration commands, one per line, 'end' to exit
[local]dennys(config)#software license
[local]dennys(config-license)#ces password <plain text passcode> 
ch-oc3oc12-8or2-port slot 2
[local]dennys(config-license)#

1.4.3.1   Syntax Description

[no] ces <password> {encrypted 1 | plain text passcode} <card-type> <slot-id>

   
 
  • password is the password provided when the license is purchased.

  • encrypted 1 | plain text passcode indicates whether the password is encrypted (encrypted 1) or not encrypted (plain text passcode)

  • card-type is the card type of the license.

  • slot-id is the slot to which the license is to be applied or removed; accepted only for per-slot licenses.


To remove all software licenses, including per-slot ones, run no software license all-ports.

1.4.3.2   Command Mode

config-license configuration mode

1.4.3.3   Usage Guidelines

Removing all software licenses on the chassis removes all per-slot licenses as well as all per-chassis licenses. When a per-slot license is removed, subsequent enabling of ports 5 through 8 is blocked.

2   Configuration

For configuration examples, see Section 3.

2.1   Configure the Channelized Line Card

The card ch-oc3oc12-8or2-port command provisions a specified slot for the Channelized OC-3/STM-1 or OC-12/STM-4 line card.

2.2   Configure the Card Clock Source

You can configure the clock source for the Channelized OC-3/STM-1 or OC-12/STM-4 line card to be either the system clock on an XCRP (the global-reference) or the 20 ppm SONET Minimum Clock oscillator on the Channelized OC-3/STM-1 or OC-12/STM-4 line card.

See the clock-source (card configuration mode) command for details.

2.3   Configure Ports for Channelized SONET/SDH

Use the port <port-type> command to configure any port as a SONET channelized OC3 or SDH channelized STM1 port. In addition, you can configure ports 1 and 5 as SONET channelized OC12 or SDH channelized STM4.

The following commands are options of the port <port-type> command.

2.4   Configure SONET Mapping

The port SONET mapping specifies the mapping used by all facilities on an OC-3 and OC-12 port. The mapping selected must match that of the far-end SONET interface, and must support the types of channels required to carry the POS or CES service.

See the channel-mapping command for details.

Table 2 shows the service provided on each type of unchannelized channel with each SDH and SONET mapping option.

Table 2 also shows which subchannel channel types can be multiplexed on each channelized channel type for each mapping option. If you attempt to configure a channel, subchannel, or sub-subchannel that is not allowed by your SDH AUG mapping or SONET channel mapping settings, the system rejects the command with a message similar to the following: channelized-ds1 cannot be configured at this port level

2.5   Configure SDH AUG Mapping

The port SDH mapping specifies the AUG mapping used by all facilities on an STM-1 or STM-4 port. The AUG mapping selected must match that of the far-end SDH interface, and must support the types of channels required to carry the POS or CES service.

See the aug-mapping command for details.

Table 2 shows the service provided on each type of unchannelized channel with each SDH and SONET mapping option.

Table 2 also shows what subchannel channel types can be multiplexed on each channelized channel type for each mapping option. If you attempt to configure a channel, subchannel, or sub-subchannel that is not allowed by your SDH AUG mapping or SONET channel mapping settings, the system rejects the command with a message similar to the following: channelized-ds1 cannot be configured at this port level

2.6   Configure Ports for DS3, DS1, or E1 Channels

In the context of the Channelized OC-3/STM-1 or OC-12/STM-4 line card, a channel refers to the Plesiochronous Digital Hierarchy (PDH) structure that is mapped to the SONET or SDH frame. This differs from a subchannel, which is a PDH structure that is multiplexed into the DS3 channel.

When you run CLI commands that create channels directly from the SONET or SDH port, the channels are mapped to the SONET or SDH frame. These channels can be DS3, DS1, and E1. The CLI commands that create channels from PDH DS3, DS1, and E1 channels, create subchannels, and these subchannels are time slots multiplexed into the DS3, DS1, and E1 channels.

The port {ds3 | channelized-ds3} command enters the configuration mode for the PDH DS3 channels in the OC-3, OC-12, STM-1, and STM-4 ports.

The port {ds1 | channelized-ds1} and port {e1 | channelized-e1) commands enter the configuration mode for the PDH DS1 and E1 channels; either multiplexed in channelized OC-3, OC-12, STM-1, or STM-4 port or multiplexed in DS3 channels.

Note:  
You can bind services only to DS0 channels and unchannelized DS1, E1, and DS3 channels . You can multiplex subchannels only in channelized DS1, E1, and DS3 channels.

The port {ds1 | channelized-ds1} and port {e1 | channelized-e1 commands configure PDH DS1 and E1 channels in the OC-3, OC-12, STM-1, and STM-4 ports PDH or DS1 and E1 subchannels multiplexed in DS3 channels.

2.6.1   Channel, Subchannel, and Sub-subchannel Services

The port-configured service type determines the service type for a channel, subchannel, or sub-subchannel. If the port is configured for POS service, and its channels, subchannels, or sub-subchannels are capable of POS service, the channel service type is POS. If the port is configured for CES, and the channel or subchannel can be carried over a CESoPSN pseudowire, then the channel or subchannel service type is CESoPSN.

2.6.1.1   Supported Channel Types

Table 2    Channel Types

Channel Type

Subchannel/


Service Type

Framing

SONET Channel


Mapping

SDH AUG


Mapping

DS3

POS

C-Bit parity


M23

STS1

au3/no-tugs


au4/tu3

Channelized DS3

DS1


E1

C-Bit parity


M23

STS1

au3/no-tugs


au4/tu3

DS1

POS

SF


ESF

VT1.5

au3/tu11


au4/tu11

Channelized DS1

NxDS0

SF


ESF

VT1.5

au3/tu11


au4/tu11

E1

POS

CRC-4


NO-CRC-4


unframed

N/A

au3/tu12


au4/tu12

Channelized E1

NxDS0

CRC-4


NO-CRC-4

N/A

au3/tu12


au4/tu12

Note:  
Because the SDH and SONET mappings are applied on a per-port basis, channels that require different SDH or SONET mappings are not supported on the same port.

2.6.1.2   Supported Subchannel Types

Table 3    Subchannel Types

Subchannel Type

Subsubchannel/


Service Type

Framing

Upper-Level Channel Type

DS1

POS

SF


ESF


unframed

Channelized DS3 channel

Channelized-DS1

NxDS0

SF


ESF

Channelized DS3 channel

E1

POS

CRC-4


NO-CRC-4


unframed

Channelized DS3 channel

Channelized-E1

NxDS0

CRC-4


NO-CRC-4

Channelized DS3 channel

NxDS0

POS

N/A

Channelized T1 channel


Channelized T1 subchannel


Channelized E1 channel


Channelized E1 subchannel

NxDS0

POS


CESoPSN

N/A

Channelized T1 channel


Channelized T1 subchannel


Channelized E1 channel


Channelized E1 subchannel

2.7   Configure Ports for NxDS0 Subchannels

The port ds0s command configures DS0 subchannels or sub-subchannels.

NxDS0 channels can be multiplexed as subchannels in a channelized DS1 or channelized E1 channel or as sub-subchannel in a channelized DS1 or channelized E1 subchannel in a DS3 channel. For details, see the port ds0s command.

2.8   Configure NxDS0 Channel Timeslots

The timeslot command defines one or more groups of NxDS0 subchannels added to the first NxDS0 subchannel (also known as a timeslot) in the parent DS1 or E1 (fractional T1/E1).

Note:  
The first NxDS0 timeslot is the subchannel set by the port ds0s command in its nxds0-channel-id argument.

2.9   Configure the Port Transmit Timing Clock Source

Use the clock-source (port) command to select whether the port and channel transmit timing is loop-timed or timed by the card-reference clock. (See the clock-source (card configuration mode) command for the card-reference clock options.)

2.10   DS3 and POS DS1/E1 Channel and Subchannel Clock Sources

Use the clock-source (port) command to select whether the transmit timing for DS3 and POS DS1/E1 channels and subchannels is loop-timed or timed by the card-reference clock.

2.11   CES Channelized DS1/E1 Channel/Subchannel Clock Source

You can configure a CES channelized DS1/E1 channel or subchannel clock source for a Channelized OC-3/STM-1 or OC-12/STM-4 line card port.

In addition to choosing card-reference or loop timing as options, you can select a local timing domain where the reference is generated using adaptive clock recovery.

2.11.1   Syntax Description

clock-source {card-reference | loop}


default clock-source

   
 
  • card-reference indicates to use the card configured reference clock source; this is the default value.

  • loop indicates to use the recovered receive clock from the port as the transmit clock source.

2.12   Configure Layer-2 Encapsulation

To provision the encapsulation of each channel, use the encapsulation (channel) command. This command applies both to unchannelized and channelized channels.

2.13   Port Configuration and Operations Tasks

2.13.1   Configuration Options for an OC-12 Port

2.13.2   Configure a Channelized OC-12 Port

Operational Features

  1. Select (begin the configuration of) a channelized OC-12 port and access port configuration mode. port channelized-oc12
  2. Specify general attributes for the port (all attributes are optional):
  3. Enable the port (begin operations on it). shutdown (Channel)

Maintenance Feature

2.13.3   Configure a DS-3 Channel or Port

Operational Features

  1. Select (begin the configuration of) a clear-channel DS-3 channel or port and access DS-3 configuration mode. port ds3
  2. Specify general attributes for the port (all attributes are optional):
  3. Specify the idle character. idle-character
  4. Specify the cable length. cablelength (DS-3)
  5. Enable the channel or port to respond to or ignore remote loopback requests. equipment-loopback (DS-1 and DS-3)
  6. Specify the DSU vendor. dsu mode
  7. Bind the channel or port to an existing interface in an existing context. bind interface
  8. Enable the channel or port (begin operations on it). shutdown (Channel)

2.13.4   Configure a Channelized DS-3 Channel or Port

Operational Features

  1. Create or select (begin the configuration of) a channelized DS-3 channel or port and access DS-3 configuration mode. port channelized-ds3
  2. Specify general attributes for the port (all attributes are optional):

Maintenance Feature

2.13.5   Configure a DS-1 Channel

Operational Features

  1. Create or select (begin the configuration of) a DS-1 channel and access DS-1 configuration mode. port ds1
  2. Specify general attributes for the port (all attributes are optional):
  3. Specify the parameters for the Cisco HDLC keepalive function. keepalive (channel)
  4. Add the channel to an existing MP or MFR bundle. link-group
  5. (Optional) Enable PAP, CHAP, PAP-CHAP, or CHAP-PAP local authentication of static links. authentication (local PAP, CHAP)
  6. Bind the channel to an existing interface in an existing context. bind interface
  7. Enable the channel (begin operations on it). shutdown (Channel)

Maintenance Feature

2.13.6   Configure a Channelized STM-1 Ports

Operational Features

  1. Create or select (begin the configuration of) a DS-1 channel and access DS-1 configuration mode. port channelized-stm1
  2. Specify general attributes for the port (all attributes are optional):
  3. Apply an existing bulkstats schema profile to the channel or port. bulkstats schema
  4. Enable the channel (begin operations on it). shutdown (Channel)

Maintenance Feature

  1. Specify a path trace message or the message length. path-trace
  2. Change to a loopback state on the port to test port operation. loopback (channels)

2.13.7   Configure a E1 Channel

Operational Features

  1. Select (begin the configuration of) an E1 channel or port and access E1 configuration mode. port e1
  2. Specify general attributes for the port (all attributes are optional):
  3. Add the channel to an existing MP or MFR bundle. link-group
  4. (Optional) Enable PAP, CHAP, PAP-CHAP, or CHAP-PAP local authentication of static links. authentication (local PAP, CHAP)
  5. Bind the channel to an existing interface in an existing context. bind interface
  6. Enable the channel or port (begin operations on it). shutdown (Channel)

2.13.8   Configure a Channelized E1 Channel

Operational Features

  1. Select (begin the configuration of) an E1 channel or port and access E1 configuration mode. port e1
  2. Specify general attributes for the port (all attributes are optional):
  3. Enable the channel or port (begin operations on it). shutdown (Channel)

Maintenance Feature

2.13.9   Configure a DS-0 Channel Group

Operational Features

  1. Create or select (begin the configuration of) a DS-0 channel group and access DS-0 channel group configuration mode. port ds0s
  2. Specify general attributes for the port (all attributes are optional):
  3. Bind the channel to an existing interface in an existing context. bind interface
  4. Enable the channel (begin operations on it). shutdown (Channel)

Maintenance Feature

2.13.10   Port and Channel Operations

3   Configuration Examples

3.1   POS Example

config
!
service multiple-contexts
!
software license
 all-ports password <plain text passcode> card ch-oc3oc12-8or2-port slot 2
!
!
context redkite1
!
interface pos_chstm1->ds3_1
  ip address 1.1.1.1/24
!
 interface pos_chstm1->chds3->ds1_1
  ip address 2.2.2.1/24
!
 interface pos_chstm1->chds3->ds1_2
  ip address 3.3.3.1/24
!
 interface pos_chstm1->chds3->chds1->ds0s_1
  ip address 4.4.4.1/24
!
 interface pos_chstm1->chds3->chds1->ds0s_2
  ip address 5.5.5.1/24
!
 interface pos_chstm1->chds3->e1_1
  ip address 6.6.6.1/24
!
 interface pos_chstm1->chds3->e1_2
  ip address 7.7.7.1/24
!
 interface pos_chstm1->chds3->che1->ds0s_1
  ip address 8.8.8.1/24
!
 interface pos_chstm1->chds3->che1->ds0s_2
  ip address 9.9.9.1/24
!
 interface pos_chstm1->e1_1
  ip address 10.10.10.1/24
!
 interface pos_chstm1->e1_2
  ip address 11.11.11.1/24
!
 interface pos_chstm1->che1->ds0s_1
  ip address 12.12.12.1/24
!
 interface pos_chstm1->che1->ds0s_2
  ip address 13.13.13.1/24
!
 ppp keepalive check-interval minutes 3 response-timeout 5 retries 3 data-check
!
!
card ch-oc3oc12-8or2-port 2
 no shutdown
 clock-source global-reference
!
!
! Example for POS, using SDH AUG mapping au3-no-tug to channelize:
! chSTM1 -> DS3
! chSTM1 -> chDS3
! chSTM1 -> chDS3 -> DS1
! chSTM1 -> chDS3 -> chDS1 -> DS0s
! chSTM1 -> chDS3
! chSTM1 -> chDS3 -> E1
! chSTM1 -> chDS3 -> chE1 -> DS0s
!
port channelized-stm1 2/1 pos
 no shutdown
 aug-mapping au3-no-tug
 clock-source card-reference
 !
 port ds3 2/1:1
  no shutdown
  clock-source card-reference
  encapsulation ppp
  bind interface pos_chstm1->ds3_1 redkite1
 !
 port channelized-ds3 2/1:2
  no shutdown
  clock-source card-reference
 !
  port ds1 2/1:2:1
   no shutdown
   clock-source card-reference
   encapsulation ppp
   bind interface pos_chstm1->chds3->ds1_1 redkite1
  !
  port ds1 2/1:2:2
   no shutdown
   clock-source card-reference
   bind interface pos_chstm1->chds3->ds1_2 redkite1
  !
  port channelized-ds1 2/1:2:3
   no shutdown
   clock-source card-reference
  !
   port ds0s 2/1:2:3:1
    no shutdown
    timeslot 1-12
    encapsulation ppp
    bind interface pos_chstm1->chds3->chds1->ds0s_1 redkite1
   !
   port ds0s 2/1:2:3:13
    no shutdown
    timeslot 13-24
    bind interface pos_chstm1->chds3->chds1->ds0s_2 redkite1
   !
  !
 !
 port channelized-ds3 2/1:3
  no shutdown
  clock-source card-reference
 !
  port e1 2/1:3:1
   no shutdown
   clock-source card-reference
   encapsulation ppp
   bind interface pos_chstm1->chds3->e1_1 redkite1
  !
  port e1 2/1:3:2
   no shutdown
   clock-source card-reference
   bind interface pos_chstm1->chds3->e1_2 redkite1
  !
  port channelized-e1 2/1:3:3
   no shutdown
   clock-source card-reference
  !
   port ds0s 2/1:3:3:1
    no shutdown
    timeslot 1-15
    encapsulation ppp
    bind interface pos_chstm1->chds3->che1->ds0s_1 redkite1
   !
   port ds0s 2/1:3:3:16
    no shutdown
    timeslot 16-31
    bind interface pos_chstm1->chds3->che1->ds0s_2 redkite1
   !
  !
 !
!
!
! Example for POS, using SDH AUG mapping au4-tu12 to channelize:
! chSTM1 -> E1
! chSTM1 -> chE1 -> DS0s
!
port channelized-stm1 2/4 pos
 no shutdown
 aug-mapping au4-tu12
 clock-source card-reference
 !
 port e1 2/4:1
  no shutdown
  clock-source card-reference
  encapsulation ppp
  bind interface pos_chstm1->e1_1 redkite1
 !
 port e1 2/4:2
  no shutdown
  clock-source card-reference
  encapsulation ppp
  bind interface pos_chstm1->e1_2 redkite1
 !
 port channelized-e1 2/4:3
  no shutdown
  clock-source card-reference
 !
  port ds0s 2/4:3:1
   no shutdown
   timeslot 1-30
   encapsulation ppp
   bind interface pos_chstm1->che1->ds0s_1 redkite1
  !
  port ds0s 2/4:3:31
   no shutdown
   bind interface pos_chstm1->che1->ds0s_2 redkite1
  !
 !
!
!
end

3.2   POS with PWFQ QoS Example

conf


port channelized-oc12 13/1 pos
 no shutdown
 !
 port channelized-ds3 13/1:1
  no shutdown
  !
  port ds1 13/1:1:1
   no shutdown
   encapsulation ppp
   bind interface int1 local
   qos policy queuing pwfq-pol
  !
  port channelized-ds1 13/1:1:2
   no shutdown
   !
   port ds0s 13/1:1:2:1
    no shutdown
    encapsulation ppp
    bind interface int2 local
    qos policy queuing pwfq-pol
 !
 port ds3 13/1:2
  no shutdown
  encapsulation ppp
  bind interface int3 local
  qos policy queuing pwfq-pol
 !
 port channelized-ds3 13/1:3
  no shutdown
  !
  port e1 13/1:3:1
   no shutdown
   encapsulation ppp
   bind interface int4 local
   qos policy queuing pwfq-pol
  !
  port channelized-e1 13/1:3:2
   no shutdown
   !
   port ds0s 13/1:3:2:1
    no shutdown
    encapsulation ppp
    bind interface int5 local
    qos policy queuing pwfq-pol
!
port channelized-oc12 13/5 pos
 no shutdown
 !
 port channelized-ds3 13/5:1
  no shutdown
  !
  port ds1 13/5:1:1
   no shutdown
   bind interface int6 local
   qos policy queuing pwfq-pol
  !
  port channelized-ds1 13/5:1:2
   no shutdown
   !
   port ds0s 13/5:1:2:1
    no shutdown
    bind interface int7 local
    qos policy queuing pwfq-pol
 !
 port ds3 13/5:2
  no shutdown
  encapsulation ppp
  bind interface int8 local
  qos policy queuing pwfq-pol
 !
 port channelized-ds3 13/5:3
  no shutdown
  !
  port e1 13/5:3:1
   no shutdown
   bind interface int9 local
   qos policy queuing pwfq-pol
  !
  port channelized-e1 13/5:3:2
   no shutdown
   !
   port ds0s 13/5:3:2:1
    no shutdown
    bind interface int10 local
    qos policy queuing pwfq-pol
!
end

3.2.1   QoS Metering

Metering 

conf


port channelized-oc12 13/1 pos
 no shutdown
 !
 port channelized-ds3 13/1:1
  no shutdown
  !
  port ds1 13/1:1:1
   no shutdown
   encapsulation ppp
   bind interface int1 local
   qos policy metering metering_ds1_1
  !
  port channelized-ds1 13/1:1:2
   no shutdown
   !
   port ds0s 13/1:1:2:1
    no shutdown
    encapsulation ppp
    bind interface int2 local
    qos policy metering metering_ds0_1
 !
 port ds3 13/1:2
  no shutdown
  bind interface int3 local
  qos policy metering metering_ds3_1
 !
 port channelized-ds3 13/1:3
  no shutdown
  !
  port e1 13/1:3:1
   no shutdown
   encapsulation ppp
   bind interface int4 local
   qos policy metering metering_e1_1

  !
  port channelized-e1 13/1:3:2
   no shutdown
   !
   port ds0s 13/1:3:2:1
    no shutdown
    encapsulation ppp
    bind interface int5 local
    qos policy metering metering_ds0_2
!
port channelized-oc12 13/5 pos
 no shutdown
 !
 port channelized-ds3 13/5:1
  no shutdown
  !
  port ds1 13/5:1:1
   no shutdown
   bind interface int6 local
   qos policy metering metering_ds1_2
  !
  port channelized-ds1 13/5:1:2
   no shutdown
   !
   port ds0s 13/5:1:2:1
    no shutdown
    bind interface int7 local
    qos policy metering metering_ds0_3
 !
 port ds3 13/5:2
  no shutdown
  bind interface int8 local
  qos policy metering metering_ds3_2
 !
 port channelized-ds3 13/5:3
  no shutdown
  !
  port e1 13/5:3:1
   no shutdown
   bind interface int9 local
   qos policy metering metering_e1_2
  !
  port channelized-e1 13/5:3:2
   no shutdown
   !
   port ds0s 13/5:3:2:1
    no shutdown
    bind interface int10 local
    qos policy metering metering_ds0_4
!


end

3.2.2   QoS Policing

conf

port channelized-oc12 14/1 pos
 no shutdown
 !
 port channelized-ds3 14/1:1
  no shutdown
  !
  port ds1 14/1:1:1
   no shutdown
   encapsulation ppp
   bind interface int1 a
   qos policy policing policing_ds1_1
  !
  port channelized-ds1 14/1:1:2
   no shutdown
   !
   port ds0s 14/1:1:2:1
    no shutdown
    encapsulation ppp
    bind interface int2 a
    qos policy policing policing_ds0_1
 !
 port ds3 14/1:2
  no shutdown
  bind interface int3 a
  qos policy policing policing_ds3_1
 !
 port channelized-ds3 14/1:3
  no shutdown
  !
  port e1 14/1:3:1
   no shutdown
   encapsulation ppp
   bind interface int4 a
   qos policy policing policing_e1_1
  !
  port channelized-e1 14/1:3:2
   no shutdown
   !
   port ds0s 14/1:3:2:1
    no shutdown
    encapsulation ppp
    bind interface int5 a
    qos policy policing policing_ds0_2
!
port channelized-oc12 14/5 pos
 no shutdown
 !
 port channelized-ds3 14/5:1
  no shutdown
  !
  port ds1 14/5:1:1
   no shutdown
   bind interface int6 a
   qos policy policing policing_ds1_2
  !
  port channelized-ds1 14/5:1:2
   no shutdown
   !
   port ds0s 14/5:1:2:1
    no shutdown
    bind interface int7 a
    qos policy policing policing_ds0_3
 !
 port ds3 14/5:2
  no shutdown
  bind interface int8 a
  qos policy policing policing_ds3_2
 !
 port channelized-ds3 14/5:3
  no shutdown
  !
  port e1 14/5:3:1
   no shutdown
   bind interface int9 a
   qos policy policing policing_e1_2
  !
  port channelized-e1 14/5:3:2
   no shutdown
   !
   port ds0s 14/5:3:2:1
    no shutdown
    bind interface int10 a
    qos policy policing policing_ds0_4


end

3.3   APS Example

config
!
service multiple-contexts
!
software license
 all-ports password <plain text passcode> card ch-oc3oc12-8or2-port slot 2
!
aps group aps1 pos
!
!context redkite1
!
 interface pos_aps_chstm1->ds3_1
  ip address 14.14.14.1/24
!
 interface pos_aps_chstm1->chds3->ds1_1
  ip address 15.15.15.1/24
!
 interface pos_aps_chstm1->chds3->ds1_2
  ip address 16.16.16.1/24
!
 interface pos_aps_chstm1->chds3->chds1->ds0s_1
  ip address 17.17.17.1/24
!
 interface pos_aps_chstm1->chds3->chds1->ds0s_2
  ip address 18.18.18.1/24
!
 interface pos_aps_chstm1->chds3->e1_1
  ip address 19.19.19.1/24
!
 interface pos_aps_chstm1->chds3->e1_2
  ip address 20.20.20.1/24
!
 interface pos_aps_chstm1->chds3->che1->ds0s_1
  ip address 21.21.21.1/24
!
 interface pos_aps_chstm1->chds3->che1->ds0s_2
  ip address 22.22.22.1/24
!
 ppp keepalive check-interval minutes 3 response-timeout 5 retries 3 data-check
!
!card ch-oc3oc12-8or2-port 2
 no shutdown
 clock-source global-reference
!
!
! APS/MSP group aps1: 2/2 working, 2/6 protect; on working port 2/2, 
   using SDH AUG mapping au4-tu3 to channelize:
! chSTM1 (APS) -> DS3
! chSTM1 (APS) -> chDS3
! chSTM1 (APS) -> chDS3 -> DS1
! chSTM1 (APS) -> chDS3 -> chDS1 -> DS0s
! chSTM1 (APS) -> chDS3
! chSTM1 (APS) -> chDS3 -> E1
! chSTM1 (APS) -> chDS3 -> chE1 -> DS0s
!
port channelized-stm1 2/2 pos
 no shutdown
 aps working aps1
 aug-mapping au4-tu3
 clock-source card-reference
 !
 port ds3 2/2:1
  no shutdown
  clock-source card-reference
  encapsulation ppp
  bind interface pos_aps_chstm1->ds3_1 redkite1
 !
 port channelized-ds3 2/2:2
  no shutdown
  clock-source card-reference
 !
  port ds1 2/2:2:1
   no shutdown
   clock-source card-reference
   encapsulation ppp
   bind interface pos_aps_chstm1->chds3->ds1_1 redkite1
  !
  port ds1 2/2:2:2
   no shutdown
   clock-source card-reference
   bind interface pos_aps_chstm1->chds3->ds1_2 redkite1
  !
  port channelized-ds1 2/2:2:3
   no shutdown
   clock-source card-reference
  !
   port ds0s 2/2:2:3:1
    no shutdown
    timeslot 1-23
    encapsulation ppp
    bind interface pos_aps_chstm1->chds3->chds1->ds0s_1 redkite1
   !
   port ds0s 2/2:2:3:24
    no shutdown
    bind interface pos_aps_chstm1->chds3->chds1->ds0s_2 redkite1
   !
  !
 !
 port channelized-ds3 2/2:3
  no shutdown
  clock-source card-reference
 !
  port e1 2/2:3:1
   no shutdown
   clock-source card-reference
   encapsulation ppp
   bind interface pos_aps_chstm1->chds3->e1_1 redkite1
  !
  port e1 2/2:3:2
   no shutdown
   clock-source card-reference
   bind interface pos_aps_chstm1->chds3->e1_2 redkite1
  !
  port channelized-e1 2/2:3:3
   no shutdown
   clock-source card-reference
  !
   port ds0s 2/2:3:3:1
    no shutdown
    timeslot 1-15
    encapsulation ppp
    bind interface pos_aps_chstm1->chds3->che1->ds0s_1 redkite1
   !
   port ds0s 2/2:3:3:16
    no shutdown
    timeslot 16-31
    bind interface pos_aps_chstm1->chds3->che1->ds0s_2 redkite1
   !
  !
 !
!
port channelized-stm1 2/6 pos
 no shutdown
 aps protect aps1
!
!
end

3.3.1   Notes

3.4   APS with PWFQ QoS Example

context local
!
 no ip domain-lookup
!
 interface local-1
  ip address 11.11.11.1/24
!
!
 interface local-2
  ip address 12.12.12.1/24
!
 interface loop loopback
  ip address 1.1.1.1/32
!
!
 interface to-dest
  ip address 192.168.1.1/24
 logging console
!
 policy access-list policy_acl
  seq 10 permit tcp any any eq www class browsers
  seq 20 permit tcp any any eq ftp class ftp-stuff
  seq 30 permit ip any dscp eq ef class dscp_ef
  seq 40 permit ip any dscp eq af12 class dscp_af12
  seq 50 permit ip any dscp eq cs3 class dscp_cs3
  seq 60 permit ip any tos max-throughput class tos_maxr
  seq 70 permit ip any tos min-delay class tos_mind
  seq 80 permit ip any any class unknown
!
!
 ip route 155.53.0.0/16 10.12.208.1
 ip route 192.168.2.0/24 11.11.11.2
!
!
!
! ** End Context **
 logging tdm console
 logging active
 logging standby short
!

!
qos queue-map default
 num-queues 2
  queue 0 priority 0
  queue 1 priority 1 2 3 4 5 6 7
 num-queues 4
  queue 0 priority 0
  queue 1 priority 1 2
  queue 2 priority 3 4 5 6
  queue 3 priority 7
 num-queues 8
  queue 0 priority 0
  queue 1 priority 1
  queue 2 priority 2
  queue 3 priority 3
  queue 4 priority 4
  queue 5 priority 5
  queue 6 priority 6
  queue 7 priority 7
!
!
qos policy metering-pol metering
 access-group policy_acl local
 class browsers
  rate 100 burst 800
 class ftp-stuff
  rate 100 burst 800
 class unknown
  rate 100 burst 800
 class dscp_af12
  rate 100 burst 800
 class dscp_cs3
  rate 100 burst 800
 class tos_maxr
  rate 100 burst 800
 class tos_mind
  rate 100 burst 800
 class dscp_ef
  rate 100 burst 800
!
!
qos policy policing-pol policing
 ip access-group policy_acl local
  class browsers
   mark priority 1
  class ftp-stuff
   mark priority 0
  class unknown
   mark priority 3
  class dscp_af12
   mark priority 2
  class dscp_cs3
   mark priority 4
  class tos_maxr
   mark priority 5
  class tos_mind
   mark priority 6
  class dscp_ef
   mark priority 7
!
qos policy pwfq_policy pwfq
 rate maximum 1000
 queue 0 priority 0 weight 100
 queue 1 priority 1 weight 100
 queue 2 priority 2 weight 100
 queue 3 priority 3 weight 100
 queue 4 priority 4 weight 100
 queue 5 priority 5 weight 100
 queue 6 priority 6 weight 100
 queue 7 priority 7 weight 100
 queue priority-group 0 rate 500
 queue priority-group 1 rate 500
 queue priority-group 2 rate 500
 queue priority-group 3 rate 500
 queue priority-group 4 rate 500
 queue priority-group 5 rate 500
 queue priority-group 6 rate 500
 queue priority-group 7 rate 500
!
aps group aps1 pos
 architecture 1+1 bidirectional
!
!
!
 system clock timezone PST -8 0 local
 system clock summer-time PST PDT recurring first Sunday April 2 
     last Sunday October 2
!
!
!
card ch-oc3oc12-8or2-port 12
!
port channelized-oc3 12/2 pos
 no shutdown
 aps working aps1
 !
 port channelized-ds3 12/2:1
  no shutdown
  !
  port ds1 12/2:1:1
   no shutdown
   encapsulation ppp
   bind interface local-1 local
   qos policy metering metering-pol   
  !
  !
 port channelized-ds3 12/2:2
  no shutdown
  !
  port ds1 12/2:2:1
   no shutdown
   encapsulation ppp
   bind interface local-2 local
   qos policy queuing pwfq_policy
  !
!
port channelized-oc3 12/4 pos
 no shutdown
 aps protect aps1
 !
 ! ---- aps protect channel
 ! port channelized-ds3 12/4:1
 ! no shutdown
  !
  ! port ds1 12/4:1:1
  ! no shutdown
  !
 ! port channelized-ds3 12/4:2
 ! no shutdown
  !
  ! port ds1 12/4:2:1
  ! no shutdown
  !
!
card ch-oc3oc12-8or2-port 13
!
card ge3-4-port 14
!
! no timeout session idle
!
service console-break
!
service crash-dump-dram
!
no service auto-system-recovery
!
!
no ipv6 path-mtu-discovery discovery-interval
!
end

3.5   MLPPP Example

config
!
service multiple-contexts
!
software license
 all-ports password <plain text passcode> card ch-oc3oc12-8or2-port slot 2
!
!
context redkite1
!
 interface mp_pos_chstm1->chds3->ds1_1
  ip address 23.23.23.1/24
!
 interface mp_pos_chstm1->chds3->e1_1
  ip address 24.24.24.1/24
!
 interface mp_pos_chstm1->e1_1
  ip address 25.25.25.1/24
!
!
link-group mp1_pos_ds1_1 mp
 bind interface mp_pos_chstm1->chds3->ds1_1 redkite1
link-group mp1_pos_e1_1 mp
 bind interface mp_pos_chstm1->chds3->e1_1 redkite1
link-group mp1_pos_e1_2 mp
 bind interface mp_pos_chstm1->e1_1 redkite1
!
!
card ch-oc3oc12-8or2-port 2
 no shutdown
 clock-source global-reference
!
!
! Example for plain MLPPP, using SDH AUG mapping au3-no-tug to channelize:
! chSTM1 -> chDS3 -> MLPPP (DS1 member links)
! chSTM1 -> chDS3 -> MLPPP (E1 member links)
!
port channelized-stm1 2/1 pos
 no shutdown
 aug-mapping au3-no-tug
 clock-source card-reference
 !
 port channelized-ds3 2/1:2
  no shutdown
  clock-source card-reference
 !
 !
 ! MLPPP bundle over POS, 8 DS1 member links 
 !
  port ds1 2/1:2:4
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:5
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:6
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:7
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:8
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:9
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:10
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
  port ds1 2/1:2:28
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_ds1_1
  !
 !
 port channelized-ds3 2/1:3
  no shutdown
  clock-source card-reference
 !
 !
 ! MLPPP bundle over POS, 8 E1 member links 
 !
  port e1 2/1:3:4
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:5
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:6
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:7
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:8
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:9
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:10
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
  port e1 2/1:3:21
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_pos_e1_1
  !
 !
!
! Example for plain MLPPP, using SDH AUG mapping au4-tu12 to channelize:
! chSTM1 -> MLPPP (E1 member links)
!
port channelized-stm1 2/4 pos
 no shutdown
 aug-mapping au4-tu12
 clock-source card-reference
 !
 !
 ! MLPPP bundle over POS, 8 E1 member links 
 !
 port e1 2/4:4
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:5
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:6
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:7
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:8
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:9
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:10
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
 port e1 2/4:63
  no shutdown
  clock-source card-reference
  encapsulation ppp
  link-group mp1_pos_e1_2
 !
!
!
end

3.5.1   Notes

3.6   MLPPP with PWFQ QoS Example

!
service multiple-contexts
!
! 
! 
 software license
  all-ports encrypted 1 $1$kqhpM6xR$RgjhWyyiIN5jOv6G1ndyH1 
      card ch-oc3oc12-8or2-port slot 3
  all-ports encrypted 1 $1$kqhpM6xR$RgjhWyyiIN5jOv6G1ndyH1 
      card ch-oc3oc12-8or2-port slot 11
!
!
!
!
!
!
context local
! 
 ip domain-name ericsson.com
 ip name-servers 155.53.12.12
 no ip domain-lookup
!
 interface ingress_1
  ip address 25.1.1.1/24
!
 interface ingress_2
  ip address 26.1.1.1/24
!
 interface int1
  ip address 11.1.1.1/24
!
 interface int2
  ip address 12.1.1.1/24
!
!
 enable encrypted 1 $1$........$kvQfdsjs0ACFMeDHQ7n/o.
!
!
 administrator test encrypted 1 $1$........$kvQfdsjs0ACFMeDHQ7n/o.
!
!
 ip route 35.1.1.2/32 11.1.1.2
 ip route 36.1.1.2/32 12.1.1.2
!
!
!
!
context a
! 
 no ip domain-lookup
!
 interface egress_1
  ip address 35.1.1.1/24
!
 interface egress_2
  ip address 36.1.1.1/24
!
 interface int1
  ip address 11.1.1.2/24
!
 interface int2
  ip address 12.1.1.2/24
 no logging console
!
!
!
!
! ** End Context **
 logging tdm console
 logging active
 logging standby short
!
!
!
qos queue-map default
 num-queues 2
  queue 0 priority 0 
  queue 1 priority 1 2 3 4 5 6 7 
 num-queues 4
  queue 0 priority 0 
  queue 1 priority 1 2 
  queue 2 priority 3 4 5 6 
  queue 3 priority 7 
 num-queues 8
  queue 0 priority 0 
  queue 1 priority 1 
  queue 2 priority 2 
  queue 3 priority 3 
  queue 4 priority 4 
  queue 5 priority 5 
  queue 6 priority 6 
  queue 7 priority 7 
!
!
qos congestion-avoidance-map my_congest pwfq
 queue 0 depth 1000
 queue 1 depth 900
 queue 2 depth 800
 queue 3 depth 700
 queue 4 depth 600
 queue 5 depth 500
 queue 6 depth 400
 queue 7 depth 300
!
!        
qos policy pwfq-pol pwfq 
 rate maximum 1000
 queue 0 priority 0 weight 100
 queue 1 priority 1 weight 100
 queue 2 priority 2 weight 100
 queue 3 priority 3 weight 100
 queue 4 priority 4 weight 100
 queue 5 priority 5 weight 100
 queue 6 priority 6 weight 100
 queue 7 priority 7 weight 100
!
qos policy pwfq_eq pwfq
 rate maximum 64
 congestion-map my_congest
 queue 0 priority 0 weight 30
 queue 1 priority 1 weight 10
 queue 2 priority 2 weight 10
 queue 3 priority 3 weight 10
 queue 4 priority 4 weight 10
 queue 5 priority 5 weight 10
 queue 6 priority 6 weight 10
 queue 7 priority 7 weight 10
 queue priority-group 0 rate percentage 10
 queue priority-group 1 rate percentage 10
 queue priority-group 2 rate percentage 10
 queue priority-group 3 rate percentage 10
 queue priority-group 4 rate percentage 10
 queue priority-group 5 rate percentage 10
 queue priority-group 6 rate percentage 10
 queue priority-group 7 rate percentage 20
!
!
!
link-group lg_local mp
 bind interface int1 local
 qos policy queuing pwfq-pol
!!
link-group lg_nonlocal mp
 bind interface int1 a
!
link-group lg_ds0 mp
 bind interface int2 local
 qos policy queuing pwfq_eq
!
link-group lg_nonlocal_ds0 mp
 bind interface int2 a
!
 system clock timezone PST -8 0 local
 system clock summer-time PST PDT recurring first Sunday April 2 
     last Sunday October 2
!
!
card ch-oc3oc12-8or2-port 3
!
port channelized-oc12 3/1 pos
 path-trace Ericsson
 no shutdown
 !
 port channelized-ds3 3/1:1
  no shutdown
  !
  port ds1 3/1:1:1
   no shutdown
   encapsulation ppp
   link-group lg_local
   !
  port ds1 3/1:1:2
    no shutdown
    encapsulation ppp
    link-group lg_local
   !
 port channelized-ds3 3/1:2
  no shutdown
  !
  port channelized-ds1 3/1:2:1
   no shutdown
   !
   port ds0s 3/1:2:1:1
    no shutdown
    encapsulation ppp
    link-group lg_ds0
   !
   port ds0s 3/1:2:1:2
    no shutdown
    encapsulation ppp
    link-group lg_ds0
   !
!
card ge3-4-port 4
!
card ch-oc3oc12-8or2-port 11
!
port channelized-oc12 11/1 pos
 path-trace Ericsson
 no shutdown
 !
 port channelized-ds3 11/1:1
  no shutdown
  !
  port ds1 11/1:1:1
   no shutdown
   encapsulation ppp
   link-group lg_nonlocal
   !
  port ds1 11/1:1:2
    no shutdown
    encapsulation ppp
    link-group lg_nonlocal
 !
 port channelized-ds3 11/1:2
 no shutdown
 !
 port channelized-ds1 11/1:2:1
  no shutdown
 !
  port ds0s 11/1:2:1:1
   no shutdown
   encapsulation ppp
   link-group lg_nonlocal_ds0
  !
  port ds0s 11/1:2:1:2
   no shutdown
   encapsulation ppp
   link-group lg_nonlocal_ds0
  !
!
card ge3-4-port 13
!
 no timeout session idle
!
no service console-break
!
no service crash-dump-dram
!
no service auto-system-recovery
no ipv6 path-mtu-discovery discovery-interval
!
!
!
end

3.6.1   Notes

3.7   MLPPP with APS Example

config
!
service multiple-contexts
!
software license
 all-ports password <plain text passcode> card ch-oc3oc12-8or2-port slot 2
!
aps group aps1 pos
!
!
context redkite1
!
 interface mp_aps_chstm1->chds3->chds1_1
  ip address 26.26.26.1/24
!
 interface mp_aps_chstm1->chds3->e1_1
  ip address 27.27.27.1/24
!
 ppp keepalive check-interval minutes 3 response-timeout 5 retries 3 data-check
!
!
link-group mp1_aps_ds1_1 mp
 bind interface mp_aps_chstm1->chds3->chds1_1 redkite1
link-group mp1_aps_e1_1 mp
 bind interface mp_aps_chstm1->chds3->e1_1 redkite1
!
!
card ch-oc3oc12-8or2-port 2
 no shutdown
 clock-source global-reference
!
!
! APS/MSP group aps1: 2/2 working, 2/6 protect; on working port 2/2, 
   using SDH AUG mapping au4-tu3 to channelize:
! chSTM1 (APS) -> chDS3 -> MLPPP (DS1 member links)
! chSTM1 (APS) -> chDS3 -> MLPPP (E1 member links)
!
port channelized-stm1 2/2 pos
 no shutdown
 aps working aps1
 aug-mapping au4-tu3
 clock-source card-reference
 !
 port channelized-ds3 2/2:2
  no shutdown
  clock-source card-reference
 !
 !
 ! MLPPP bundle over APS/MSP, 8 DS1 member links 
 !
  port ds1 2/2:2:4
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:5
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:6
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:7
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:8
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:9
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:10
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
  port ds1 2/2:2:28
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_ds1_1
  !
 !
 port channelized-ds3 2/2:3
  no shutdown
  clock-source card-reference
 !
 !
 ! MLPPP bundle over APS/MSP, 8 E1 member links 
 !
  port e1 2/2:3:4
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:5
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:6
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:7
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:8
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:9
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:10
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
  port e1 2/2:3:21
   no shutdown
   clock-source card-reference
   encapsulation ppp
   link-group mp1_aps_e1_1
  !
 !
!
port channelized-stm1 2/6 pos
 no shutdown
 aps protect aps1
!
!
end

3.7.1   Notes

3.8   MLPPP with APS and PWFQ QoS Example

context local
!
 no ip domain-lookup
!
 interface local-1
  ip address 11.11.11.1/24
!
!
 interface local-2
  ip address 12.12.12.1/24
!
 interface loop loopback
  ip address 1.1.1.1/32
!
!
 interface to-dest
  ip address 192.168.1.1/24
 logging console
!
 policy access-list policy_acl
  seq 10 permit tcp any any eq www class browsers
  seq 20 permit tcp any any eq ftp class ftp-stuff
  seq 30 permit ip any dscp eq ef class dscp_ef
  seq 40 permit ip any dscp eq af12 class dscp_af12
  seq 50 permit ip any dscp eq cs3 class dscp_cs3
  seq 60 permit ip any tos max-throughput class tos_maxr
  seq 70 permit ip any tos min-delay class tos_mind
  seq 80 permit ip any any class unknown
!
!
 ip route 155.53.0.0/16 10.12.208.1
 ip route 192.168.2.0/24 11.11.11.2
!
!
!
! ** End Context **
 logging tdm console
 logging active
 logging standby short
!

!
qos queue-map default
 num-queues 2
  queue 0 priority 0
  queue 1 priority 1 2 3 4 5 6 7
 num-queues 4
  queue 0 priority 0
  queue 1 priority 1 2
  queue 2 priority 3 4 5 6
  queue 3 priority 7
 num-queues 8
  queue 0 priority 0
  queue 1 priority 1
  queue 2 priority 2
  queue 3 priority 3
  queue 4 priority 4
  queue 5 priority 5
  queue 6 priority 6
  queue 7 priority 7
!
!
qos policy metering-pol metering
 access-group policy_acl local
 class browsers
  rate 100 burst 800
 class ftp-stuff
  rate 100 burst 800
 class unknown
  rate 100 burst 800
 class dscp_af12
  rate 100 burst 800
 class dscp_cs3
  rate 100 burst 800
 class tos_maxr
  rate 100 burst 800
 class tos_mind
  rate 100 burst 800
 class dscp_ef
  rate 100 burst 800
!
!
qos policy policing-pol policing
 ip access-group policy_acl local
  class browsers
   mark priority 1
  class ftp-stuff
   mark priority 0
  class unknown
   mark priority 3
  class dscp_af12
   mark priority 2
  class dscp_cs3
   mark priority 4
  class tos_maxr
   mark priority 5
  class tos_mind
   mark priority 6
  class dscp_ef
   mark priority 7
!
qos policy pwfq_policy pwfq
 rate maximum 1000
 queue 0 priority 0 weight 100
 queue 1 priority 1 weight 100
 queue 2 priority 2 weight 100
 queue 3 priority 3 weight 100
 queue 4 priority 4 weight 100
 queue 5 priority 5 weight 100
 queue 6 priority 6 weight 100
 queue 7 priority 7 weight 100
 queue priority-group 0 rate 500
 queue priority-group 1 rate 500
 queue priority-group 2 rate 500
 queue priority-group 3 rate 500
 queue priority-group 4 rate 500
 queue priority-group 5 rate 500
 queue priority-group 6 rate 500
 queue priority-group 7 rate 500
!
aps group aps1 pos
 architecture 1+1 bidirectional
!
link-group local-1 mp
 bind interface local-1 local
 mp endpoint-discriminator ip
 qos policy queuing pwfq_policy
!
link-group local-2 mp
 bind interface local-2 local
 mp endpoint-discriminator ip
 qos policy metering metering-pol
!
!
!
!
 system clock timezone PST -8 0 local
 system clock summer-time PST PDT recurring first Sunday 
    April 2 last Sunday October 2
!
!
!
card ch-oc3oc12-8or2-port 12
!
port channelized-oc3 12/2 pos
 no shutdown
 aps working aps1
 !
 port channelized-ds3 12/2:1
  no shutdown
  !
  port ds1 12/2:1:1
   no shutdown
   encapsulation ppp
   link-group local-1
  !
  port ds1 12/2:1:2
   no shutdown
   encapsulation ppp
   link-group local-1
  !
 port channelized-ds3 12/2:2
  no shutdown
  !
  port ds1 12/2:2:1
   no shutdown
   encapsulation ppp
   link-group local-2
  !
  port ds1 12/2:2:2
   no shutdown
   encapsulation ppp
   link-group local-2
!
!
port channelized-oc3 12/4 pos
 no shutdown
 aps protect aps1
 !
 ! ---- aps protect channel
 ! port channelized-ds3 12/4:1
 ! no shutdown
  !
  ! port ds1 12/4:1:1
  ! no shutdown
  !
  ! port ds1 12/4:1:2
  ! no shutdown
  !
 ! port channelized-ds3 12/4:2
 ! no shutdown
  !
  ! port ds1 12/4:2:1
  ! no shutdown
  !
  ! port ds1 12/4:2:2
  ! no shutdown
!
card ch-oc3oc12-8or2-port 13
!
card ge3-4-port 14
!
port ethernet 14/3
 no auto-negotiate
 no shutdown
 bind interface to-dest local
 qos policy policing policing-pol acl-counters
!
!
 no timeout session idle
!
service console-break
!
service crash-dump-dram
!
no service auto-system-recovery
!
!
no ipv6 path-mtu-discovery discovery-interval
!
end

4   Verification, Testing, and Status Reporting

4.1   Loopback Testing

The loopback tests that you can run on the Channelized OC-3/STM-1 or OC-12/STM-4 line card are described in the loopback (channels) command.

4.1.1   On Demand Diagnostics and Power-On Diagnostics Commands

See also the following:

4.1.2   Status Reporting Commands

4.1.3   Statistics Reporting Commands

4.1.4   SNMP for Channelized Card and Monitoring

The RBN-Product-MIB reports on the following object:

rbnEntModuleSE8OR2PORTCHOC3OC12 OBJECT-IDENTITY
STATUS current
DESCRIPTION
     "The definitive identifier for the Redback Networks
     channelized OCx/STMx to fractional T1/E1 card"
::= { rbnEntityTypeModule X }

Glossary

AUG
administrative unit group
 
Channel
A channel is a PDH structure that is mapped into a SONET VT or STS-1. A channel can be either “unchannelized”, in which case it carries the POS or CES data within it, or “channelized”, in which case it carries a lower order subchannel.
 
CES
Circuit Emulation Service, allows DS-n and E-n circuits to be transparently extended across a packet oriented network.
 
MLPPP
Multilink PPP
 
MP
Multilink PPP
 
PDH
Plesiochronous Digital Hierarchy
 
SAToP
Structure-Agnostic Time Division Multiplexing (TDM) over Packet
 
STS-1
Synchronous transport signal level 1.
 
TUG
tributary unit group
 
VT-1.5
Virtual tributary 1.5

Reference List

[1] Configuring Circuits for QoS, 53/1543-CRA 119 1170/1
[2] Configuring Queuing and Scheduling, 56/1543-CRA 119 1170/1-V1
[3] Configuring APS MSP, 13/1543-CRA 119 1170/1
[4] Configuring PPP and PPPoE, 64/1543-CRA 119 1170/1
[5] RFC 4553 Structure-Agnostic Time Division Multiplexing (TDM) over Packet (SAToP)
[6] RFC 5086 Structure-Aware TDM Circuit Emulation Service over Packet Switched Networks (CESoPSN)