SYSTEM ADMINISTRATOR GUIDE     21/1543-CRA 119 1170/1-V1 Uen B1    

Configuring IS-IS

© Ericsson AB 2009–2010. All rights reserved. No part of this document may be reproduced in any form without the written permission of the copyright owner.

Disclaimer

The contents of this document are subject to revision without notice due to continued progress in methodology, design and manufacturing. Ericsson shall have no liability for any error or damage of any kind resulting from the use of this document.

Trademark List

SmartEdge is a registered trademark of Telefonaktiebolaget LM Ericsson.
NetOp is a trademark of Telefonaktiebolaget LM Ericsson.

Contents

1Overview
1.1Supported IS-IS Features
1.2IS-IS Packets
1.3IS-IS Fast Convergence

2

Configuration and Operations Tasks
2.1Configuring an IS-IS Instance
2.2Configuring an IS-IS LSP
2.3Configuring IS-IS SPF Calculations
2.4Configuring an IS-IS Interface
2.5Configuring IS-IS Hello Packets
2.6Configuring IS-IS Interface LSPs
2.7Configuring IS-IS Interface Metrics
2.8IS-IS Operations

3

Configuration Examples
3.1Basic IS-IS
3.2Two Routers Using IS-IS for Routing Information Exchange
3.3IS-IS P2P-over-LAN Circuit
3.4Three Routers Using IS-IS for Routing Information Exchange
3.5Basic Multitopology IS-IS
3.6Example: Configure IS-IS Route Redistribution and Aggregation


1   Overview

This document provides an overview of Intermediate System-to-Intermediate System (IS-IS) routing, describes the tasks and commands used to configure, monitor, troubleshoot, and administer IS-IS features through the SmartEdge® router.

IS-IS is an Interior Gateway Protocol (IGP) that uses link-state information to make routing decisions.

IS-IS is defined in ISO 10589, Intermediate System to Intermediate System Intra-Domain Routing Exchange Protocol for Use in Conjunction with the Protocol for Providing the Connectionlessmode Network Service (ISO 8473), ISO DP 10589, February 1990, and RFC 1195, Use of OSI IS-IS for Routing in TCP/IP and Dual Environments.

1.1   Supported IS-IS Features

The SmartEdge router supports IS-IS as an IP routing protocol. The implementation also includes:

1.2   IS-IS Packets

IS-IS standards refer to packets as protocol data units (PDUs). IS-IS uses four types of PDUs to exchange routing information with neighbors:

See ISO 10589 for detailed definitions of and information about these PDU types.

1.3   IS-IS Fast Convergence

IS-IS fast convergence enables networks to offer high availability IP services to their customers by:

This fast response not only affects the local router that has the link status change, but also the entire IS-IS routing domain.

Fast convergence is enabled on all IS-IS interfaces by default. Use the no fast-convergence command in IS-IS configuration mode to disable fast convergence. The quick calculation of new routing information based on a network topology change minimizes data packet loss in the network. IS-IS fast convergence affects the entire IS-IS routing domain, along with the local router that has the status change.

Use fast-convergence command in IS-IS configuration mode to re-enable fast convergence on the interfaces in an IS-IS instance and configure the SPF delay (in milliseconds) and maximum SPF count.When fast convergence is enabled, the SPF delay and maximum SPF count are used within the window of time (in seconds) specified by SPF holddown interval. The receipt of a network event results in an SPF run at the SPF delay interval configured with the fast-convergence command.

When fast convergence is disabled, the holddown time is seconds long, and there is a delay between successive SPF calculations.

Using the fast-convergence command to configure a maximum SPF count to be greater than zero enables additional SPF calculations to be squeezed into the delay (holddown) window (specified by the spf holddown command). Configuring the maximum SPF count to be zero prevents additional SPF calculations and enables a delay between SPF scheduling and the next holddown window.

IS-IS fast convergence response is adaptive to the frequency of network events. It reacts quickly when there is a sudden network change, but it slows down when there are persistent topology changes to offer IS-IS routing stability.

Note:  
The SPF delay (in milliseconds) that is configured with the fast convergence command overrides the SPF delay interval (in seconds) that is set with the spf interval command.

2   Configuration and Operations Tasks

Note:  
In this section, the command syntax in the task tables displays only the root command.

To configure IS-IS, perform the tasks described in the sections that follow.

2.1   Configuring an IS-IS Instance

To configure an IS-IS instance, perform the tasks described in Table 1. Enter all commands in IS-IS router configuration mode, unless otherwise noted.

Table 1    Configure an IS-IS Instance

Task

Root Command

Notes

Create an IS-IS instance.

router isis

Enter this command in context configuration mode.


A context can have multiple IS-IS instances. No more than one instance of IS-IS can operate on a single interface.


The no router isis command removes the IS-IS instance and all related configuration settings, which is different from deleting the last network entity title (NET). Deleting the last NET disables the IS-IS instance while preserving all configuration information.

Enable graceful restart for an IS-IS instance.

graceful-restart

Replace the interval argument with the grace period, in seconds. During this time period, the IS-IS instance attempts to restart gracefully. The range of values is 10 to 900; the default value is 120.(1)(2)


IS-IS graceful restart must be enabled on the designated intermediate system (DIS) to be effective. If graceful restart is not enabled on the DIS, graceful restart does not work for any other routers on a LAN.

Define the NET for an IS-IS instance.

net

The network entity title (NET) defined for each IS-IS instance contains the IS-IS area information and the router ID information.

Enable only one IS-IS routing level.

is type

By default, both IS-IS routing levels, level-1 and level-2, are enabled.

Enable an address family for the IS-IS instance and access IS-IS address family configuration mode.

address-family (IS-IS)

The address-family command is used to configure multitopology IS-IS routing. The multitopology IS-IS feature can generate multiple address families (topologies) for IS-IS; for example, it can enable one for an IPv4 unicast network, one for an IPv4 multicast network, and one for an IPv6 unicast network. (3)


Before an interface can participate in the routing for an address family, that address family must be enabled at both the instance level and interface level.


If you do not want the IPv4 unicast address family enabled on an IS-IS instance (it is enabled by default), explicitly disable it using the no address-family command in IS-IS router configuration mode.

Enable the SmartEdge router to route IPv6 traffic if existing IPv6 IS-IS routers in the area are operating in single-topology mode.

multi-topology transition

Enter this command in IS-IS address family configuration mode. This command is relevant to IPv6 routing only. (4)

Enable the advertisement of short or wide metrics, and migration of existing traditional IS-IS networks, into the new scheme on a per-level basis.

metric-style

By default, IS-IS runs with wide metric styles enabled.


Use the wide keyword to set the metric style back to the default.


The wide-style metric can be enabled when traffic engineering capabilities or metrics longer than 63 are preferred. With the exception of devices in transition mode, all devices in the area must apply the same metric style; otherwise the IP topology becomes partitioned.

Redistribute IP routes learned through external route sources into the IS-IS routing instance.

redistribute (IS-IS)

IS-IS can import routes from one or more external route sources including OSPF, OSPFv3, RIP, BGP, STATIC, CONNECTED, and from other IS-IS instances. By default, the imported routes are redistributed into the level-2 routing process. The metrics of the external routes are set to zero if not specified. The metric type is internal if not specified as external.


Currently, this command is available only for IPv4 and IPv6 unicast address families.


See Example: Configure IS-IS Route Redistribution and Aggregation for an example of how to configure route redistribution and aggregation for an IS-IS instance.

Configure route leaking between levels.

interarea-distribute

Redistributing routes between the IS-IS levels is also called route leaking. Route leaking is automatically done from level-1 into level-2. The route leaking from level-2 into level-1 must be explicitly configured with a prefix-list. The leaked routes from level-2 into level-1 is possible in wide metric style only. Make sure all the routers in the level-1 area can process wide metric style.


Currently, this command is available only for IPv4 and IPv6 unicast address families.

Configure IS-IS authentication at the IS-IS instance level.

authentication (IS-IS)

IS-IS authentication is used to check authentication information on incoming IS-IS packets, or to attach authentication information to outgoing packets. There are two types of IS-IS authentication, simple and HMAC-MD5. HMAC-MD5 is more secure and we highly recommend it. Authentication can be configured at the IS-IS router configuration mode level, or at the interface configuration mode level. The interface authentication settings overwrite the router authentication settings for the IS-IS interface-related PDUs on that interface.


Authentication at the IS-IS instance level controls the authentication scheme for the entire IS-IS instance on the router.


Careful planning is necessary to ensure a smooth rollout of IS-IS authentication across a network. Use a secure channel to configure the passwords. We recommend that you choose HMAC-MD5 because it is highly secure.

Specify multiple summary addresses.

summary-address (IS-IS)

IS-IS summary addresses can be used at the redistribution boundary to reduce routing information in the destination IS-IS domain or area. This redistribution boundary includes redistribution of external routes or between IS-IS levels. By default, the summary address is applied to the level-2 domain only.


Currently, this command is available only for IPv4 and IPv6 unicast address families.

Change the IS-IS distance.

distance (IS-IS)

The distance is used to specify a routing source preference. IS-IS uses the default distance of 115.

Configure a dynamic hostname for an IS-IS instance.

dynamic-hostname

Unless you use this command to specify a different hostname, the hostname of the IS-IS instance is the name specified through the system hostname command in global configuration mode.

Enable MPLS traffic engineering within IS-IS routing.

traffic-engineering

Enabling traffic engineering allows IS-IS LSPs to carry traffic engineering information on IS-IS interfaces, and can be enabled on either IS-IS level-1, level-2, or both level-1 and level-2 routing.


Resource Reservation Protocol (RSVP) must be configured on the interface for IS-IS traffic engineering information to be included in its LSP for the link.


An IS-IS metric style of wide or transition must be used for traffic engineering to take effect.


The global router-id command in context configuration mode must be configured for the IS-IS LSP to carry the specified IP address of the router ID interface.

Configure the IS-IS attached bit preferences in L1 LSPs.

attached-bit

Routers in an IS-IS L1 area exchange information within the L1 area. For IP destinations not found in the prefixes in the L1 database, the L1 router must forward packets to the nearest router that is in both IS-IS L1 and L2 with the attached bit set in its L1 LSP.

Change the router’s default number of multiple equal-cost IS-IS paths for load balancing of outgoing traffic packets.

maximum paths (IS-IS)

The SmartEdge router load balances among the number of paths you specify with the paths argument if, in the routing table, they are the best paths among paths provided by all running routing protocols.

Limit the number of routes that can be redistributed into the IS-IS instance you are configuring.

maximum redistribute (IS-IS)

If the maximum number of redistributed prefixes is reached, IS-IS stops redistributing external routes for the duration specified by the retry-interval interval construct.

Set the overload bit so that other devices do not use the SmartEdge router to forward traffic.

set-overload-bit

Other routers can still forward traffic to IP networks advertised by the SmartEdge router.

Optional. Re-enable fast convergence and schedule SPF calculations in response to network events in an IS-IS instance.

[no] fast-convergence [spf-delay-interval max-spf-count]

Be aware that fast convergence is enabled on all IS-IS interfaces by default. Use the no fast-convergence command to disable fast convergence on all IS-IS interfaces.


Use the optional spf-delay-interval argument to modify the number of milliseconds that pass between the receipt of a topology change and the start of the SPF calculation. Valid values are 0 to 999 milliseconds; the default value is 100.


Use the optional max-spf-count argument to modify the desired maximum number of additional SPF calculations allowed during the SPF hold time. Valid values are 0 to 15; the default value is 3.

Enable LDP IGP synchronization between IS IS and OSPF.

ldp-igp-synchronization

If an interruption in an LSP occurs, the IGP advertises the maximum routing metric for the link until it detects that LDP has converged. After the LSP is established, the IGP advertises the configured metric for the link and the LDP and IGP are considered synchronized.

Configure an IS-IS LSP.

For the complete list of tasks used to configure IS-IS LSP, see Configuring an IS-IS LSP.

Configure IS-IS SPF calculations.

For the complete list of tasks used to configure IS-IS SPF calculations, see Configuring IS-IS SPF Calculations.

(1)  Graceful restart is enabled on IS-IS instances by default.

(2)  Helper mode is automatically enabled when you enable graceful restart for an IS-IS instance. An IS-IS instance enters into helper mode when it receives a restart request from a restarting IS-IS instance. The IS-IS instance exits helper mode when it receives a restarting-clear message from the restarting IS-IS instance.

(3)  The SmartEdge router supports IPv6 IS-IS routing in multitopology mode only.

(4)  The SmartEdge router supports IPv6 IS-IS routing in multitopology mode only.


2.2   Configuring an IS-IS LSP

To configure an IS-IS LSP, perform the tasks described in Table 2. Enter all commands in IS-IS router configuration mode.

Table 2    Configure an IS-IS LSP

Task

Root Command

Notes

Modify the length of time that IS-IS LSPs can live before timing out.

lsp max-lifetime

In the case of large networks, use this command in conjunction with the lsp refresh-interval command in IS-IS router configuration mode. Longer-lived LSPs allow for less flooding and higher stability.


The value set by the lsp max-lifetime command should be at least 60 seconds longer than the value set through the lsp refresh-interval command, and should also be longer than the value set through the lsp gen-interval command.

Control how frequently an LSP can be regenerated for the IS-IS instance.

lsp refresh-interval

In the case of large networks, use this command in conjunction with the lsp max-lifetime command in IS-IS router configuration mode. Longer-lived LSPs allow for less flooding and higher stability. This value should be at least 60 seconds less than the value set through the lsp max-lifetime command, and should also be less than the value set through the lsp gen-interval command. This LSP refresh interval also determines the IS-IS periodical Shortest Path First (SPF) calculations on the system.

Control how frequently an LSP can be regenerated with new content.

lsp gen-interval

Decreasing the frequency at which an LSP can be regenerated with new content can stabilize a network at the cost of slower convergence. New versions of LSPs with updated content are generated less often and produce less load on the network than the load caused by flooding and route recomputation. Typically, the value set by the lsp gen-interval command should be lower than the values set through the lsp max-lifetime and lsp refresh-interval commands in IS-IS router configuration mode.

2.3   Configuring IS-IS SPF Calculations

To configure IS-IS SPF calculations when fast convergence is not enabled, perform the tasks described in Table 3. Enter all commands in IS-IS router configuration mode.

Table 3    Configure IS-IS SPF Calculations

Task

Root Command

Notes

Modify the delay time between an event that triggers an SPF calculation and the calculation itself.

spf holddown

The purpose of the delay is to prevent immediate successive recalculations when computation triggers, such as new LSPs, occur in bursts as they often do. Because SPF calculations are performed when the topology changes, increasing this value offloads the processor, especially in large topologies, but slows down the convergence of the network.

Configure the minimum interval between SPF calculations.

spf interval

Increasing this value also offloads the processor, especially in large topologies, but slows down the convergence of the network.


Be aware that, if fast convergence is enabled, the SPF delay interval that is configured with the fast convergence command overrides the SPF delay interval that is set with the spf interval command.

2.4   Configuring an IS-IS Interface

To configure an IS-IS interface, perform the tasks described in Table 4. Enter all commands in IS-IS interface configuration mode, unless otherwise noted.

Table 4    Configure an IS-IS Interface

Task

Root Command

Notes

Enable IS-IS routing on the interface, and access IS-IS interface configuration mode.

interface (IS-IS)

Enter this command in IS-IS router configuration mode.


Only one IS-IS instance can be running on an interface.

Enable an address family for the IS-IS interface and access IS-IS interface address family configuration mode.

address-family (IS-IS)

The address-family command is used to configure multitopology IS-IS routing. The multitopology IS-IS feature can generate multiple address families (topologies) for IS-IS; for example, it can enable one for an IPv4 unicast network, one for an IPv4 multicast network, and one for an IPv6 unicast network. (1)


Before an interface can participate in the routing for an address family, that address family must be enabled at both the instance level and interface level.


If you do not want the IPv4 unicast address family enabled on an IS-IS instance (it is enabled by default), explicitly disable it using the no address-family command in IS-IS router configuration mode.

Configure the IS-IS interface maximum transmit unit (MTU) size independent of the IP interface MTU size.

circuit mtu

Configure the type of IS-IS circuit on the interface.

circuit type

Configure the interval at which CSNPs are sent over the interface.

csnp interval

CSNPs contain a list of all LSPs in the database. An IS-IS system receiving CSNPs can compare this information with its own LSP database to determine whether it and the CSNP transmitter have synchronized LSP databases.


CSNP packets are sent over LAN interfaces every 10 seconds unless you use this command to modify the interval. A shorter interval allows faster convergence; however, it increases bandwidth and CPU usage, and might add to instability in the network. In addition to saving bandwidth and CPU usage, a longer interval can increase overall network stability.

Enable periodic CSNPs to be sent on a P2P interface.

csnp periodic-on-ptp

Sending periodic CSNPs on point-to-point interfaces can increase the stability of the network, especially when flooding topology has been heavily pruned.

Disable Bidirectional Forwarding Detection (BFD) for the IS-IS interface.

disable-bfd (IS-IS)

Enable optional IS-IS checksums on the interface.

optional-checksums

Configure IS-IS instance to advertise the interface’s IP addresses without actively running IS-IS on the interface (IS-IS passive mode).

passive-interface

When an IS-IS interface is configured in passive mode, IS-IS packets are sent and no adjacency is formed on the interface. IS-IS advertises the interface’s IP address in its LSPs.

Configure the IS-IS designated router priority setting for the specified LAN interface.

priority (IS-IS)

A priority value determines which router on a network is the first router chosen for sending and receiving traffic. The priority value is advertised in Hello packets. The router with the highest priority becomes the Designated Intermediate System (DIS).


In IS-IS, there is no backup designated router. If a router is set to priority 0, it has a smaller chance of becoming the DIS, but it may not be prevented from becoming the DIS. When a router with a higher priority becomes available on the network, it takes over as the current DIS. In the case of equal priorities, the highest medium access control (MAC) address breaks the tie.

Configure IS-IS Hello packets.

For the complete list of tasks used to configure IS-IS Hello packets, see Configuring IS-IS Hello Packets.

Configure IS-IS interface LSPs.

For the complete list of tasks used to configure IS-IS interface LSPs, see Configuring IS-IS Interface LSPs.

Configure IS-IS interface metrics.

For the complete list of tasks used to configure IS-IS interface metrics, see Configuring IS-IS Interface Metrics.

(1)  The SmartEdge router supports IPv6 IS-IS routing in multitopology mode only.


2.5   Configuring IS-IS Hello Packets

To configure IS-IS Hello packets, perform the tasks described in Table 5. Enter all commands in IS-IS interface configuration mode.

Table 5    Configure IS-IS Hello Packets

Task

Root Command

Notes

Configure the size of IS-IS Hello packets sent via the interface.

hello padding

Modify the interval at which IS-IS Hello packets are sent via the interface.

hello interval (IS-IS)

A shorter interval allows faster convergence; however, it increases bandwidth and CPU usage, and might add to instability in the network. In addition to saving bandwidth and CPU usage, a longer interval, especially when used in conjunction with a higher Hello multiplier can increase overall network stability.


You can configure the Hello interval independently for level-1 and level-2, except on serial point-to-point (P2P) interfaces. Tuning the Hello interval and Hello multiplier on point-to-point interfaces is more useful than on LAN interfaces.


Under link flapping, network churn, or heavy traffic congestion can cause Hello packet transmission or processing to be delayed, or packets to be dropped. Setting the Hello hold time too low can cause IS-IS adjacencies to flap, which can cause network instability. Use the millisecond or adaptive-millisecond keyword only on some P2P interfaces where the fast detection of lost adjacencies is required.

Determine how many IS-IS Hello packets can be missed by a neighbor before the SmartEdge router declares that the adjacency is down.

hello multiplier

The advertised holdtime in IS-IS Hello packets is the value of the multiplier argument multiplied by the value of the seconds argument set through the isis hello interval command in interface configuration mode. The advertised holdtime is also known as the IS-IS router dead interval.


The Hello multiplier can be configured independently for level 1 and level 2, except on serial P2P interfaces. The level-1 and level-2 keywords are used on multiaccess networks or LAN interfaces. The Hello multiplier and the Hello interval can be different between different devices in one area.

2.6   Configuring IS-IS Interface LSPs

To configure an IS-IS instance, perform the tasks described in Table 6. Enter all commands in IS-IS interface configuration mode.

Table 6    Configure IS-IS Interface LSPs

Task

Root Command

Notes

Control the pace at which LSPs are flooded on the interface to IS-IS neighbors.

lsp interval

In dense-meshed IS-IS network topologies with a large number of devices and IS-IS neighbors, LSP flooding is the key scaling factor. Ensure that devices are not overloaded by LSPs from neighbors.

Prevent LSPs from being flooded on the interface.

lsp block-flooding

This command is typically used for point-to-point IS-IS interfaces. When a network topology has many redundant connections among IS-IS devices, LSPs can be flooded excessively inside the network, costing extra CPU cycles and bandwidth consumption. This feature is especially useful in a large, fully meshed IS-IS topology.

Configure how long the system should wait for an acknowledgment from the neighbor before sending an IS-IS LSP.

capabilities

The number of seconds should be greater than the expected round-trip delay between any two devices on the attached network. This command has no effect on LAN interfaces. On P2P links, the interval argument can be increased to enhance network stability. The retransmission interval can be larger for serial lines. More neighbors and paths over which LSPs are flooded allow for a longer interval.

Prevent the specified interface from forwarding LSPs.

lsp receive-only-mode

This command is used for internal lab test situations only and is relevant only for a stub IS-IS area where the goal is to import the network routing information from the operational network without exporting lab environment routing information into the operational network. After enabling IS-IS on an interface using the interface command in IS-IS router configuration mode, a delay in entering the lsp receive-only-mode command can result in lab routing information leaking into the operational network. To reduce the risk, immediately enter the lsp receive-only-mode command after enabling IS-IS on an interface using the interface command in IS-IS router configuration mode.

2.7   Configuring IS-IS Interface Metrics

To configure IS-IS interface metrics, perform the tasks described in Table 7.

Table 7    Configure IS-IS Interface Metrics

Task

Root Command

Notes

Access IS-IS interface configuration mode.

interface (IS-IS)

Enter this command in IS-IS router configuration mode.

Enable an address family for the IS-IS interface and access IS-IS interface address family configuration mode.

address-family (IS-IS)

Configure the IS-IS interface metric for a specific address family.

metric

Metric values are determined by circuit distance, load-sharing requirements, and other traffic engineering factors.


Range of values is 1 to 63 for narrow-style metrics, and 0 to 16,777,215 for wide-style metrics; the default value is 10.

2.8   IS-IS Operations

To manage IS-IS functions, perform the appropriate tasks described in Table 8. Enter the show commands in any mode; enter the clear, debug, monitor, and protocol trigger commands in exec mode.

Table 8    IS-IS Operations Tasks

Task

Root Command

Reset the IS-IS Hello hold time to the original value on the interface.

clear isis adaptive-holdtime

Reset IS-IS adjacencies with neighbors.

clear isis adjacency

Clear all IS-IS adjacencies and recalculate the routes for an IS-IS instance.

clear isis instance

Clear IS-IS logs.

clear isis log

Clear existing routes from the IS-IS routing table and repopulate the table with updated route information.

clear isis routes

Clear IS-IS statistics.

clear isis statistics

Enable the generation of IS-IS adjacency debug messages.

debug isis adjacency

Enables the generation of all IS-IS debug messages.

debug isis all

Enables the generation of IS-IS Bidirectional Forwarding Detection (BFD) event debug messages.

debug isis bfd

Enable the generation of IS-IS circuit debug messages.

debug isis circuit

Enable the generation of IS-IS Hello packet debug messages.

debug isis hello-packets

Enable the generation of IS-IS locally generated link-state protocol data unit (LSP) event debug messages.

debug isis local-updates

Enable the generation of IS-IS LSP debug messages.

debug isis lsp-packets

Enable the generation of IS-IS routing policy debug messages.

debug isis policy

Enable the generation of debug messages related to incorrectly formatted or corrupted IS-IS packets.

debug isis protocol-errors

Enable the generation of debug messages for events relating to interaction between the Routing Information Base (RIB) and IS-IS.

debug isis routes

Enable the generation of debug messages related to IS-IS complete sequence number protocol data units (CSNPs) and partial sequence number protocol data units (PSNPs).

debug isis snp-packets

Enable the generation of debug messages for events related to SPF computation within IS-IS.

debug isis spf-events

Enable the generation of debug messages for events related to the causes of triggered SPF runs within IS-IS.

debug isis spf-triggers

Display continuously updated information about IS-IS neighbors.

monitor isis adjacency

Display continuously updated information about IS-IS interfaces.

monitor isis interfaces

Display continuously updated information about IS-IS traffic statistics.

monitor isis statistics

Stop the IS-IS process for a brief period without affecting IP forwarding in the network, enabling the system to prepare information about IS-IS operations up to that point.

protocol maintenance isis

Force IS-IS CSNPs to be sent out through all interfaces or through a particular interface.

protocol trigger isis csnp

Force an IS-IS Hello packet to be sent out through a particular interface or out through all interfaces.

protocol trigger isis hello

Force an IS-IS LSP to be sent out a particular interface or out all interfaces.

protocol trigger isis lsp

Force IS-IS PSNPs to be sent out through all interfaces or through a particular interface.

protocol trigger isis psnp

Force an IS-IS Shortest Path First (SPF) calculation to run immediately instead of waiting for the next interval.

protocol trigger isis spf

Display the current IS-IS configuration for the current context.

show configuration isis

Display information about IS-IS neighbors.

show isis adjacency

Display adjacency logs.

show isis adj-log

Display information about the IS-IS link-state database.

show isis database

Display enabled IS-IS debug settings.

show isis debug-setting

Display IS-IS dynamic hostname and system ID mapping.

show isis dynamic-hostname

Display information about IS-IS interfaces.

show isis interfaces

Display IS-IS protocol summary information.

show isis protocol-summary

Display IS-IS routes.

show isis routes

Display a history of the IS-IS SPF calculation results.

show isis spf-log

Display IS-IS traffic information.

show isis statistics

Display information about IS-IS IP summary addresses.

show isis summary-address

Display IS-IS topology information.

show isis topology

3   Configuration Examples

This section provides examples of IS-IS configurations.

3.1   Basic IS-IS

For IS-IS to work, you must configure one or more IS-IS instances in context configuration mode, and enable IS-IS for the interface. Although multiple instances can be configured in a context, only one can be enabled per interface. Use the router isis command in context configuration mode to create an IS-IS instance and enter IS-IS router configuration mode where you can configure parameters for the instance. Use the isis router command in interface configuration mode to enable a specific IS-IS instance for the interface. In order for IS-IS to exchange routing information with other routers, you must also assign a network entity title (NET).

The implementation of IS-IS supported by the SmartEdge router starts only on demand. One of two triggers starts IS-IS: the router isis instance command in context configuration mode, or the isis router instance command in interface configuration mode.

The following example illustrates a basic IS-IS configuration on a SmartEdge router. In this configuration, IS-IS is running in the local context with a single instance. The NET assigned to the router is 47.0001.1111.2222.3333.00. The 1111.2222.3333 portion is the system ID of the router, and it has to be unique within the entire IS-IS domain or area. The Ethernet interface, first-isis-intf, is configured to run the IS-IS instance, my-backbone. An IP address has to be assigned on the interface or an unnumbered interface is used:

[local]Redback(config)#context local 



[local]Redback(config-ctx)#interface first-isis-intf 

[local]Redback(config-if)#ip address 10.1.1.1/24 

[local]Redback(config)#exit



[local]Redback(config-ctx)#router isis my-backbone 

[local]Redback(config-isis)#net 47.0001.1111.2222.3333.00 

[local]Redback(config-isis)#interface first-isis-intf

[local]Redback(config-isis-if)#exit

[local]Redback(config-isis)#exit

[local]Redback(config-ctx)#exit



[local]Redback(config)#port ethernet 14/2 

[local]Redback(config-port)#no shutdown 

[local]Redback(config-port)#bind interface first-isis-intf local 

3.2   Two Routers Using IS-IS for Routing Information Exchange

The following example illustrates two routers configuring IS-IS for routing information exchange; Figure 1 shows the topology.

Figure 1   Two Routers Exchanging Routing Information

In this example, router A and router B have an Ethernet connection to one another. Both routers run IS-IS level-1 routing and exchange route information with each other. Router A learns router B’s loopback address of 192.168.1.200/32, and router B learns router A’s loopback address of 192.168.1.100/32. Two different mechanisms are used to export each router’s internal IP routes to its neighbors. Router A configures the IS-IS passive-interface to export the prefix 192.168.1.100/32; router B uses the redistribution of connected routes method to export prefix 192.168.1.200/32.

The configuration for Router_A is as follows:

[local]Router_A(config)#context local

[local]Router_A(config-ctx)#interface router-A-id loopback

[local]Router_A(config-if)#ip address 192.168.1.100/32

[local]Router_A(config-if)#exit



[local]Router_A(config-ctx)#interface first-isis-intf

[local]Router_A(config-if)#ip address 10.1.1.1/24

[local]Router_A(config-if)#exit



[local]Router_A(config-ctx)#router isis my-backbone

[local]Router_A(config-isis)#net 47.0001.1111.2222.3333.00

[local]Router_A(config-isis)#is type level-1



[local]Router_A(config-isis)#interface router-A-id

[local]Router_A(config-isis-if)#passive-interface

[local]Router_A(config-isis-if)#exit

[local]Router_A(config-isis)#interface first-isis-intf

[local]Router_A(config-isis-if)#exit

[local]Router_A(config-isis)#exit

[local]Router_A(config-ctx)#exit

[local]Router_A(config)#



[local]Router_A(config)#port ethernet 14/2

[local]Router_A(config-port)#no shutdown

[local]Router_A(config-port)#bind interface first-isis-intf local

The configuration for Router_B is as follows:

[local]Router_B(config)#context local

[local]Router_B(config-ctx)#interface router-B-id loopback

[local]Router_B(config-if)#ip address 192.168.1.200/32

[local]Router_B(config-if)#exit



[local]Router_B(config-ctx)#interface eth-10-1

[local]Router_B(config-if)#ip address 10.1.1.2/24

[local]Router_B(config-if)#exit



[local]Router_B(config-ctx)#router isis my-backbone

[local]Router_B(config-isis)#net 47.0001.0001.0002.0003.00

[local]Router_B(config-isis)#is type level-1

[local]Router_B(config-isis)#address-family ipv4 unicast

[local]Router_B(config-isis-af)#redistribute connected level-1

[local]Router_B(config-isis-af)#exit



[local]Router_B(config-isis)#interface router-B-id

[local]Router_B(config-isis-if)#passive-interface

[local]Router_B(config-isis-if)#exit

[local]Router_B(config-isis)#interface eth-10-1

[local]Router_B(config-isis-if)#exit

[local]Router_B(config-isis)#exit

[local]Router_B(config-ctx)#exit

[local]Router_B(config)#



[local]Router_B(config)#port ethernet 10/1

[local]Router_B(config-port)#no shutdown

[local]Router_B(config-port)#bind interface eth-10-1 local

3.3   IS-IS P2P-over-LAN Circuit

The following example configures an IS-IS point-to-point over LAN (P2P-over-LAN) circuit with an unnumbered interface. For detailed information about P2P-over-LAN, see the Internet Draft, draft-shen-isis-ospf-p2p-over-lan-01.txt:

The following example configures an IS-IS point-to-point over LAN (P2P-over-LAN) circuit with an unnumbered interface. For detailed information about P2P-over-LAN, see RFC 5309, Point-to-Point Operation over LAN in Link State Routing Protocols:

[local]Redback(config)#context local

[local]Redback(config-ctx)#interface lo0 loopback

[local]Redback(config-if)#ip address 10.1.1.1/32

[local]Redback(config-if)#exit

[local]Redback(config-ctx)#interface to-core2 p2p

[local]Redback(config-if)#ip unnumbered lo0

[local]Redback(config-if)#exit



[local]Redback(config-ctx)#router isis my-backbone

[local]Redback(config-isis)#net 47.0001.1111.2222.3333.00

[local]Redback(config-isis)#interface to-core2

[local]Redback(config-isis-if)#exit

[local]Redback(config-isis)#exit

[local]Redback(config-ctx)#exit



[local]Redback(config)#port ethernet 14/2

[local]Redback(config-port)#no shutdown

[local]Redback(config-port)#bind interface to-core2 local

[local]Redback(config-port)#exit

3.4   Three Routers Using IS-IS for Routing Information Exchange

The following example has three routers using IS-IS for routing information exchange; Figure 2 shows the topology.

Figure 2   Three Routers Exchanging Routing Information

Router A and router B are in the same Point of Presence (PoP). Router B is a backbone router connected to remote backbone router C. Router A is an edge router running two IS-IS instances and redistributes routes from one IS-IS instance to the other. Router B leaks level-2 routes into the level-1 area.

The configuration for Router_A is as follows:

[local]Router_A#configure

[local]Router_A(config)#context local

[local]Router_A(config-ctx)#interface toCoreRouter

[local]Router_A(config-if)#ip address 10.1.1.1/24

[local]Router_A(config-if)#exit

[local]Router_A(config-ctx)#interface toSubArea

[local]Router_A(config-if)#ip address 10.3.1.1/24

[local]Router_A(config-if)#exit



[local]Router_A(config-ctx)#router isis edge

[local]Router_A(config-isis)#is type level-1

[local]Router_A(config-isis)#net 47.0001.1111.2222.3333.00

[local]Router_A(config-isis)#authentication key-chain keys type hmac-md5

[local]Router_A(config-isis)#address-family ipv4 unicast

[local]Router_A(config-isis-af)#redistribute isis subArea level-1
route-map rtMap1

[local]Router_A(config-isis-af)#exit

[local]Router_A(config-isis)#interface toCoreRouter

[local]Router_A(config-isis-if)#exit

[local]Router_A(config-isis)#exit



[local]Router_A(config-ctx)#router isis subArea 

[local]Router_A(config-isis)#is type level-1

[local]Router_A(config-isis)#net 47.0003.1000.2000.3000.00

[local]Router_A(config-isis)#interface toSubArea

[local]Router_A(config-isis-if)#exit

[local]Router_A(config-isis)#exit



[local]Router_A(config-ctx)#ip prefix-list prefixList

[local]Router_A(config-prefix-list)#permit 200.0.0.0/8 le 32

[local]Router_A(config-prefix-list)#permit 100.16.1.0/24 le 32

[local]Router_A(config-ctx)#key-chain keys key-id 1

[local]Router_A(config-key-chain)#key-string monday

[local]Router_A(config-key-chain)#exit

[local]Router_A(config-ctx)#route-map rtMap1 permit 10

[local]Router_A(config-route-map)#match ip address prefix-list prefixList

[local]Router_A(config-route-map)#set metric 4

[local]Router_A(config-route-map)#exit

[local]Router_A(config-ctx)#exit

[local]Router_A(config)#port ethernet 12/1

[local]Router_A(config-port)#no shutdown

[local]Router_A(config-port)#bind interface toCoreRouter local

[local]Router_A(config-port)#exit

[local]Router_A(config)#port ethernet 10/3

[local]Router_A(config-port)#no shutdown

[local]Router_A(config-port)#bind interface toSubArea local

[local]Router_A(config-port)#exit

[local]Router_A(config)#exit

The configuration for Router_B is as follows:

[local]Router_B#configure

[local]Router_B(config)#context local

[local]Router_B(config-ctx)#interface toBackbone

[local]Router_B(config-if)#ip address 10.2.1.1/30

[local]Router_B(config-if)#exit

[local]Router_B(config-ctx)#interface toEdge

[local]Router_B(config-if)#ip address 10.1.1.2/24

[local]Router_B(config-if)#exit



[local]Router_B(config-ctx)#router isis core

[local]Router_B(config-isis)#is type level-1

[local]Router_B(config-isis)#net 47.0001.0001.0002.0003.00

[local]Router_B(config-isis)#authentication key-chain keys type hmac-md5

[local]Router_B(config-isis)#address-family ipv4 unicast

[local]Router_B(config-isis-af)#interarea-distribute l2-to-l1
prefix-list prefixList

[local]Router_B(config-isis-af)#exit

[local]Router_B(config-isis)#interface toBackbone

[local]Router_B(config-isis-if)#circuit type level-2-only

[local]Router_B(config-isis-if)#exit

[local]Router_B(config-isis)#interface toEdge

[local]Router_B(config-isis-if)#circuit type level-1

[local]Router_B(config-isis-if)#exit

[local]Router_B(config-isis)#exit



[local]Router_B(config-ctx)#ip prefix-list prefixList

[local]Router_B(config-prefix-list)#permit 100.0.0.0/8 le 32

[local]Router_B(config-prefix-list)#permit 150.16.1.0/16 le 32

[local]Router_B(config-ctx)#key-chain keys key-id 1

[local]Router_B(config-key-chain)#key-string monday

[local]Router_B(config-key-chain)#exit

[local]Router_B(config-ctx)#exit

[local]Router_B(config)#port ethernet 12/1

[local]Router_B(config-port)#no shutdown

[local]Router_B(config-port)#bind interface toEdge local

[local]Router_B(config-port)#exit

[local]Router_B(config)#port pos 1/1

[local]Router_B(config-port)#no shutdown

[local]Router_B(config-port)#bind interface toBackbone local

[local]Router_B(config-port)#exit

[local]Router_B(config)#exit

The configuration for Router_C is as follows:

[local]Router_C#configure

[local]Router_C(config)#context local

[local]Router_C(config-ctx)#interface toPop

[local]Router_C(config-if)#ip address 10.2.1.2/30

[local]Router_C(config-if)#exit

[local]Router_C(config-ctx)#interface toSanFrancisco

[local]Router_C(config-if)#ip address 10.5.1.2/30

[local]Router_C(config-if)#exit



[local]Router_C(config-ctx)#router isis backbone

[local]Router_C(config-isis)#is type level-2-only

[local]Router_C(config-isis)#net 49.0002.1234.aaaa.bbbb.00

[local]Router_C(config-isis)#authentication key-chain keys type hmac-md5

[local]Router_C(config-isis)#interface toPop

[local]Router_C(config-isis-if)#exit

[local]Router_C(config-isis)#interface toSanFrancisco

[local]Router_C(config-isis-if)#exit

[local]Router_C(config-isis)#exit



[local]Router_C(config-ctx)#ip prefix-list prefixList

[local]Router_C(config-prefix-list)#permit 100.0.0.0/8 le 32

[local]Router_C(config-prefix-list)#permit 150.16.1.0/16 le 32

[local]Router_C(config-ctx)#key-chain keys key-id 1

[local]Router_C(config-key-chain)#key-string monday

[local]Router_C(config-key-chain)#exit

[local]Router_C(config-ctx)#exit

[local]Router_C(config)#port pos 5/2

[local]Router_C(config-port)#no shutdown

[local]Router_C(config-port)#bind interface toPop local

[local]Router_C(config-port)#exit

[local]Router_C(config)#port pos 9/2

[local]Router_C(config-port)#no shutdown

[local]Router_C(config-port)#bind interface toSanFrancisco local

[local]Router_C(config-port)#exit

[local]Router_C(config)#exit

3.5   Basic Multitopology IS-IS

The following example enables the IPv4 unicast and IPv4 multicast address families in the IS-IS instance isis1, enables the IPv4 unicast and IPv4 multicast address families on the fa4/1 interface, enables the IPv4 unicast address family only on the fa4/2 interface, and enables IPv4 multicast only on the fa4/3 interface:

[local]Redback(config-ctx)#router isis isis1

[local]Redback(config-isis)#address-family ipv4 unicast

[local]Redback(config-isis-af)#exit

[local]Redback(config-isis)#address-family ipv4 multicast

[local]Redback(config-isis-af)#exit

[local]Redback(config-isis)#interface fa4/1

[local]Redback(config-isis-if)#address-family ipv4 unicast

[local]Redback(config-isis-if-af)#exit

[local]Redback(config-isis-if)#address-family ipv4 multicast

[local]Redback(config-isis-if-af)#exit

[local]Redback(config-isis-if)#exit

[local]Redback(config-isis)#interface fa4/2

[local]Redback(config-isis-if)#address-family ipv4 unicast

[local]Redback(config-isis-if-af)#exit

[local]Redback(config-isis-if)#exit

[local]Redback(config-isis)#interface fa4/3

[local]Redback(config-isis-if)#no address-family ipv4 unicast

[local]Redback(config-isis-if)#address-family ipv4 multicast

[local]Redback(config-isis-if-af)#exit

[local]Redback(config-isis-if)#exit

3.6   Example: Configure IS-IS Route Redistribution and Aggregation

The following example configures route redistribution and aggregation for an IS-IS routing instance. First, configure a list of aggregate IP prefixes:

[local]Router(config-ctx)#ipv6 prefix-list test1-aggregate
[local]Router(config-ipv6-prefix-list)#seq 10 permit 4001:101:101:106::/64 ge 64
[local]Router(config-ipv6-prefix-list)#seq 20 permit 5001:101:101:106::/64 ge 64
[local]Router(config-ipv6-prefix-list)#seq 30 permit 6001:101:101:106::/64 ge 64
[local]Router(config-ipv6-prefix-list)#seq 40 permit 7001:101:101:106::/64 ge 64
[local]Router(config-ipv6-prefix-list)#seq 50 permit 2001:101:101::/48 ge 48

Next, configure a route map called test1 that aggregates the IPv6 prefixes in the aggregate prefix list called test1-aggregate:

[local]Router(config-ctx)#route-map test1 permit 10
[local]Router(config-route-map)#match ipv6 address prefix-list test1-aggregate
[local]Router(config-route-map)#set ipv6 aggregate test1-aggregate

Specify that routes selected for redistribution are summarized only if they contain any of the prefixes specified in the IPv6 prefix list called test1:

[local]Redback(config-ctx)#router isis 1
[local]Redback(config-isis)#address-family ipv6 unicast
[local]Redback(config-isis-af)#redistribute subscriber static route-map test1

Configure the static routes. In this example, the routes match the aggregate prefix 2001:101:101::/48:

[local]Redback(config-ctx)#ipv6 route 2001:101:101:303::/64 80::2
[local]Redback(config-ctx)#ipv6 route 2001:101:101:304::/64 80::2
[local]Redback(config-ctx)#ipv6 route 2001:101:101:305::/64 80::2
[local]Redback(config-ctx)#ipv6 route 2001:101:101:306::/64 80::2
[local]Redback(config-ctx)#ipv6 route 2001:101:101:307::/64 80::2
Note:  
When an IP prefix list is used for aggregation, the ge and le parameters (configured with the seq command) are ignored and the prefix list entries match any route subsumed by the prefix. In such cases, the ge parameter is implicit.